USB install, falling at last hurdle

I have managed to get my USB key to boot the mini-ISO (i586-NET).
I can get as far as the initialise set up. It accepts when I point to the ISO on the hard drive, and proceeds to ask my language and keyboard, and continues with “system analysis”. It gets to the last stage “Initialise Package Manager”, and then YAST reports:

Unable to create repository
From: xxxxx (path)

details: failed to mount xxxxxxxxx (path)

can’t find valid meta-data at xxxxx (path)

I have tried telling it where to find the ISO (even though it accepted it at the very start) in various ways, but no good. How do I get over this last hurdle in to Linuxland…?
Do I have to strip/expand the ISO?
If so where do I point YAST to when I have done it?
Surely I can use the packed ISO as a repository?

Truly driving me insane now.
I have got to the failure page and tried pointing to
AS Auto, NTFS, NTFS-3g, ISO-9660 filesstems
All these with various attempts in “name of repo”
I have tried Upper case and lower case
I have tried with trailing slashes and without
I have extracted the ISO and tried all of the above pointing to
and any and all combo’s, all four filesystems

All I get is “no valid metadata”, “repo type cannot be determined”
I have tried editing in CONFIG before set up starts…

I am starting to hate Linux, computers and life in general>:(>:(>:(>:

After many more wasted hours I am still at the same point >:)>:)>:)>:)

At the end of the system analysis/package manager YAST2 reports:

Unable to create Repository from URL 'hd:///*name*.iso?device=dev/disk/*mydisk*&filesystem=auto

|] Valid metadata not found at specified URL(s)

-*name*.iso] hd:///*name*.iso?device=dev/disk/*mydisk*&filesysystem=auto Repository type cannot be determined.

Try again?

If I answer yes it goes to a form to put in details of where it should look for the repos, with the following boxes:

Repository name?

I guess this is just a handle for later when I wish to set the priorities, but I have tried to enter as many different names for my iso as I can imagine might be relevant
Then a box with disk type, a drop down menu with my disk already filled in.
Then a drop down with filetype, default auto.
I have tried all possibilities, auto, ntfs, ntfs-3g, iso-9660.
Then a box with


I have tried everything in here.
There is then a check box with something like:

plain rpm repository?

I have tried with this checked and unchecked, pointing to the .iso, the unpacked iso, the suse directory within the unpacked iso, the suse/i586 directory within the unpack etc etc.
I have now exhausted all I can think of.

If I answer NO to the first question, the install aborts.

At the install options menu, there is expert>config and >change config.

Looking in >config I find that there is

install url:hd/*name*.iso?device=sdb1 

which AFAICS, is correct
If I go >change config, I could alter the above.

One thing always present is the ? in the path


Any ideas anyone?
Should I submit a bug report?

I’ve had trouble installing from iso’s on hard drive. But is seems system dependant. What worked is:

  1. as root# mount -oloop “youropenSUSE.iso” /mnt
  2. mkdir /11.1
  3. cp -r /mnt/* /11.1
  4. Boot from NET-install-disk
  5. Choose Harddisk from media, enter /dev/yourdevicewherefolder11.1is and /11.1/ (yourdevice… as sd{letter][number]

One way or another the installer is not able to find the repodata from the iso. This way you mount the iso, and then put the content of the iso in a folder. On my laptop I cannot install from an iso on the laptop’s own harddisk. Same for 11.0 and 10.3, this worked for me.
If you don’t know what /dev/… is the right one, just fill in the /11,1/ in the Folder option, should work as well

Keep us posted.

Thank you, I have found a workaround, I will report back from Linuxland!

Well here I am in Linuxland, I shall report the workaround tomorrow, ATM I am so pleased that I am off to play

Thanks Knurpht for your reply and the excellent advice in it. I am sure that your method will help others in a similar boat. For the record, what I did was this:
( I had windows on one HDD, and was installing openSUSE to another, virgin HDD)
Boot to a live cd, with a distro with ntfs support.
Create an ext3 partition on the target HDD, and copy the .iso to it
Then I booted the installer from USB and pointed it to the new partition/copy.
Everything went perfectly, & apart from the copying, no scarey CLI mount, umount -o loopiness was needed. I have later learned that there are programs which allow R/W of ext* filesystem from within Windows, so even that could have been avoided by the terminalophobic.
I searched Bugzilla and added myself to a mailing list about a similar problem and received a reply saying that this issue had been addressed, but I must confess I did not really understand it! It is here: