USB Headset does not work (Suse 12.1)

Hi all,

I’d be very grateful if somebody has an idea about the following problem:

I have a Lenovo T410 laptop, more precisely as CPU: Intel(R) Core™ i5 CPU M 540 @ 2.53GHz. In March, I installed Suse 12.1 and now I am runnning

OS: (Suse) Linux 3.1.10-1.9-desktop x86_64
System: openSUSE 12.1 (x86_64)
KDE: 4.7.2 (4.7.2) “release 5”
Vendor: nVidia Corporation
2D driver: nvidia
3D driver: NVIDIA 290.10

Everything runs smoothly, EXCEPT my Logitech USB Headset. When I plug it in, the sound still comes via the laptop loudspeakers. And the integrated micro also doesn’t work. (My old analog headphones worked, but they died yesterday. I never tried an analog micro.)

When I plug the USB Headset in, it appears in Yast > Sound > as

“nonconfigured” Logitech USB Headset

When I click on “edit” in order to configure them, I get the message

“Logitech Headset will be configured as 4th soundcard (snd-card-3)”

and I can choose quick/normal/advanced setup. But no matter what I choose, I get the message

“An error occured during the installation. The kernel modul snd-usb-audio for sound support could not be loaded, this can be caused by incorrect module parameters, including invalid IO or IRQ parameters.”

Does somebody have an idea? Please note: I am doing fine with the “window version” of yast, BUT I am HOPELESS with the command line!!! Please keep that in mind when you write your answer…

Best & thanks,


So to really help, we need more info on the headset. Since its USB you can open terminal and run this command:


And post the results here. Further, you can look on the box and give us the full model number for the headset. Since openSUSE uses PulseAudio, you might want to read up about the basics here:

Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

The pavucontrol control mentioned can be run where you go to the Configuration tab and make sure only the headset is enabled, if it shows up there. I am not sure what the YaST sound control really does any more for us. With the model number we might determine that you need a newer kernel for it to work For instance, I purchased a PCIe Sound Blaster card only to discover I had to use kernel version 3.2 (or higher) for it to work (we are up to 3.3 in full release) and openSUSE 12.1 comes with 3.1. Anyway, it is not time to give up just yet.

Thank You,

Thanks for your answer. I get

sonja@linux-66mg:~> lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 004: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
Bus 001 Device 005: ID 17ef:480f Lenovo Integrated Webcam [R5U877]
Bus 001 Device 006: ID 046d:0a14 Logitech, Inc.

And my headset is a “Logitech USB Headset H330”.

Having the same (i think) problem here. I have chosen the USB as preferred over Internal analog audio, but now it is greyed out

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 049f:0051 Compaq Computer Corp. KU-0133 Easy Access Interner Keyboard
Bus 003 Device 002: ID 046d:c03d Logitech, Inc. M-BT96a Pilot Optical Mouse
Bus 005 Device 003: ID 046d:0a01 Logitech, Inc. USB Headset
Bus 004 Device 002: ID 043d:0079 Lexmark International, Inc. InkJet Color Printer

To be more specific, if i R. click on the Kmix icon in the sys. tray and selctect Master channel, all i see is Internal Audio.

If i go to Personal Settings (under Classic menu) and then Multimedia>Phonon>Music, then the USB headset is greyed out. However, under Audio Recording it shows 3 instances of Logitech headset, one of which is set as Default audio device.

If i use Yast Admin settings>Hardware>Sound, then it shows 82801G (ICH7 Family) High Definition Audio Controller ,Configured as sound card number 0, Driver snd-hda-intel,
and Logitech USB Headset, Configured as sound card number 1, Driver snd-usb-audio.

And if i clk. on Other and Play test sound (with the headset selected in the window above), then i can hear the test midi music fine. But i get no sound with Amarok or in Firefox.

I then (under Other) set the headset as the primary card, and then tested but then i get no sound with the headset selected in the window above, but if i have the High Definition Audio Controller selected and choose Test sound, then i can hear it through the headset, but i get no sound with Amarok or in Firefox.

On a previous install of OpenSuse 12.1 then the headset worked.

Thanks for any help.

Did you try ‘pavucontrol’ per jdmcdaniel3’s recommendation ? I use it for my USB device and it works well.

I had it installed, and reinstalled it, but i still have no sound apart from the test. I also exited kmix and started it, and now it shows up along with the internal analog, but phonon shows the PulseAudioMixer. I did not think this would be a complicated issue for such a basic thing, but thanks.

  1. I didn’t have PulseAudio, only Kmix. Thus I installed PulseAudio, but it crashes (Message: “Fatal Error. Unable to connect to PulseAusio.OK”). What might be the problem?

  2. I played a bit around with Kmix and my experience is similar to Act1036’s experience:

My headset shows up in Kmix; I can choose between “HDA Intel” and “Logitech Headset” as current mixer, but in spite of choosing the Logitech headset the sound still comes via the spaekers. Then I went in Kmix to Settings > Audio control. I get the window of Phonon KDE control module. When I clicked on AudioPlayback, a bunch of devices “default”, “hw:0,0”, “hw:1,3”, “hw:1,7”, “hw1,8”, “hw:1,9”, “hw:2,0” showed up.

I tried the sound test for all of them — the first 2-3 produced loudspeaker sound, the middle ones nothing, BUT “hw:2,0” played the test sound via headphones! So I moved it up to first preference and rebooted. Unfortunately the sound still comes via the loudspeakers… but now I can also see “Logitech Headset” in the list of Audioplayback, in fact several times — some are grey and some are normal font and if I choose the normal font ones I also get the test sound… but Firefox, caffeine etc. still come via loudspeaker!..

  1. When I plug my headset in and when I unplug it, I get the corresponding message in the right bottom corner of the desktop. So the system obviously recognizes it. Why is there no sound…?

Let me add that we need to know what openSUSE version you are using including the desktop that you use. PulseAudio is installed and activated by default. If you need to reinstall it, because you uninstalled it, its possible you may need to reload everything. The GStreamer package is the default back-end and we suggest you stick with PulseAudio and GStreamer and do not uninstall any major audio packages. If you want to test your system by disabling PulseAudio and when disabled, you can place xine ahead of GSTreamer as your backend, thats OK. But, if this does not help, go back to the defaults please. For some help with audio issues including the ability disable/enable PulseAudio, look to the bash script I have called START.

S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.12 - Blogs - openSUSE Forums

Thank You,

…ok, the next act in the drama…

As I said in post #8, I didn’t have PulseAudio. Then I installed a few packages, but it crashed. Thus I guessed that some packages were missing; I did a new package search and installed everything which looked somewhat reasonable. I didn’t restart, but tried right away PulseAudio Volume Control — and it didn’t crash, but worked to some extent:

The Headset (phones & micro) worked under VLC, caffeine and xine, but NOT in dragon player and firefox (i.e. youtube and other adobe flash videos). But the loudspeakers didn’t work any more, no matter, what I did.

Thus I decided, that a reboot may be in order — but the laptop didn’t shut down! It got stuck with a dimmed screen, until I pulled the plug and removed the battery. It restarted without problems.

Then a window popped up saying that certain sound devices were deemed outdated and needed to be deleted permanently. Me, being already tired (here it is 2am), clicked on “yes” before having read all the small print… well, whatever the system wanted me to delete, I am now back in the old state: PulseAudio Volume Controle crashes (“Fatal Error, unable to connect to PulseAudio:OK”), the loudspeaker work, but the headset not… I am slowly getting desparate…

I understand from your first post, that you have KDE-4.7.2 desktop on a 64-bit openSUSE-12.1. As noted pulse audio comes installed by default in such a case. The application ‘pavucontrol’ is not installed by default. But if you had to install pulse audio, it is only because at sometime in the past you chose to remove it. Pulse audio is not removed by default in any application that I know of.

After a fresh reboot, BEFORE you run any other application, does ‘pavucontrol’ run ? I would like to remove the possiblilty that some other multimedia application seized the audio device, and refused to share it with pulse audio. So after a fresh reboot, please run ‘pavucontrol’. And after setting up a few apps, close ‘pauvcontrol’ (don’t wait until it crashes) so that any settings it has are saved (which typically takes place upon closure, if not sooner).

With respect to your dragon player and firefox not playing sound via speakers, that IMHO is likely because of settings you made on your KDE desktop during your earlier efforts to get the USB device working, and those would need to be restored.

I’m glad to read it restarted, but why did you have to remove the battery ? Does this laptop have a design different from most other laptops ? In every laptop that I know of, in such a case one simply continuously presses down on the power on/off switch for 10 to 20 seconds until the laptop shuts down. … Please try that next time. And if you did try that (continuous press of power on/off) and it did not work, then the design of your laptop is very foreign to me and it makes me wonder what else may be so foreign. If your laptop design is that foreign, then this could be beyond my ability to help.

Wrt rejecting the KDE settings to remember, IMHO you made the best choice.

This is likely easy to put back, but currently I believe you have been inflicted with the fog of frustration that grips all of us on occasion (and it grips me too at times).

Best wishes and keep trying. :slight_smile:

I did not use this, but went reinstalled kmix and also went to Phonon and Audio setup and chose analog stereo output and analog mono input, and also rebooted, and found that kmix (sys. tray) now shows simultaneous output to both internal analog stereo and USB headset analog stereo, and now Amarok will play thru the latter, but neither Firefox or Konquer will play audio. has detected that the server is redirecting the request for this address in a way that will never complete.

Ignore the line about " the server is redirecting the request for this address in a way that will never complete," which was for another forum, but how do i get the browsers to play sound as Amarok does? I installed Chrome also but it will not play there either. Thanks.

pavucontrol works for me.

  1. ok, I rebooted, opened a terminal and run “pavucontrol” which resulted in the following error message:

sonja@linux-66mg:~> pavucontrol &
[1] 2298
(pavucontrol:2298): Gtk-CRITICAL **: gtk_main_quit: assertion main_loops != NULL' failed (pavucontrol:2298): Gtk-CRITICAL **: gtk_main_quit: assertion main_loops != NULL’ failed
[1]+ Done pavucontrol

and a little window popped up with “Fatal error. Unable to connect to PulseAudio: OK”.

How do I find out why pavucontrol doesn’t start? And how do I fix it?

  1. And about my weird “emergency shut down”: My last Laptop was a cheap, weird no-name product. Pushing the button for 20sec didn’t work with my old one… so I picked up the above mentioned bad habit (this time was the first time I did it to my new (= 1 year old) Lenovo Laptop)).

  2. In March, I updated from Suse 11.3 to Suse 12.1. And Suse 11.3 had been installed by our computer guy. Already under Suse 11.3, USB headsets didn’t work. The computer guy worked on it, but didn’t get it to run. So he might have (un)installed certain sound mixers/ programs etc. during that struggle… My old analog headset had always worked without trouble, but it died a couple of days ago…

My research tells me that error means pulse audio did not run.

That also supports the error message, indicating pulse audio was not running.

How to fix it ? I don’t know. Pulse just works for me.

I suppose you could confirm what pulse audio rpms you have installed. What is the output of the command:

rpm -qa '*pulse*'

for example, I get:

oldcpu@corei7:~> rpm -qa '*pulse*'

and there could be other reasons why pulse audio is not running.

Also, I know you already provided a lot of information, but can you provide some more ? With your PC connected to the internet, and with your USB headset plugged in, send the command


and select the UPLOAD/SHARE option, and it will paste your PCs audio configuration to an alsa pastebin site. when the script completes, please copy the webaddress/URL where it uploaded your audio configuration (it will tell you where) and paste that here.

I did mine, and here it is.

Note that i can hear sound thru my headset if i go to Kimx>Restore>Settings>Audio Setup and hit Music (left) and click on USB headset or simutaneous… and then hit Test. But it will not play on any browse such as in videos (like this )

I would like to see the output of the rpm command. Did it not work ?

I note:

**** List of PLAYBACK Hardware Devices ****
card 0: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

which makes it clear your USB headset is hw:0,0 and not hw:2,0 which an earlier post suggested.

I also note:

**Card hw:0 'Headset'/'Logitech Logitech USB Headset at usb-0000:00:1d.3-1, full speed'**
  Mixer name	: 'USB Mixer'
  Components	: 'USB046d:0a01'
  Controls      : 6
  Simple ctrls  : 2
**Simple mixer control 'Speaker',0**
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 44
  Front Left: Playback 0 [0%] -41.00dB] [on]
  Front Right: Playback 0 [0%] -41.00dB] [on]

… assuming that is your USB headset, then you have the sound muted in the mixer. That should stop any audio from playing.

I want to say first that i think you might be getting me confused with the original OP, and i am sorry if i have in any way intruded on him. I thought perhaps my issue could have the same cause, but it seems they may not.

As regards the mute, the sound is not muted and i hear it fine via Amarok, but not in FF. Knqr or Chrome, including YouTube.

I had not run pavucontrol or the rpm that you suggested to the OP, but here are the results to each below:

** (pavucontrol:28845): DEBUG: Error reading config file /home/d7/.config/pavucontrol.ini: No such file or directory
** (pavucontrol:28845): DEBUG: Ignoring sink-input due to it being designated as an event and thus handled by the Event widget
[this continued when i moved the slider from Silence under Playback>System Sounds to 42% or so, but moving it has not fixed the problem]

rpm -qa ‘pulse

What this means i know not. Thanks for any help.