USB, Ethernet failing irregularly (no light), WLAN connection works occasionally, HP 15-ba100ng

Hello there,

I recently installed openSUSE Leap 15.3 on an HP 15-ba100ng laptop. Sometimes I’m seeing multiple hardware issues after booting:

  • if I plug a USB device into the USB 3 port, everything works fine. If I use the two other (USB 2 I believe) ports, nothing happens (no light on flash drive, no journalctl entry). But: If the flash drive is already plugged when booting, it works fine. If I then unplug it and replug while laptop is booted, nothing happens (no light, no journal entry).
  • same problem with Ethernet cable: No light, no response, unless it has been plugged since before I booted.

I rebooted my laptop multiple times this morning, most of the times the two issues showed up, one time they didn’t. I don’t see the point, did no updates during that test whatsoever. Just booting and rebooting.

Some possibly related information:

  • When installing Leap 15.3, it wouldn’t boot past “Loading initial ramdisk” until I added “iommu=soft” to the kernel boot parameter list. Found this solution in the following thread: (see post by dkaylor, he reported this problem related to Stoney Ridge architecture)
  • Processor I have: A9-9410 (AMD Stoney Ridge)
  • kernel:
> uname -sir 
Linux 5.3.18-150300.59.49-default x86_64 

  • every time I boot I get the following output on the screen for a short while:
    0.537854] ACPI BIOS Error (bug): Could not resolve symbol \_SB.WLBU._STA.WLVD], AE_NOT_FOUND (20200925/psargs-330) 
    0.537854] ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20200925/psparse-531) 
    0.611555] ACPI BIOS Error (bug): Could not resolve symbol \_SB.WLBU._STA.WLVD], AE_NOT_FOUND (20200925/psargs-330) 
    0.611565] ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20200925/psparse-531) 
    0.696293] ACPI BIOS Error (bug): Could not resolve symbol \_SB.WLBU._STA.WLVD], AE_NOT_FOUND (20200925/psargs-330) 
    0.696305] ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20200925/psparse-531) 
    1.927805] tpm_crb MSFT0101:00: can't request region for resource [mem 0xdfb76000-0xdfb79fff] 

  • My boot arguments are (/etc/default/grub):
GRUB_CMDLINE_LINUX_DEFAULT="splash=silent iommu=soft mitigations=auto quiet" 

For the sake of completeness (I’m not sure if this is really coupled to the above problem):
WLAN connection to my home network works sometimes. In the first few days it worked well, then started failing about 50% of the time. The following shows up in the journal:

Feb 27 11:51:28 localhost.localdomain kernel: wlan0: e4:bf:fa:cb:df:08 denied authentication (status 33) 

Sometimes restarting the router removes the problem. Connecting to other networks (for example mobile phone hotspot) works fine, connecting other devices to my home WLAN Network (for example mobile phone) is also no problem.

Also, the following shows up in the journal every few seconds when I’m connected:

Feb 27 11:47:46 localhost.localdomain NetworkManager[1468]: <info>  [1645958866.5866] policy: set-hostname: set hostname to 'localhost.localdomain' (Error reverse-resolving “”: Name or service not known) 

Any thoughts?

This Laptop seems to have been introduced to the market around 2016 – it’s possibly now about 6 years old.

  • The symptoms described could be due to ageing.

What happens if you disassemble the device and, check all the available hardware connections inside the case?

  • Possibly a cable connection could need attention with some contact spray.

Try to update BIOS and other firmwares.
Try another kernel parameters without “iommu=soft”:
Possibly you need newer kernel from Kernel:Stable:Backport repo.

Hi there,

it’s been a while and I’ve made some progress. First of all I did BIOS update like Syvatko recommended, that didn’t seem to change anything.


1. WLAN problem is solved: I have a Realtek RTL8723BE Adapter, controlled by the rtl8723be kernel module. As mentioned here HP probably only connected one of the antennas. The kernel module has an ant_sel parameter to select which antenna to use, so I tried unloading and reloading the module with different settings and scanning for WLAN networks:

rmmod rtl8723be
modprobe rtl8723be ant_sel=1
iwlist wlan0 scan

With ant_sel=1 the results were usual, with ant_sel=2 almost no networks were found. I have now added


to my kernel command line in /etc/default/grub and haven’t had WLAN problems ever since.

2. I was able to narrow down the USB port issue. It seems to have something to do with the laptop running from wall power or from battery. I did some tests plugging in and out a USB flashdrive and here’s what happens: (this only concerns the USB 2 ports, the USB 3 port is fine)

  • initial case: laptop booted, power plugged in, flash drive plugged in, flash drive turned on and recognized by the system
  • I unplug and replug the flash drive, it is recognized again
  • if I unplug flash drive, unplug laptop power and insert flash drive again, it blinks very shortly and stays turned off. No entries in journalctl.

There are three methods I found out to turn the flash drive on again:
a) reload ehci_pci kernel module:

rmmod ehci_pci
modprobe ehci_pci

b) suspend the laptop and start it again (close lid, wait til fan turns off, open lid again)
c) reboot

May be an issue with power saving settings on battery? Is it possible there is a setting somewhere turning off all USB 2 ports after last device is unplugged when running on battery?

Check your BIOS for any powersaving settings, this may help