USB error mesage

I Installed OpenSuse 11.1 on my Dell inspiron 6400 it has worked fine for the past few days then out of the blue I am having probs with the USB when i put in my USB flash drive I get the following error

An error occurred while accessing Volume (vfat) the system responded org.freedesktop.DBus Error.1 Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

When i run dmesg this is what i get about the USB

usb 5-3: new high speed USB device using ehci_hcd and address 2
usb 5-3: configuration #1 chosen from 1 choice
usb 5-3: New USB device found, idVendor=1307, idProduct=0163
usb 5-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 5-3: Product: USB Flash Drive
usb 5-3: Manufacturer: USB 2.0
usb 5-3: SerialNumber: 7ea464720ce167
Initializing USB Mass Storage driver…
scsi2 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi 2:0:0:0: Direct-Access USB 2.0 USB Flash Drive 0.00 PQ: 0 ANSI: 2
sd 2:0:0:0: [sdb] 7897087 512-byte hardware sectors: (4.04GB/3.76GiB)
sd 2:0:0:0: [sdb] Write Protect is off
sd 2:0:0:0: [sdb] Mode Sense: 00 00 00 00
sd 2:0:0:0: [sdb] Assuming drive cache: write through
sd 2:0:0:0: [sdb] 7897087 512-byte hardware sectors: (4.04GB/3.76GiB)
sd 2:0:0:0: [sdb] Write Protect is off
sd 2:0:0:0: [sdb] Mode Sense: 00 00 00 00
sd 2:0:0:0: [sdb] Assuming drive cache: write through
sdb: sdb1
sd 2:0:0:0: [sdb] Attached SCSI removable disk
sd 2:0:0:0: Attached scsi generic sg2 type 0
usb-storage: device scan complete