USB EFI Install

I’m trying to install using a usb written by suse imagewriter in efi mode and install started in efi mode at boot.
The installer is clearly not running from the usb but attempting to download all the files. It was showing in excess of 37 minutes
and disconnecting the ethernet cable halts the process.
Any ideas why this might be happening?

Did you select to add the online repos during install? If you start the install without the network cable what happens? This is the DVD not the Net install image?

I did not select online repos durring the install
and it’s the full dvd iso and i even tried adding the usb as media
I’ve also noticed it takes three to four mins to just reach the installation first menu - previously this is seconds.

Cheers malcolm

just tried booting without eth cable, landed in linuxrc 5 eventually with installer asking to try a web address again

As a foot note, other distros have a tendancy in efi boot to require the usb to be unplugged and plugged in again to continue the boot
sus didn’t but still seems intent on downloading.

Not a USB 3.0 port? Try a different USB port. If after you select the grub installation option, press the esc key and can see what the system is up to, more than likely probing for something…

front ports are usb 3
and esc shows it going through the loading drivers and requesting dhcp from eth0
then after which installation starts but then is clearly downloading.

i’ll try running it in a usb2 port and see if it’s usb3 related

does the same in usb2 port!

All very strange, you did check the sha256 sum on the iso image before creating with imagewriter?

Are you sure you have the full iso should be about 8 gig in size

My install was a USB install on an EFI box.

I did not run into any problems.

It actually looks to me, from your post, that you are using the NET installer rather than the DVD installer. The NET installer does download from the network. I used the DVD installer, which is self-contained and does not require a network connection, though it will use the network if it is available.

I got the full iso at 4.7Gb but it acts like the net install.


4.4 GB (4,384,096,256 bytes)

ba5af6b0ac4d42d801de642304eb88ca9fd65a61b6c3ff25724182494f288f00 confirmed correct with quick hash

Yes, that’s looks like the correct hash for the DVD installer.

Is it possible that you were confused by the messages? Yes, for my install, it did say that it was downloading. But it was only “downloading” from the USB with the installer image. It wasn’t using the network.

No it was definately downloading as I disconected the ethernet cable and it stopped.
I ran it from dvd and it installed fine, after reboot it black screened on me so I gave up for now.