USB Drives not auto mounting

Hello,

my opensuse is not auto mounting USB drives anymore. It was working a few weeks ago! I have an external 500GB HDD and also an 16GB Kingston USB flash disk, both are not being auto mounted.

If i do lsusb i get

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 2.0 Stick (4GB) / PNY Attache 4GB Stick
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

seems the system is detecting the USB stick. /var/log/messages is telling me its there also

Sep 12 11:45:47 SERVER kernel: [1342530.133037] usb 1-2: new high speed USB device using ehci_hcd and address 6
Sep 12 11:45:47 SERVER kernel: [1342530.253229] usb 1-2: New USB device found, idVendor=0930, idProduct=6545
Sep 12 11:45:47 SERVER kernel: [1342530.253236] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Sep 12 11:45:47 SERVER kernel: [1342530.253240] usb 1-2: Product: DataTraveler G2
Sep 12 11:45:47 SERVER kernel: [1342530.253244] usb 1-2: Manufacturer: Kingston
Sep 12 11:45:47 SERVER kernel: [1342530.253247] usb 1-2: SerialNumber: 001D0F160F0CBA31239C01F5

What version of openSUSE and what Desktop?

Do this in a terminal and post result

uname -a

opensuse 11.3

uname -a
Linux SERVER 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

Desktop = KDE or Gnome?

Gnome should just auto mount

KDE you have to specify it in the System Settings > Hardware > Removable Devices

I am using gnome

Do you have access to windows
Try them there. Even if they work, format them and make sure you safely remove them.

Hang on, you might not want to format the 500GB
Just try in windows and be sure to safely remove it

Then try it again in Linux

external disks are just fine under windows!

I restarted the pc about 4 times and it seems to be working now. I think a kernel security update came through the other week? Maybe thats what was playing up?

OK. Thanks for letting us know.

Hi Caf, I had this problem, 11.2 KDE 4.4.4
I had to go system settings>Advanced>removable devices and click auto mount.
What is annoying is that this just happened, before I had been happily using my USB dives with no prob, plug em in and there they were in Dolphin etc. What could have made this change? It is very annoying when linuxes are being touted as desktop for eveyone, when stuff that was working just suddenly stops…

Auto mount has never been there by default in kde4
Yes, devices when plugged would show in Dolphin’s ‘Places’ but not mounted.
The introduction of the auto mount option came in around 4.4 I just can’t recall.

Hmmm must’ve been an update glitch, I have used thumb drives recently, plug em in and off they go, the other day I needed to update my cv, plug in, nothing, not there etc etc …
Maybe the the “removable devices” module itself got updated, and reset itself to defaults somehow? Still annoying :slight_smile: but thanks to your pointer all back to working now.