USB Drives get disconnected on fsck

I wanted to test Displaylink driver, so I installed Kubuntu on my USB drive. The USB drive is partitioned as
part 1 fat32 10gb
part 2 extended
part 5 home
part 6 other
part 7 root

I used a friend’s McBook Air to install Kubuntu from a USB stick to the other one. Shockingly the installer did install itself into the Efi boot loader instead of the selected USB drive.

The McBook froze while running some updates and I ended up with damaged home filesystem. Root partition I reformatted, but on the home partition are some files I need.

when I run fsck.ext4 under OpenSuse the USB drive gets disconnected from the system and fsck can not be finished.

kubuntu is running fsck from a USB ISO for 12 hours now, without disconnecting the USB stick.
how come, opensuse 42.3 disconnects USB Sticks on fsck? And there is no data output on the progress?

Sure home is ext4 and not the default xfs? Run the fsck command by itself and let it sort out what to do… also check it’s a USB2 port if possible?

I paritioned the USB stick that way long time ago. so home is definitely ext4.

USB2 stick is USB3.0 , I connected it to USB3.0 and USB2.0 ports directly on the computer and on a USB3.0 hub and a USB2.0 hub, on all ports the stick gets disconnecting, if I do fsck after a while.

I cann access the fat32 partition and other partition. the partition for / I reformatted and can acccess. Just that partition labeled as /home has problems. When I tried fsck on the partition for / I also got disconneced.

I can do a :

mount -oro,noload /dev/sdb5 /mnt

and can enter the directory from the terminal.

Dolphin does calculate the amount of files if I right click, but does not display anything. So appears to be a problem with the journal.

superuser dolphin can access the data.

question left, how to remove the broken journal flag

There are a few howto’s on the web… google “Repair a broken Ext4 Superblock” should get you in the right direction :wink:

Actually there seam to be a different problem. I copied all files to another drive and trieed to reepartition the drive. But I cannot delete, format or create a new partition table. Neither, OpenSuse, Windows nor my samsung phone, let me correct it.

sb 2-1.2: reset SuperSpeed USB device number 4 using xhci_hcd
1828.601301] sd 4:0:0:0: [sdb] tag#0 FAILED Result: hostbyte=DID_ABORT driverbyte=DRIVER_OK
1828.601307] sd 4:0:0:0: [sdb] tag#0 CDB: Write(10) 2a 00 00 00 08 f0 00 00 f0 00
1828.601310] blk_update_request: I/O error, dev sdb, sector 2288
1828.601312] buffer_io_error: 20 callbacks suppressed
1828.601314] Buffer I/O error on dev sdb1, logical block 30, lost async page write
1828.601324] Buffer I/O error on dev sdb1, logical block 31, lost async page write
1828.601325] Buffer I/O error on dev sdb1, logical block 32, lost async page write
1828.601327] Buffer I/O error on dev sdb1, logical block 33, lost async page write
1828.601328] Buffer I/O error on dev sdb1, logical block 34, lost async page write
1828.601330] Buffer I/O error on dev sdb1, logical block 35, lost async page write
1828.601331] Buffer I/O error on dev sdb1, logical block 36, lost async page write