usb devices not recognised after switch to VT

I installed an application that uses ncurses, old tty …

It starts itself on vt02. After this application is started
no usb device is recognised in the kde environment.

USB printer, mouse, stick… not recognised or unusable (mouse e.g.)

This also happens when I just have the agetty on tty2 and log in
on this VT.

System is opensuse 13.2 32 bit.

Hi welcome,

That’s a serious bug. Contact the developer.

the developer is me.

this has worked on a dozen of opensuses before, 6.1 was the first one.
this is also the first time it is installed on a portable PC.

on the kde screen (ALT F7) the built-in mouse(pad) doesn’t work
either after the switch to VT02.

I also have the problem when no app. is started but simple go
to VT02 (ALT F2) and login.

There have been some issues with a kernel update, which is fixed by a next update. Is your system up to date?

BTW: run

dmesg -w

and have a look at the output

My guess is that this is a coding issue, and you didn’t identify how you wrote your program.
If this works in real mode, that probably should be a hint where your coding error is, the method you use to connect and use a USB device.

Yes, there are differences between a virtual tty and a real mode tty, and you’ve probably run into one of those differences.
I’d guess you might get more eyes relevant to whatever coding language you’re using if you post instead in the Programming/Scripting Forum.

And, you may want to provide a snippet of the code you use to access USB devices.


hi all,

there is a misunderstanding: it is not my program that is not able to access a usb device,
it is linux itself! the program doesn’t access any usb device at all.
when I switch to kde, the mouse doesn’t work anymore, when i insert a usb stick it is
not detected…

Observe the output from dmesg (as already suggested) when a USB device is attached. When a memory stick is connected what is reported by ‘blkid’ or ‘fdisk -l’?

lsusb doesn’t show any devices anymore

fdisk -l doesn’t show any usb stick, only the hard drives.

both commands showed correct output after booting.

If these commands (particularly lsusb) display information about your devices after booting, do those devices also work after booting?

In that case,
It might be that your system has a problem auto-detecting removable devices that are connected or disconnected during a session.

Pls clarify/verify if this is what you posted.


Re-reading your original post,
It still sounds like you are saying that your code is what you believe that triggers losing access to USB devices.

So, my previous comment about needing to inspect your application code still applies.

The suggestions to view dmesg should also be important to determine what is happening when your app launches.

Also, have you tried running your app in a real mode TTY (eg init3)?
You should do so, then switch back to a graphical console and check whether your USB devices still work.


You were asked to provide output of dmesg. Both commands require device nodes to be present; if for some reasons device nodes are not created - or you do not have permissions to access them - these commands show nothing. But dmesg shows what kernel detected.