USB DAC no longer working

Having upgraded from Leap 15.1 to 15.2 my USB DAC no longer works:

Feb 21 10:19:03 ada kernel: usb 1-1: new high-speed USB device number 7 using xhci_hcd
Feb 21 10:19:06 ada kernel: usb 1-1: device descriptor read/64, error -71
Feb 21 10:19:06 ada kernel: usb 1-1: New USB device found, idVendor=2972, idProduct=0044, bcdDevice= 3.10
Feb 21 10:19:06 ada kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Feb 21 10:19:06 ada kernel: usb 1-1: Product: FiiO M3K
Feb 21 10:19:06 ada kernel: usb 1-1: Manufacturer: GuangZhou FiiO Electronics Technology Co., Ltd.
Feb 21 10:19:06 ada kernel: usb 1-1: SerialNumber: FiiO M3K
Feb 21 10:19:06 ada kernel: usb 1-1: 1:1: freq mismatch (RO clock): req 192000, clock runs @48000
Feb 21 10:19:06 ada mtp-probe[14616]: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-1"
Feb 21 10:19:06 ada kernel: usb 1-1: 0:2 : does not exist
Feb 21 10:19:06 ada mtp-probe[14616]: bus: 1, device: 7 was not an MTP device
Feb 21 10:19:07 ada kernel: usb 1-1: 1:1: freq mismatch (RO clock): req 44100, clock runs @48000
Feb 21 10:19:07 ada kernel: usb 1-1: 1:1: freq mismatch (RO clock): req 44100, clock runs @48000
...
Feb 21 10:19:07 ada pulseaudio[3231]: E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
Feb 21 10:19:07 ada pulseaudio[3231]: E: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="1" name="usb-GuangZhou_FiiO_Electronics_Technology_Co.__Ltd._FiiO_M3K_FiiO_M3K-00" card_name="alsa_card.usb-GuangZhou_FiiO_Electronics_Technology_Co.__Ltd._FiiO_M3K_FiiO_M3K-00" namereg_f>
Feb 21 10:19:07 ada pulseaudio[3231]: W: [pulseaudio] module-udev-detect.c: Tried to configure /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0/sound/card1 (alsa_card.usb-GuangZhou_FiiO_Electronics_Technology_Co.__Ltd._FiiO_M3K_FiiO_M3K-00) more often than 5 times in 10s

It does still work on a Tumbleweed machine at 44kHz 24bits.

Maybe you can set the frequency explicitly in /etc/pulse/daemon.conf?

Thanks, I tried un-commenting this line in that file but it did not help:

default-sample-rate = 44100

Does the syslog suggest the kernel has a problem with the device before Pulse tries to use it? I am also unable to use it direct from Alsa (Strawberry) as I was before.

https://fiio.com/m3k
http://www.fiio.me/forum.php?mod=viewthread&tid=43627&extra=page=1

M3K-FW1.4.5 firmware download:Click here

The following changes and improvements have been made to the FW1.4.5 compared to the FW1.4.3 on M3K:

  1. Fixed the issue where the system would be stuck at the Welcome page after the device turned on.
  2. Miscellaneous bug fixes and performance improvements.
  1. ILL new installation of Pulse/ALSA wipes off your settings.

https://askubuntu.com/questions/138611/how-to-change-audio-bit-depth-and-sampling-rate

default-sample-format = s24le
default-sample-rate = 192000
alternate-sample-rate = 44100

Without 48000.

Thanks, firmware updated from 1.4.3 to 1.4.5

I have tried those settings in /etc/pulse/daemon.conf

Unfortunately neither the firmware or the settings resolve the problem. I don’t believe I ever changed the settings before and certainly didn’t on Tumbleweed, it just works there.

I guess you could try testing with the latest stable kernel? (Beware if using proprietary graphics modules of course).

https://kernel.opensuse.org/stable.html

Maybe

Don’t just comment out the 44000 frequency, set to the expected minimum 48000.

If it’s working on another machine, generate the same output, or search for the journal log entries that correspond to your error output.
Compare to see what is different… maybe it’s recognized differently(Don’t go by the common name, verify the vendorid and deviceid)? Is just another kernel and nothing else?

TSU

I have created a bug for this: https://bugzilla.opensuse.org/show_bug.cgi?id=1182633