[usb bootable] can not boot when bootable iso put on stick

I use an iso (utils) that could be booted using vmware it always booted and worked (but I think vmware considers this is a DVD/CD).
I want to put it on a usb stick because the computers to be recovered have no DVD/CD reader.

I used all I have found from internet howtoes and opensuse howtoes, this usb stick can not be booted on another computer (I see the usb stick in the boot menu but there is nothing more than an error that I can’t read when I hit return, grub2 took the relay).

Is anybody could give me a way to help me put this iso (bootable but taken as a CD/DVD) on a usb stick ?

I just copy the iso directly to the usb device. However, you have to copy to the raw device, rather than to the file system.

On this computer, a USB device usually shows up as “/dev/sdd”. So I use:

dd_rescue ISOFILE.iso /dev/sdb

(replace “ISOFILE.iso” with the actual file name). And note that “dd_rescue” is in the repos so you can easily install it.

Other methods that probably work:

dd if=ISOFILE.iso of=/dev/sdd
cp ISOFILE.iso /dev/sdd
cat ISOFILE.iso > /dev/sdd

I always used /dev/sdd as the target of my copies… I will try with dd_rescue than dd.

Ooow, take care. Make sure the /dev/sd* entry is the correct one, dd will destroy everything on that device. I always check, with

ls -ltr /dev/sd? 

right after inserting the USB stick. The last line in the output tells you which /dev/sd entry to use.

The logical structure of a bootable CD/DVD is different from the logical structure of a USB.

Copying an iso to a USB is not guaranteed to work. It will only work if the iso was built with an appropriate hyrbrid structure such as would allow it to work either way.

Many linux isos are built in a suitable way. But I have run into some isos that don’t work. Maybe you have one of those.

The logical structure of a bootable CD/DVD is different from the logical structure of a USB.

That is why I said that this iso i taken as a CD/DVD… ^^

I will try rufus under windows : as there is nothing as far as I know that will help my build a bootable usb stick with an iso that is booted on vmware…

Some rufus options modify the iso and mess up openSUSE installer. Be sure to use only dd option. You want a pure unchanged binary copy to the device not a partition on the device.

Right. However, the OP does not seem to be working with the openSUSE installer. He mentioned an iso with utility tools. So maybe rufus defaults work for that. Or maybe one of the other USB builder applications works. Hard to guess without knowing more about what iso he is trying to use.

Thank you for your help… I did loooot of works to do with my students and at house (isolation, and other heavy works) so I did not answer since today.

I tried dd_rescue instead of dd to /dev/sdd target (I always look twice to triple when doing this if the device is the correct one ^^)…

<*** going to the test computer ***>

Failure :{

Do you think Ii have to first create a UEFI partition ?
The file system is VFAT (FAT32)

It doesn’t work :{ (strangely GRUB is launched and stucked after the reset provoked by the boot attempt on the usb stick that is always recognized as a simple usb stick as vmware see it as dvd/cd)

I have to flash the usb under windows things I really don’t like to do :{
I thought it was possible to do so using Linux LEAP… I’m disappointed :{

The installer will use existing EFI boot partition if it existor create it when in EFI mode. (note it may complain if it thinks it is too small but unless it is truly tine all should be sell0

Personally I just use cp to copy the iso to the device (not a partition on the device just straight to the device.) But dd or dd_rescue should be ok as long as you copy to the device not a partition on the device.

Have you run a checksum on the iso to be sure it is a clean download???