USB Bluetooth / HID headset / SUSE 10.3 / BlueZ

Hi all,

I’m a new user of openSUSE (and linux in general). I’m running 10.3 on a Desktop machine. I have a USB Bluetooth adaptor which it seems is being detected as “Zeevo Audio Dongle” by the OS:

<command prompt> dmesg | grep -i ‘usb’

usb 1-3: new full speed USB device using ohci_hcd and address 2
usb 1-3: new device found, idVendor=0b7a, idProduct=0100
usb 1-3: new device strings: Mfr=2, Product=3, SerialNumber=1
usb 1-3: Product: Zeevo Audio Dongle
usb 1-3: Manufacturer: Zeevo
usb 1-3: SerialNumber: 0012A100B82A
usb 1-3: configuration #1 chosen from 1 choice
usbcore: registered new interface driver hiddev
input: USB HID v1.10 Device [Zeevo Zeevo Audio Dongle] on usb-0000:00:02.0-3
usbcore: registered new interface driver usbhid
drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
ALSA sound/usb/usbaudio.c:1276: 2:1:1: cannot get freq at ep 0x5
ALSA sound/usb/usbaudio.c:1276: 2:1:2: cannot get freq at ep 0x5


usbcore: registered new interface driver snd-usb-audio


And that’s where it ends. I’m trying to put together whatever I have read on the net but can’t get it to work. BlueZ is installed and Yast>Hardware>Bluetooth has bluetooth enabled + SDP, HCI, RFCOMM and HID2HCI are enabled. I have tried rebooting with the dongle attached/not-attached. No change. When I run kbluetooth, it sits gray in the corner of the screen and a mouse-over shows “No Bluetooth Adaptor”. Kbluemon crashes and says no adaptor was found and asks for a restart and crashes.

<command prompt> sudo /etc/init.d/bluetooth restart

doesn’t change it.

<command prompt> hcitool scan
Device is not available: No such device

whereas :

<command prompt> lsusb
Bus 001 Device 002: ID 0b7a:0100 Zeevo, Inc.

so I assume atleast the system sees the hardware. the Mixer application shows “Zeevo Audio Dongle” in the list of its mixers but that’s it and no use as nothing comes out of the headphones. I have used the dongle on a windows machine successfully and easily. I have paired it to my cell phone or headphones. under Linux, When I power on my headphone and the dongle is in search mode (guessing by the way the light flashes), it seems to pair and find the headphone but apparently the connection between the dongle and Linux is dead.

Any guidance is highly appreciated.


Some threads to consider for possible ideas (neither are specifically written for your openSUSE version):

Hi oldcpu,

Thanks for the prompt reply. I just gave up and went for an alternative hardware solution, so I’ll try these in case that doesn’t work out. I haven’t yet checked them but thanks for providing the links!