usb audio/video capture

I have not been able to find a simple program to capture audio/video from a usb webam. I’m running SuSE 11.1 with updates and am using a Logtech QuckCam for Notebooks. The camera works fine both audio and video.

The best I could find, on pacman, was wxcam. It doesn’t work for 11.1 even with the widgets installed. Seemed like it would have done the job if it worked.

Anybody know of a simple program or …, that can capture audo and video from a usb webcam?

Please, and thanks,

Hei Jack,

I have used Cheese but haven’t tried the video function, just photos. Thus, I don’t know how the app work with audio. You could of course try Cinelerra which isn’t simple, but not to hard if you just want to capture a sequence of video. Possibly, you might use Kino or another more simpler video editor programme as well, Kdenlive maybe.


Thanks for the response. I have, kdenlive and I’m asking on that forum why I can’t get the usb webcam mic to record.

I’ll try your other suggestions.


When I did a search on Packman for webcam I found the following:
PackMan :: webcam search

Are you saying you checked all those, and only wxcam had the feature you wanted?

The features I’m looking for from the webcam capture is video and audio. Sigh, all other platforms have such capture programs. And after using linux for 15 years not to find something like that now is…

I’ll give wxcam another try. And if anyone has any other possibilities, please let me know. In my search I found many others who were asking this same thing.

Thank you,

Did you try doing this with mplayer? ie this article: :: Five fun ways to use a Linux webcam

mencoder tv:// -tv driver=v4l:width=320:height=240:device=/dev/video0 -nosound -ovc lavc -o wcrecording.avi

but instead of " -nosound" substitute the appropriate argument (and I don’t know what it is) to record audio at the same time.

I did read one site that recommended this line:

mencoder tv:// -tv driver=v4l:width=320:height=240:device=/dev/video0:forceaudio:alsa:adevice=hw.U0×46d0×8d7,0 -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o $1

Recording video+audio with webcam (Linux) « E-notações

There is also the application cheese: Cheese web site

with rpms on webpin: Webpin search for cheese

I found those after 5 minutes of surfing …
Just how hard did you surf for this ?

In truth, it surprises me when you state "And after using linux for 15 years not to find something like that now is… " … Or did you try both those methods and they did not work . … and you decided to leave it up to us to ask you if you tried it ???

Either way, I’m puzzled. Best I can say is “have faith and try harder”.

Good luck.

In case you are curious , this is the search I did to find a number of ideas and possible applications to do this: Let me google that for you

… Good luck, and if you succeed, please let us know what app you find that works the best for you!

For example, another user tried this (I believe in conjunction with uvcview):

ffmpeg -f video4linux2 -s 320x240 -i /dev/video1 -f oss -ac 2 -i /dev/dsp2 -f mp4 test.mp4

although they noted it had problems in the audio …
[Linux-uvc-devel] How to record audio and video from a webcam?](

No, wxcam does not work for suse 11.1, the package is for 10.3, perhaps that is the problem.

You may have to try a custom compile of wxcam. I used to do that some time back, but I have not tried it for a couple of years.

I tried a compile from source this time and the configure went well, and the make complained about CImg, …, can’t find it anywhere, will wait for some insight.

Thanks for assist,

Had some luck with mencoder and have not figured out how to include audio.

I had the same. I found cimg on the web, but that did not help as its a library that needs be placed somewhere.

I had some success with this

ffmpeg -f video4linux2 -s 320x240 -r 24 -i /dev/video -f oss -ac 2 -i /dev/dsp test.mpg

but I struggled a bit with my old web cam, and the frame rate. Possibly I need to pick a better video codec that my old PC (an athlon-1100) can handle. My webcam was on /dev/video

Audio sounded mostly ok

I’m calling it a night! Good luck.

I have always found that is a good way to find out what is missing and which needs to be added to sys.

Yes, I just tried that, the configure went ok, and the make craped out with something not found, gee, can’t remember closed it down after looking all over, web and pacman, etc. Just turned my head off, when I got a video call on skype.

Sorry that I’m not very detailed, I usually am.


I just tried;
ffmpeg -f video4linux2 -s 320x240 -r 24 -i /dev/video0 -f oss -ac 2 -i /dev/audio1 test.mpg

and it worked. So, now I know it is possible, and ffmpeg, of course is command line and one can’t compose the shot.

BTW: were did you find that CImg, I was not successful in all my searches?

Thanks for going through this with me,

OK, I found CImg, and I don’t know how to place it either. So much for wxcam.

And I realize that I didn’t use the code command in my previous message.