USB audio adapter configuration problem


following situation:

A notebook with working loudspeakers but failing headphones – as soon as they are plugged in, there is no sound. This is most likely a hardware problem since it happens with Windows also.

A small USB audio adapter which is properly recognized by openSuSE (this is, by ALSA).

I now want to have this behaviour:

As soon as I plug in the USB audio adapter, the whole system should use it instead of the built-in sound system. Of course, as soon as a remove it, the built-in sound system should be used again.

How can I do this?

Any takers? I can’t believe that my wish is that strange… Before starting to write modprobe scripts by myself (by trial and error, I fear) I have hoped that someone had done this already.

Dependant on the hardware, I might be able to help with this. The more recent alsa drivers help some hardware codecs with this. However typically the manufacturers provide very good MS-Windows drivers, so if this never worked in MS-Windows, then maybe this is a hardware limitation. Frankly, I’m reluctant to recommend a dozen different trial-and-error steps if this is the case.

I don’t have a USB adapter. I have helped users get their USB adapter running, but not with the following HOTPLUG request:

I definitely can not help there with the above request. HOT-PLUG mounting and umounting is a much bigger request, and I have neither the hardware to test this myself, nor have I tried to help anyone with this.

Takers? Not me. As noted, I don’t have the hardware.

I may be able to help with a subset (ie basic sound with no special mounting features - but I suspect you have that working already).

I have tried to contribute in a few areas on openSUSE, writing a few openSUSE wiki’s on sound, but one thing that is a disappointment to me, is that users who have surround sound, or USB sound devices (with slightly different characteristics) have not (to my knowledge) taken the time to write openSUSE specific wiki’s with guidance for users like ourselves.

Good luck!

Some openSUSE wikis (which are unfortunately NOT relevant to your request):