usb 3.0 support - high speed - kde

I’ve been doing some reading about USB 3.0 support for Linux. As of 2009, Linux has support for it. You can setup your USB 3.0 ports to use the USB 2.0 commands. Now, opensuse leap 15 doesn’t recognize the USB 3.0 ports.

In other articles, I found that people doing speed tests got the full speed of a USB 3.0 ports. How do fix linux to support full USB 3.0 high-speed support?

Command:
‘lsusb’ doesn’t show USB 3.0 ports

‘journalctl’ doesn’t show anything when I plug into a USB 3.0 drive into a USB 3.0 port.

Need help.

Hi
It’s not the ports as such, it’s the root hub and driver :wink:

The bit your missing in your lsusb -s the -t option…


lsusb

Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 413c:2113 Dell Computer Corp. 
Bus 001 Device 003: ID 413c:3010 Dell Computer Corp. Optical Wheel Mouse
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
--> Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub <--
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 lsusb -t (USB drive plugged into USB 3.0 port)

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    |__ Port 3: Dev 4, If 0, Class=Mass Storage, Driver=usb-storage, 5000M

lsusb -t (Same device plugged into USB 2.0 port)

/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 1: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 2: Dev 4, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 2: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 5: Dev 5, If 0, Class=Mass Storage, Driver=usb-storage, 480M

lsusb -t
lsusb -s 1
lsusb -s 2
lsusb -s 3
lsusb -s 4

All no ‘usb 3.0’ listed. I’ve found some info about bios settings.

Maybe you’re using a mainboard that provides USB 3 with Windows drivers only? It happened to me.

I thought I had researched enough details about state-of-the-arts motherboards when I bought the Asus H87i-Plus for my main Linux rig five years ago. It has USB 3, but unbeknownst to me some fine print somewhere in the ASUS FAQ stated that in order to actually achieve USB-3-level throughputs, additional Windows-only ASUS drivers were necessary.

I bought a slightly wrong mainboard. Now my system is still USB-2 only, despite lsusb showing the 3.0 capability:

~ ▶ lsusb -s 1
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
**Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub**
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Oh well.
As an alternative to USB 3 speed, I use Gigabit ethernet whenever I need to transfer data quickly (Linux-eth0 to USB-3-capable MacBook to external USB-3 HDD), and that’s rarer than I first thought — turns out, monthly backups via USB 2 eventually finish just fine after a few hours.

It would be nice, though, to have faster USB. I will be extra careful as soon as I start planning the hardware for my next DIY computer.

Well, I may have a ‘lemon’ motherboard. GA-970A-DS3P (rev. 2.x) Overview | Motherboard - GIGABYTE Global

It has major hardware issue. I got a corsair 2400 memory set. On the msi motherboard, I could set 1866 memory speed. This board won't work higher than 1333.  :p    (For a later post about manually setting the values, if possible.)

I contacted gigabyte about 2 years ago. On the phone with tech support they couldn’t get it working in a few hours. I’m going to try again this month.

ethernet <–> usb cable?

Some mentioned you could use other commands to detect the ports.

Maybe it’s a motherboard driver error. USB 3.0 is reading like 2.0

What about a pci card that has usb 3.0 ports?

That is an option you could take.

Does linux support pci –> usb 3.0? Specific hardware or general support.

If I use ‘load optimized defaults’, then I enable ‘immu support’ to get my usb mouse to work.

I have a setting called ‘xhci handoff’ If it’s enabled, I get a long list of errors in the bootup. If I disable it, I get a shorter list of errors.

In researching, I found this group commands and info.

https://stackoverflow.com/questions/18479192/use-of-xhci-driver-and-usb-storage-driver

#dmesg | grep xhci
    2.182971] xhci_hcd 0000:02:00.0: xHCI Host Controller
    2.182979] xhci_hcd 0000:02:00.0: new USB bus registered, assigned bus number 1
   19.780373] xhci_hcd 0000:02:00.0: can't setup: -110
   19.780399] xhci_hcd 0000:02:00.0: USB bus 1 deregistered
   19.780472] xhci_hcd 0000:02:00.0: init 0000:02:00.0 fail, -110
   19.780497] xhci_hcd: probe of 0000:02:00.0 failed with error -110
#grep -i xhci /boot/config-$(uname -r)
CONFIG_USB_XHCI_HCD=m
CONFIG_USB_XHCI_PCI=m
# CONFIG_USB_XHCI_PLATFORM is not set
#lspci -v | grep xhci
        Kernel modules: xhci_pci
#lsmod | grep xhci
xhci_pci               16384  0
xhci_hcd              249856  1 xhci_pci
usbcore               286720  8 usbhid,ehci_hcd,ohci_pci,usblp,xhci_pci,ohci_hcd,xhci_hcd,ehci_pci
#

Does this help?

Looks like i’m not going to get USB 3.0 on this motherboard. Thanks for the help…

I’m going to buy another one. :frowning:

Thanks who fixed the problem. I now have USB 3.0 support for the first time, high speed transfers. :slight_smile:

GIGABYTE motherboard