USB 3.0 & openSUSE 11.2 (Kernel Version 2.6.31) Does it Work?

It is my understanding that the Linux kernel version 2.6.31 and higher supports USB version 3.0 and I saw other references to the NEC USB 3.0 adapter chip-set. I wonder if anyone here has gotten or tried to use a USB 3.0 device under openSUSE 11.2?

I recently purchased an external hard drive enclosure that supports USB 3.0. Should I purchase a USB 3.0 adapter and give it a try under openSUSE 11.2?

All comments are welcome.

Thank You,

Well, it would seem I did not get an answer to my question about using USB 3.0 devices with openSUSE 11.2, so I decided to find out for my self.

I am happy to report that indeed YOU CAN GET USB 3.0 to work with openSUSE 11.2 !

Now, I like to boot openSUSE from a external USB hard drive and this is only possible if the motherboard BIOS can work with the USB 3.0 ports directly, but alas, my motherboard does not work. Support for USB 3.0 devices, when the motherboard did not come with native USB 3.0 support, only comes about after the Operating System is loaded. I am able to use a USB 3.0 hard drive both in openSUSE 11.2 (without loading any new driver) and with Windows 7 (after loading a new driver).

Here is what I used for my USB 3.0 testing:

  1. BUFFALO USB 3.0 PCI Express card model IFC-PCI1E2U3 (Cost $45US from
  2. VANTEC NexStar3 External USB 3.0 Drive Enclosure model NST-380S3-BK (Cost $50US from Fry’s )
  3. Segate Barracuda 3.5" Sata Hard Drive model ST315005N4A1AS-RK (Cost $90US from Fry’s)

I do not think the hard drive type matters except it must be SATA to match the external hard drive enclosure.

Now you know, USB 3.0 Native Support in openSUSE 11.2 exists today and is ready for you to use!

Thank You,

I would assume the the USB 3.0 Standard is backward compatible, so the question would be are you getting USB 3.0 speed (as I understand it about time 10), or is it just working…?

Yes, I am getting USB 3.0 speeds. Now by that I mean it is faster than USB 2.0 on my computer. I think the maximum speed is 5 Gb/s, but as best as I can tell, the actual speed I got must be around 102 Mb/s (0.1 Gb/s). This compares to 34 Mb/s from my USB 2.0 hard drive. Loading files is about three times faster when compared to USB 2.0, but no where near the alleged maximum. None the less, it is cheap fix to get a 3x external hard drive speed-up. As they say, your mileage may vary and my test does not consider computer or actual hard driver performance. I copied 17.5 GB’s of files to/from the same drive and measured the time to determine my speed.

The only problem is without native USB 3.0 support in your motherboard BIOS, you are not going to boot any OS from an external USB 3.0 hard drive. I have been looking at motherboards and both ASUS and Gigabyte offer USB 3.0 support built into their motherboards. The only thing I do not know if it still works like an add-in card or can it support external booting with a USB 3.0 drive? I plan on picking a new motherboard to try, but once again I need a new CPU and memory as well to make it work. That is kind of out of my budget for the moment.

Thank You,

I need to update one line about my speed test, but the new forum setup does not seem to allow an edit so here is the corrected info:

“the actual speed I got must be around 102 MB/s (0.8 Gb/s). This compares to 34 MB/s”

Sorry for the error…

Thank You,

I stumbled across this thread a few minutes ago, as I am contemplating purchasing a new external hard drive to get even more offline storage.

I noted some of the external hard drives in our local PC shop support USB-3.0, so naturally, I was curious about USB-3.0 and linux.

Hard drive I’m considering (I already own an external USB-2.0 drive from Fantec): FANTEC GmbH - 1.5 TB USB-3.0 external drive

… but I can see I need to also find a USB-3.0 pci-e card. :slight_smile:

Turns out our local store only has this PCI-e USB-3.0 card: LogiLink® | PCI Express Interface Card USB 3.0 2x LogiLink® | 25.06.2010 … I need to research it a bit

The FANTEC GmbH - 1.5 TB USB-3.0 external drive drive I am considering notes they are “linux” compatible. But since I see no entry on the LogiLink® | PCI Express Interface Card USB 3.0 2x LogiLink® I decided to send LogiLink an email, and see what they say about Linux compatibility with a 2.6.31 or newer kernel. I don’t really expect an answer, but sometimes one is pleasantly surprised.

I took a look at the openSUSE HCL, but I could not find any mention of USB-3.0 external drives, nor of PCI-e cards supporting USB-3.0. Clearly some are supported, but as is typical the HCL lags.

Well oldcpu, I have tested exactly one external USB3 drive enclosure and one pcie USB3 card. Both work just fine with openSUSE 11.2. The only odd thing I ran into was that ever so often, the drive would not mount. So, oddly, as if it might really make any difference, I placed the mount command last in my fstab file. It seems to make it mount every-time. Is it possible the fstab mount order makes any difference? Well it did for me.

Of course, the real thing is the speed, It seems three time faster than my USB2 drive, but no where near as fast as the specification. I can not boot from the USB3 drive because my computer BIOS does not understand how to use it. USB3 only starts working after openSUSE or Windows is loaded, this is important to understand. None the less, such a speed up is worth consideration, even if you can’t load openSUSE on it.

Now one final note, don’t forget about eSATA. eSATA is just an externally mounted internal SATA drive. You need an eSATA drive enclosure, an eSATA cable and a PCI card slot eSATA adapter plate. I found one of these quick hard drive test rigs with eSATA made by Thermatake for $55 at Best Buy. I had a cable and adpter from one of the many motherboards I have purchased.

The thing about eSATA is that it is as fast as an internal SATA drive, but the eSATA cable can only be ran a short distance, like 18" or so from your case. I did setup one and loaded openSUSE on it which works like a champ. The drives sits right on top of the PC as that is as far as I can get with the cable.

Thank You,

I’m looking at an external drive to store data, and not interested in booting off of an external drive. … That limitation may affect others (but not me).

I think my Core i7 motherboard has an eSATA connection as does my Dell Studio 1537 laptop. But my other 2 PCs do NOT have an eSATA connection. Neither does my wife’s desktop PC, nor my wife’s laptop, nor my mother’s PC. Also, I confess I do not recall reading a post from anyone noting eSATA works with openSUSE-11.2. I DO recall reading some posts from users complaining it does not work. … But thats possibly the classic openSource problem. Users who have it working rarely post, and those who do not have it working complain loudly. It makes it difficult to assess the real situation.

The 18" is a problem. My external drives are about 50" to 60" away.

Having thought about it, I do not think an eSATA is compatible with my requirements. The extra speed would be real nice, but there are too many other compromises/complications specific to my setup.

I checked some of the German mail order sites and noted that a " BUFFALO USB 3.0 PCI Express card model" (which may be the same as what you have used) is available by mail order. So if I do not get satisfactory word back from LogiLink , I may go the BUFFALO PCI-e card route.

One other note, a USB3 enclosure (or complete USB3 hard drive solution), still works with USB2. This is why I would buy a USB3 external drive or enclosure as you give up nothing if you stick with USB2 now and have more when USB3 becomes more common in the future.

I already have my eyes on a new ASUS motherboard that includes USB3 and works with the new six core AMD chips and it is almost in my price range. I can almost feel the power, were it not for my many doctor bills I seem to have these days. Don’t worry though, it will be mine someday in the future, running at least openSUSE 11.3.

Thank You,

Please note:
eSATA USB 3.0 is backward compatible with USB 2.0. With a standard USB external cable speed is limited well below USB 3.0 standard but higher than USB 2.0 can reach, just as you found.

To Boot, the BIOS must support USB 3.0 standard. To USE, Windows can access with additional driver, Linux can access with the latest kernels even if the BIOS doesn’t recognise, this also is as you found.

With an USB 3.0 compatible cable/CARD/MBO pairing, and appropriate drivers for Windows/Linux you will get full speed +/- 2% of the stated and the ability to Boot from it and up to 10 feet cable distance.

I’m trying to wrap my occasionally thick head around this one. … ie … does this mean if I purchase a USB-3.0 PCI card and an external hard drive that supports USB-3.0 , that in order to take advantage of this, I need also to purchase a USB-3.0 cable (which is presumably different from a USB-2.0 cable) ?

It appears to me that I do need to also purchase a new cable (if it does not come with the hard drive) based on your post and also on various web articles such as this one I’m quoting.

You are correct in the assumption. The USB 3.0 cable provides two way communication, higher speed, longer 10 foot runs via improved shielding against crosstalk, higher power. The USB 3.0 controller (MBO or cardslot type) provides for greater power supplied to the USB connection, handshaking for the two way communication, and access to the higher speeds via the device drivers. Now on the USB 3.0 device side, the drive will function from a USB 3.0 cable at full rated specs but if connected via a standard USB 2.0 cable will be limited to that technology. A USB 3.0 drive is capable of much higher speeds than it’s USB 2.0 counterpart. So when you use a USB 2.0 HDD you never come close to the full rated speed of USB 2.0 simply because the drive just doesn’t have that potential. A USB 3.0 drive connected with a USB 2.0 cable to a standard USB 2.0 port achieves a much faster transfer rate because the drive can function faster and the cable can handle the faster drive action.

Linux, can access a USB 3.0 drive because it gets the standard polled responce back from the drive in USB 2.0 style using it’s device driver in the kernel. Windows can use the USB 3.0 drive because it’s supplied USB 3.0 driver (came with the drive) tells it how to access the drive in USB 2.0 mode when USB 3.0 port in the computer isn’t present.

The BIOS of a non-USB 3.0 system can’t boot from the drive because when it polls the drive it’s limited ROM routines can’t understand why the drive reports USB 3.0 and DTR of 4.7GB

Just adding a USB 3.0 card will allow faster transfer rates closing in on 480MB/s (without special driver software) but to get full access the Linux kernel will need full USB 3.0 driver support for 4.7GB and the drive is too new yet. This leads us to another Chicken and egg problem.

In Linux we have always lagged behind due to Proprietary device drivers and the industry not willing to share on a fair even scale. While Intel is spearheading the way into USB 3.0 with their own rendition of the specs, Abit, Gigabit, AMD, nVidea, and others are also planning to release their own versions of the specs in hopes of squeezing the others to conform to their’s. This is really Bad for an innovation (harddisks) which have always enjoyed a sharing so that people would be free to upgrade their systems. I guess they think that because a USB 3.0 Hdd is decidedly an external device the claim to proprietary rights apply.

Bottom line is who has enough of a clout to settle the dispute and force friendly co-operation…

Also, the USB3 cable I have came with the USB3 hard drive enclosure. So, I did not have to purchase a separate one. Check the included items for the USB3 drive you purchase.

Thank You,

In reply to my email query to LogiLink on the Linux compatibility of their LogiLink® | PCI Express Interface Card (PC0054) USB 3.0 2x LogiLink® , I received this today from LogiLink:

you can only use the PC0054 with Windows XP/VIsta/7 and Mac 10.3 or higher.
We can’t offer you a Card for Linux or Linux Distributions.
Now I suspect this LogiLink PC0054 card may indeed work with a recent Linux kernel, but clearly the manufacturer won’t admit to it. So scrap that card, and it looks like I’ll be ordering a BUFFALO USB 3.0 PCI Express card model IFC-PCI1E2U3 from the internet. I did a search on an Austrian search page for computer products and for that card obtained many hits. … After shipping, it won’t be cheap.

I found a datasheet for the Buffalo USB-3.0 IFC-PCIE2U3 and I note they also do not claim any sort of Linux compatibility.

Fortunately user jdmcdaniel3 has paved the way here, and knows that the the Buffalo USB-3.0 IFC-PCIE2U3 card works with openSUSE-11.2.

I need to compose a reply to LogiLink, thanking them for their reply. I have not yet decided if I should mention one of their competitors USB-3.0 cards has been proven by user test to work with Linux. Heck if they (Logilink) would send me a card (for free) I could even test it for them against the USB-3.0 drive I plan to purchase, … but I don’t plan to mention that as such testing may entail more time than I am willing to give to this.

I did a bit more research here, and I may have a problem with this card, … in fact, … maybe with all USB-3.0 cards. I noted this caution wrt the Buffalo USB-3.0 card:

Chipsatz: NEC • Achtung! Die volle Geschwindigkeit wird nicht erreicht auf Mainboards mit Intel H55/H57/P55/Q57/X58 Chipsets.
and pumping that into a computer translator gave:

Chip set: NEC • Note! The full speed not reached on Main boards with Intel H55/H57/P55/Q57/X58 chip set.
… where my motherboard has an X58 chipset and hence that does not read to be too promising.

Another popular mail order card is the ASUS U3S6, 2x USB 3.0/2x SATA 6Gb/s, PCIe 2.0 x4. but then I noticed this caveat:

Achtung! Nur mit folgenden Modellen kompatibel: Maximus III Formula, P7P55D Deluxe, P7P55D EVO, P7P55D PRO, P7P55D, P7P55D LE, P7P55 LX, P7P55 WS Supercomputer, P6T Deluxe, P6T Deluxe V2, P6TD Deluxe, P6T SE, Rampage II Extreme, Rampage II GENE, M4A79T Deluxe, M4A785TD-V EVO, M4A77TD PRO, M4A79T Deluxe/U3S6, M4A77TD PRO/U3S6, M4A785TD-V EVO/U3S6
where the board is red is my main board. … My German is not good enough for me to understand if that indicates it works best with those boards, or does NOT work with this boards. Edit - checking the English web site it appears it does work.

… but the above has cooled me down on this. I’m not going to jump into a purchase until I sort out the risk of incompatibility (for full speed) with my P6T Deluxe V2 motherboard.

This Asus card may indeed be the card I need to focus my compatibility searches on (as it is noted on the Asus website as being specifically compatible with my PC’s main board). ie I now need to confirm that it works with Linux ?

oldcpu, my motherboard is a ASUS M2A-VM using the AMD 690G chipset and provide AM2 AMD CPU support. The cost was around $50 and so I decided to give the PCIe card a try. I did find one post of someone else saying the BUFFALO card did not work with Linux, but I found that the chipset on the PC card did work with Linux, so I decided to give it a try. And it does work for me, but I did not consider any motherboard chipset issues.

Thank You,