US keyboard layout after login in KDE

I have FI - Finnish and FI - Finnish (Windows) keyboard layouts enabled in Kde (no US layout at all), but every time I reboot and login the layout is US until I manually change it. How do I get rid of US layout permanently?

One possibility is a wrong setting in YaST. The YaST setting should be the same as the physical keyboard. Then KDE can make the conversions from the hardware layout to the software layout.

I finally figured it out, I had installed Zoom which in turn installed IBUS which seems to cause this issue.

…Goodbye IBUS and Zoom.