US-Intl layout, problem with one letter

Hi all.

I am using English US, US International layout because I live in Brazil and I need portuguese characters, but cannot get used to ABNT2 keyboard layout. So, US Intl works for me.

However, no matter what linux is (openSuse, Ubuntu, Fedora…) all has same problems
(my current systems are suse 10.3 desktop, 11.0 laptop and ubuntu at work)

Instead of writing “ç” it writes “ć”
(key combination apostrophe+c)

How to fix it?


Shouldn’t you be using comma + c?

I use US-intl too for “ç” I use rightAlt + comma.

Right Alt + Comma works.
Comma is not a special key so comma+c does not work.

OK, I didn’t know for Right Alt + Comma. When I started using US-Intl it was on windows and there is apostrophe+c. I reckon it should be the same. I resolved the problem by installing ABNT making a quick-switch just because of that letter.

Anyway, problem is now solved… I shall use Right Alt + Comma from now on.

Just out of curiosity, is there a way to make linux work as I want, I mean, regarding this key combination?

You can configure input actions in KDE, but I’m not sure you can configure comma+c as a combination since neither is a “special” key.

Well, I will think on some workaround…


What I do for diacritics is enable the Compose key so that I have the standard compose sequences that Xorg knows about. In YaST > Hardware > Keyboard find the Menu is Compose checkbox and turn it on. Menu is the normally useless key next to the Windows key. Or use the Windows key for Compose. (And for good measure, if you hate the Caps Lock key like I do, turn on Caps Lock is additional Ctrl.)

Now you can enter diacritics with 3 key sequences:

Euro sign € is Compose = C
c cedilla ç is Compose , c

and so forth. Here are all the supported Compose sequences:

Compose key magic « Cyberborean Chronicles

Thank you very much. I will try that


I tried to follow some of the instructions on the “cyberborean chronicles” link, but when I try to edit /usr/share/X11/locale/en_US.UTF-8 VIM tells me that is an illegal file name… I am logged as root and the file exists =S

Also, I am used to type ’ + c in order to type ç, with compose keys I will need to press compose key first? If this is how it works, is there a way to skip that compose-key-pressing part?

I’d really appreciate some help, I’m quite lost =/ Thanks in advance!

I just gave up. There is no easy way to do it.
Easier is to get used to “right ALT” + “,”
after a couple of days of irritation, I got used to it.

Well, I don’t really care if it’s easy or not, I have other distros to use meanwhile.

  • If you’d like to do it too, just install any gtk-based distro, use us-intl keyboard anf put export GTK_IM_MODULE=“cedilla” in /etc/environment (~/.bashrc didn’t work for me) -
    Plus, I use Firefox and Thunderbird. I can live without this weird cedilla even in there with the tip above =D
    Maybe it’s time to talk with the KDE team as well :slight_smile:

You’re probably right. I started nagging developers recently, about all stuff I think it can be done better… LOL
Maybe one will listen;)