urgent: permission problem with networkmanager

I have a curious problem, but it causes me a heck of a problem. I cannot connect to wirless with my machine anymore with normal user accounts. What happens is that nm-applet as usual requires superuser rights and therefore asks for the root-pwd. But if you type this in, nothing happens.
So you might think the passwrd is wrong, but it isn’t.
It is just the window of the nm-applet that apparently does not “see” what I type.
This seems to be for me a permission related problem.
I tried to create a new user account. I did try to connect with this account. Same, very same issue. Password is as if it isn’t typed in.
Now if I go and (yes I know you do not do that, so just DON’T post that comment: do not login as root in a GUI. I KNOW about the problematic and I did NOT access /home) login as root it does as expected connect to the network.
Now I do not find anything wrong in my permission.secure or in any changes in policykit. So I am a bit baffled. where in all world can be the problem that represents consistently in all KDE users created (but root of corse).
I am VERY greatful for all usable hints and advices where to check which permission. I have had this problem after setting up virtual-box (which gives me the same “the UID is not root” and aborts). But I had some problems before this happened lately, sometimes needed to type the password 4 times or more before getting it accepted.

So what was different when you could connect with NetworkManager ?

What do you see in the NetworkManager log ?

Hi Stakanov. So, I assume from your reference to ‘nm-applet’ you’re using Gnome? Which version of openSUSE? Have you tried reconfiguring the desired wireless connection as a ‘system connection’ to see if that helps with connectivity?

hi both of you and thank you for the reply. I am very puzzled. By trial and error I found out that now, although again secure permissions are set, the system is asking me not the root password to create a wireless connection but my user password??? Yast and shutdown are staying normal on root password to start (and of course shutdown).
What I do not understand, where are the permissions for nm-applet (gnome) set. I am using nm-applet within the KDE4 environment as a substitute for networkmanager because the KDE version (at least in this version of 12.1 still) did not work for me.
Now up to now the behavior was the one note to everyone that you where required the root password for authorization.
So now for Wlan and for VPN suddenly it is the userpassword?
Where do I have to look to see where these permissions have been changed? As I write you, I can connect, permissions are set to secure and so this is actually strange that I can set the wirless via the userpassword.

I guess these are some policykit settings. There has been some resent updates regarding this on my system. I’ve got no idea where to look what these settings are and how to change them.

I’m inclined to agree with glistwan here, although I’m not a Gnome user, so can’t confirm. Anyway, I suggest you have a look at the NM policy settings with

pkaction --list

FWIW, I have the following NM policies defined


The check a given policy. For example

pkaction --action-id org.freedesktop.NetworkManager.use-user-connections --verbose

It is possible that it wants to open the Gnome keyring, although I would have thought that the prompt would indicate that. You could try running “seahorse” to see what it shows as in the gnome keyring.