Whoa… nightmare. First of all: We are talking about 11.1 here.

Here’s what happened: Yesterday night I worked on my system as usually. After a reboot I noticed that login in wasn’t possible because after entering the data (username and fingerprint) the screen blacked, the NVIDIA-sign shows up and… the the login window prompted again - same thing forever.

Clever as I am I went into console mode (STRG+ALT+F1) and noticed the screen said “…no space left on device”. So what I did was something I did once before (and it worked before) - to completely delete the directory /tmp.

Wrong decision, guys. NEVER delete any data from your root partition by hand if you don know what it causes!

Rebooting via Grub now showed, that several processes failed and I did not get any login screen - except for the login via bash. Next? Recovery through the Installation DVD. ~ba-baam, I started to sweat…

So what does it boil down to? I figured to create an new directory /tmp in root - and that partially did the job. There are only 2 or 3 processes that are still failing, but fortunately I get back to the login screen. The installation DVD could not recognize errors in the file system anymore. Except for one: No Linux root partition found!

I know the root files are still there - so what to do? Gimme a nuge and don’t blame me for deleting stuff. :wink:
As I said: I LEARNED from it.


What permissions do you have on /tmp and who is the owner.
If I’m not mistaken, /tmp has a special attribute of t so it should
look like drwxrwxrwt and be owner group of root root.

Oh, you mean the remaining errors could be due to missing rights? That’s very well a possibility…
I’ve created that folder via Live-CD. How do I check those rights - is there a command to check?

And hey, huge THANKS for answering. :slight_smile:


How about “ls”?

:stuck_out_tongue: Of course…

drwxrwxrwt   5 root root     4096 May  5 15:15 tmp/

Somehow that folder is marked green. Would chmod 777 be the correct choice in this case?


Why would you want to do this?

The permissions are OK, as you were also told before.

Darn. I just don know how to proceed. All files are still there and I’d really like to get back in as usual.

The following ‘basic’ files exist:

drwxr-xr-x   2 root root     4096 May  4 21:01 bin/
drwxr-xr-x   3 root root     4096 Apr 18 21:12 boot/
-rw-------   1 root root  1515520 May  5 10:12 core
drwxr-xr-x   5 root root     4096 Jan 18 21:13 dev/
drwxr-xr-x 117 root root    12288 May  5 15:15 etc/
drwxr-xr-x   2 root root     4096 Jan 18 21:13 home/
drwxr-xr-x  13 root root     4096 Apr 18 20:33 lib/
drwxr-xr-x   7 root root     4096 Apr 18 20:52 lib64/
drwxr-xr-x   2 root root     4096 Feb 16 11:18 local/
drwx------   2 root root    16384 Jan 18 21:11 lost+found/
drwxr-xr-x   2 root root     4096 May  3 21:24 media/
drwxr-xr-x   2 root root     4096 Dec  3 10:23 mnt/
drwxr-xr-x   5 root root     4096 Mar 28 22:21 opt/
drwxr-xr-x   3 root root     4096 Jan 18 21:13 proc/
drwx------  41 root root    20480 May  4 20:17 root/
drwxr-xr-x   3 root root    12288 May  4 21:01 sbin/
drwxr-xr-x   4 root root     4096 Dec  9 21:50 srv/
-rw-r--r--   1 root root        0 May  5 15:15 success
drwxr-xr-x   3 root root     4096 Jan 18 21:13 sys/
drwxrwxrwt   5 root root     4096 May  5 15:15 tmp/
drwxr-xr-x  13 root root     4096 Dec  9 21:50 usr/
drwxr-xr-x  15 root root     4096 May  4 18:23 var/

What would YOU recommend as the next step? Any missing files you might catch?


Well, I just did deliberately what you did by accident before, started my VBox, logged in as root, deleted /tmp completely and rebooted.

There were some complaints that /tmp was missing, but I could login as root and recreate the /tmp-Folder without problems.

So I seriously doubt, that you only deleted /tmp or at least you hosed up your system at another point.

I hope you have recent backups :slight_smile:

I am able to access ALL my files via console as well as LIVE-CD.
Think is, that booup somehow fails (after logging in with the normal login screen, it blacks and returns to the login screen).

DARN. Any suggestions? I’ve pasted my full DMESG right here: Private Paste :: Paste 6eS12zprjq

Please take a look at it. I would LOVE to be able to get back into my system. by the way: I’ve noticed that all folders insode /root do not contain much except for some files I’ve stored on the roots desktop.

Is it possible to “re-generate” that directory somehow? :wink: Thanks for every helping answer you might throw at me.


What errors do you actually get when you try startx from the cli?

We had something about no space, so what does df -h tell you? All along we’re making the presumption it is / but it could be home.

Nothing out of the ordinary, not even one failed service.

Some more information on Errors when logging in would make sense.

Do you mean that you are not able to do graphical login only?

If that is the case, what is your desktop? You delete the desktop configuration drectory (or just move it away).

For example, if it is KDE4, do a text login, go to your home directory and delete/move the .kde4 directory. Then, logout and try the graphical login again.

cd /home/yourlogin
mv .kde4 .kde4.saved

Thanks syampillai - I’ll try that after I’ve answered the previous questions:

  1. startx returns:

Fatal server error: Server is already active for display 0… bla…bla…bla…

  1. df -h returns:

Filesystem Size Used Avail Use% Mounted on
/dev/sda2 58G 58G 0 100% /
udev 2.0G 96K 2.0G 1% /dev
/dev/sda3 231G 123G 99G 56% /home

Looks like /dev/sda2 is full. That was the reason for my previous actions. :wink:
Anyway - here the errors shown in text mode of cli at bootup:

Starting java.binfmt_misc ---- failed

Failed services in runlevel 5: vware avahi-daemon

Iĺl be right back. Gotta throw up - hang on…


Which obviously failed.

As long as you don’t remove some unneccessary files, that will also not change.

How did you “delete” the /tmp-folder before?


(How can one fill up / with 58GB (!) when there is an extra /home? Congrats, looks like a world record for me…)

Good guess. I deleted the folder with a Live-CD. Moving the .kder4 folder did not help any.
You guys think freeing some space for the porn might be the solution? :smiley:


No, but freeing some space by deleting some of your porn might help.

Dude, do you take everything that serious? Anyway - I am wondering WHAT to delete because if I look at /dev/sda2 via LIVE-CD, there are only essential folders. In /dev/sda3 though, there are all my other files…


No, but you obviously just did.



The command “du” is your best friend.

I already told you, filling up / with 58GB of space is a world record, there MUST be some unnecessary files (and you should delete files, not folders, but I think you already figured that out after deleting /tmp :D).

Please clarify that. Should I just execute “du”? What does that help to solve the issue?
Yes, I am serious. I am Arnold Schwarzenegger.


Then read

man du

Mr. Governator :slight_smile: