upgrading windows when Suse is on the same hard disk

I know that it is mainly a windows problem but I am sure that the Suse group will be more helpful!!
I have a dual boot machine with windows Vista and Suse 11.1 working well with GRUB
the C: partition of windows and the /usr and swap partitions are on the same primary disk.
of course the data of both systems are on a secondary disk.

when I try to run the upgrade windows disk to go to windows 7, this stupid program detects the /usr partition and try to use it as “a new systemVolume” and of course crashes…

I know that I can erase the Linux partition and do the microsoft solution but as I have already a good suse environment (with NVIDIA-CUDA installed) I don’t want to destroy this /usr partition.

So any help will be good.

You have run squarely into the Microsoft only thunker! You need to do 2 - 4 things. 1) back-up all important data, settings 2) make a boot method for recovering your Linux system 3) try to back-up mbr 4) re-attempt winblows 7 upgrade paying attention to each screen about possible choices.

Windows 7 uses 2 partitions instead of just 1, so it wants to make a seperate one for the boot stuff. I would guess that’s where the problem lies.

You might have to mess around changing your Linux partitions as Microsoft don’t believe in letting the end user choose what to put where.

As techwiz suggests, the best way would be to backup what you want to keep, install win7, then re-install Linux.

thanks for the two replies,
I agree with you that a full backup and recovery of my linux root partition will solve my problem, but I was expecting a “simpler and faster” solution to avoid it.

too bad!! as usual Microsoft forces us to follow their rules…>:(>:(

> too bad!! as usual Microsoft forces us to follow their rules…>:(>:(

no, you are not forced…

in fact, you willingly pay (too much) money to willingly accept
their rules.

see, you have the same choice that all do:

  1. install Microsoft software
  2. do not install Microsoft software

no force involved…

running 10.3 and seeding while downloading 11.2 DVD (64) and GNOME Live CD

Since when ??

Every version of windows only needs one partition, the only necessary thing is that the bootfiles need to be installed on the first primary and active partition. The rest of the OS can be anywhere.

So if the first partition is active and you use that one for windows it will only use that one, nothing else.

The TS might need to check the partition order and setup prior to installing windows. I have the following list of Operating Systems on my laptop without issues and all of them except opensuse 11.1 uses only one partition : OSX Leopard, Windows Vista, Windows XP, opensuse 11.1 and in between a swap partition for windows, and EFI partition needed by OSX in the beginning of the disk, a ReiseFS partition containing the disk image from Microsoft Small Business Server in VMWare running on opensuse and a data partition at the end. Finally a hidden HPA partition from Acronis True Image.

So you see, it can be as complex as you want, only be carefull when installing.

I used the version you can download and “try before you buy”, and it automatically created a seperate 100 megabyte partition for some system files.

I tried it on 2 laptops, and it did the same on both!

Windows 7, unless you already have an ntfs formatted partition to install it into, will always create a separate hidden boot partition in addition to its shown C: drive.

But! Once I was aware of that after playing with the RC for a while, I now install 7 in a way that has it only create one!

Basically I tell Windows to create its partition, say ok to its message that it “may” create an additional “System” partition, delete it and expand what remains to fill the entire area. Windows then proceeds to install all it needs to the single partition in the traditional way since it sees the single formatted ntfs partition that it, itself has created.

That way is more desirable than using an XP or other program’s partitioner for the ntfs partition because then you will be using Microsoft’s latest version of ntfs.

I wouldn’t have bothered if I were just using Windows, but I found that grub had problems booting Windows from that hidden system partition and that Windows bcd had problems booting Linux using Easybcd as well. So neither installing grub into the mbr (no Windows boot) or installing grub into the Linux root partition (no Linux boot) was working for me. Installing Windows into the one partition solved those for me. I now use EasyBCD to bootup Linux on my second hard drive and the Windows loader (of course) finds Windows and EasyBCD’s NeoGrub finds Linux just fine.

Well I tried to edit but I ran into the time limit.

Anyway, if you go the EasyBCD route (to use the Windows boot loader to chainload grub in the Linux partition instead of putting grub into the mbr) make sure you join the neosmart.net forum to download and use the latest EasyBCD 2.0 beta. The released version doesn’t handle Windows 7 that well nor grub2 that most recent Linux distros are using but the latest beta handles both fine.