Upgrading to php 5.6?

I’m running OpenSuse 13.1 and have run yast and done a full update.
I also have PHP installed and its reporting:

Version: 5.4.20-30.1 Installed: 5.4.20-30.1

Why is the online update saying everything is up to date when I’m on php 5.4.x - how can I upgrade to the latest php stable - 5.6.0?


You can do it by copy pasting these commands as root;

zypper ar -f http://download.opensuse.org/repositories/server:/php/openSUSE_13.1/server:php.repo
zypper ref

At this point it will ask you to "trust" the repository, press A to always trust the repository, it's maintained by openSUSE guys 

zypper dup --from server_php

Restart Apache for the php 5.6.0 module to take effect.

Because the latest version released as update for 13.1 is indeed 5.4.20-30.1.

And it is openSUSE’s policy to not provide version upgrades in the official update repos.
Bug- and Security fixes are backported to the shipped version.

  • how can I upgrade to the latest php stable - 5.6.0?

You can add an additional repo and install it from there.
But why do you want to do that? Any specific reason?
If you are just worried about bugs or security problems:
You are not really using 5.4.20, a lot of bug and security fixes have been added by (open)SUSE.
Have a look at the package changelog:

rpm -q --changelog php5
* Wed Sep 10 2014 pgajdos@suse.com
- security update:
  * CVE-2014-5459 [bnc#893849]
  * CVE-2014-3597 [bnc#893853]
  * CVE-2014-5120 [bnc#893855]
- fixed suhosin crash if used with php session_set_save_handler()
- added patches:
  * php-CVE-2014-3597.patch
  * php-CVE-2014-5120.patch
  * php5-suhosin-crash.patch

* Thu Jul 17 2014 pgajdos@suse.com
- security update:
  * php-CVE-2014-4670.patch [bnc#886059]
  * php-CVE-2014-4698.patch [bnc#886060]
  * php-CVE-2014-4721.patch [bnc#885961]

* Mon Jun 30 2014 pgajdos@suse.cz
- security update [bnc#884986], [bnc#884987], [bnc#884989],
    [bnc#884990], [bnc#884991], [bnc#884992]
- added patches:
  * php-5.4.20-CVE-2014-0207.patch
  * php-5.4.20-CVE-2014-3478.patch
  * php-5.4.20-CVE-2014-3479.patch
  * php-5.4.20-CVE-2014-3480.patch
  * php-5.4.20-CVE-2014-3487.patch
  * php-5.4.20-CVE-2014-3515.patch

* Tue Jun 17 2014 pgajdos@suse.com
- security update:
  * php-5.4.20-CVE-2014-4049.patch [bnc#882992]

* Tue Jun 03 2014 pgajdos@suse.com
- security update
  * CVE-2014-0237 [bnc#880905]
  * CVE-2014-0238 [bnc#880904]

* Fri May 09 2014 pgajdos@suse.com
- security update
  * CVE-2014-2497.patch [bnc#868624]
  * CVE-2014-0185.patch [bnc#875826]

* Fri Dec 13 2013 pgajdos@suse.com
- security update
  * CVE-2013-6420.patch [bnc#854880]
  * CVE-2013-6712.patch [bnc#853045]

* Wed Sep 25 2013 pgajdos@suse.com
- updated to 5.4.20:
  * About 30 bugs were fixed.

PHP 5.6.0 has vastly better performance when combined with php5-opcache by the way, that’s one really good reason to upgrade it and use php5-opcache module :slight_smile:

Well, of course there might be valid reasons to upgrade, yes. That’s why I asked.

But upgrading just to have the higher version number is probably not worth it… :wink:

Thanks all - upgraded perfectly.

I need to run 5.5 or above as I want to use the array_column function.