Upgrading to KDE 4.2 issues

I am using the KDE 4.2 repo and the 4.2 community repo to upgrade to KDE 4.2, but there are problems.

Firstly, the KDE4base does not show up in the 4.2 repo. How do I upgrade the base?

Secondly, I tried to upgrade all in the list if newer versions exist, under 4.2 repo, but there are SO MANY dependency issues it got insane.

Any ideas?

I haven’t committed to anything yet.

I did it simply by going to KDE/KDE4 - openSUSE

The only dependency conflict I got related to Gwenview; so I asked it to leave the earlier version and I have had no problems.

KDE4.2.* (How To Add) Guide. - openSUSE Forums

I have read threads where users disable ALL repos except oos and non-oss, keeping of course the kde42’ repo’s
and this eliminates some of the issues.

FYI- there were changes in naming policy. On release packages like amarok were kde4-amarok
Now it’s amarok

and the kde3 ver is: kde3-amarok

Dependency issues are easy to resolve, just remember this and you want to change vendor to Build Service

Personally I leave my repos intact and change the repo Updates priority to 99

I forgot to mention I am upgrading from KDE 4.1 to 4.2

The main problem I have is with kde runtime 4.2, which it doesn’t find and is required for so many packages.

I have been running KDE 4.1 since installation of SuSE and have added many packages. I don’t want them downgraded or changed due to some problem with a dependency being upgraded and incompatible, etc…

Upgrading plasma changes ktorrent plasm, which changes ktorrent and makes the dht addon function unavailabe.

What a mess!

Ok, I am in the middle of the one-click install recommended above.

Illiteracy again in KDE…

“The applications a KDE 4 installation would contain if it would be the default desktop.”

What does this mean? It heads an empty box. There is no colon, so I am not sure if there should be a list following it or not. It sounds like it, but the punctuation is messed up and the absence of a list makes it suspicious. Can’t people communicate in English when using English? Wow…

Ok, rant phase over… continuing with install.

Next screen:

If you continue, the following changes will be made to your system:
Repositories to be added:
Index of /repositories/KDE:/42/openSUSE_11.1 (KDE:42)
Index of /repositories/devel:/tools:/building/openSUSE_11.1 (devel:tools:building)
Index of /update/11.1 (openSUSE:11.1:Update)

You will remain subscribed to these repositories after installation.
Software to be installed:

Looks fine.

Using the customize button has no way of getting back out of the customize mode, even with going back and clicking next again. ARGH!

Restarting one-click install.

Beautiful! When I click Next on the second screen I get a warning:

Have you reviewed the changes that will be made to your system?
Malicious packages could damage your system.
]Do not ask me again
Yes / No

My GOSH! So with the default I might get malicious packages installed on my system? :’(

I clicked yes and got another confidence builder.

Import Untrusted GnuPG Key…
meaning that you trust the owner of the key. You should be sure that you can trust the owner and that the key really belongs to that owner before importing it.

What in the world! I do not even know who it is. How can I be sure I can trust them? This is allowing someone access to my system as if they were my good friend. Scary!

Next screen… (I trusted just to get to the next screen, which I am afraid anyone would do):

Perform Installation
(nothing below that)

Suddenly, out of the blue - DONE!

Final Screen:

Software installation
The installation has failed. For more information, see the log file at /var/log/YaST2/y2log. Failure stage was: Installing Packages
Error Message
An error occurred while attempting to install the specified packages. Review the yast2 logs for more information.

Excellent! I wanted to dig through log files and read a mess of output. :open_mouth:

It’s there. Pic of mine (I use 4.3)

also pic of the 42 repo

http://thumbnails12.imagebam.com/3843/2fbdf338426715.gif](http://www.imagebam.com/image/2fbdf338426715/) http://thumbnails13.imagebam.com/3843/9f26f138426726.gif](http://www.imagebam.com/image/9f26f138426726/)

Nice, but why would it claim this didn’t exist? My repo is enabled and on refresh.

Just post your dependency error.
Use the expert button in the error box to save to file and then paste here. We’ll take a look

I tried the one-click install again and it gave me a very long list that shows that it wants to change the vendor on nearly everything installed and that it wants to downgrade everything else.

I thought this was an UPGRADE… :X

Well, it looks like I shouldn’t do this on my production system I use for my daily work.

Whilst you are at it give me this

zypper lr --details

You won’t believe what just happened!

I got the list and tried pasting it, but the forum gave me this error:

The following errors occurred with your submission:

  1. The text that you have entered is too long (108276 characters). Please shorten it to 15000 characters long.

HA HA HA!!! It never ends! This is a forum for discussing and posting exactly these sorts of things and there is this sort of limit! My Gosh! What a comedy of errors! rotfl!

Ok, we will do it the Windows 3.11 way…

I will post one tenth of the file here and then a tenth and then a tenth and then a tenth and then a tenth and then a tenth and then a tenth and then a tenth and then a tenth and then a tenth. By noon I should be done.

Use an online service like pastebin

I’ve put it up here.


I don’t know what pastebin is. Never heard of it. It must be a work around for a crippled forum like this one, right?


Pastebin.com is a debugging site. Did you mean pastebin.ca?

@recraig2: I just can’t believe it anymore. Deano_ferrari helps you out to make K the default file manager, and in the mean time you’re upgrading your KDE4.

My question is: Are you using the forum to get things working with help of other people or do you regard us as a wall to throw your frustrations against?

If I just take a look at the threads I can only suggest to READ READ READ, then do a clean install, then add the KDE4 repos, then update all packages in these repos. But, in fact I don’t know why I’m suggesting anything anyway.

Having read the post right above this one, I indeed regret the suggestion

First post:

zypper lr --details

Yes, knurpht. I don’t need those kinds of suggestions. I am not a programmer or a kid playing with his computer for fun. I am a working adult, as I suppose are you, using it on a daily basis for my work.

There are some frustrating aspects of KDE 4.1 I would like to get rid of. I tried the suggestion about the browser change and there was an error, if you recall reading. I solved that myself. However, the suggestion was made to upgrade to 4.2 Whether I do or not is my choice, not yours. If you want to help, I would be appreciative, but if you want to cause troubles, please bother someone else. Thank you.


zypper lr --details

Thanks caf4926

Here it is

Seriously dude this is ridiculous:

  1. 1 | KDE_4.2 | KDE 4.2 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/42/openSUSE_11.1 |
  2. 2 | KDE_4.2_Community | KDE 4.2 Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42 |
  3. 3 | Mondo_Rescue | Mondo Rescue | Yes | Yes | 99 | rpm-md | ftp://ftp.mondorescue.org/suse/11.1/ |
  4. 4 | QT_4.4_for_KDE_4.2 | QT 4.4 for KDE 4.2 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Qt44/openSUSE_11.1 |
  5. 5 | devel:tools:building | devel:tools:building | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
  6. 6 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
  7. 7 | openSUSE-Education Updates | openSUSE-Education Updates | Yes | Yes | 99 | rpm-md | Index of /download/updates/1.0/11.1 |
  8. 8 | repo | NVIDIA Repository | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1 |
  9. 9 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
  10. 10 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
  11. 11 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
  12. 12 | repo-source | openSUSE-11.1-Source | Yes | Yes | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
  13. 13 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |
  14. 14 | repo_1 | openSUSE BuildService - Wine CVS Builds | Yes | Yes | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.1 |
  15. 15 | repo_10 | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | Index of /repositories/games/openSUSE_11.1 |
  16. 16 | repo_11 | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
  17. 17 | repo_12 | openSUSE BuildService - Database | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/database/openSUSE_11.1 |
  18. 18 | repo_13 | openSUSE BuildService - PHP | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/php/openSUSE_11.1 |
  19. 19 | repo_14 | Main Repository (Sources) | Yes | Yes | 99 | yast2 | Index of /source/distribution/11.1/repo/oss |
  20. 20 | repo_15 | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
  21. 21 | repo_16 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
  22. 22 | repo_17 | openSUSE Education | Yes | Yes | 99 | yast2 | Index of /download/repo/1.0/11.1 |
  23. 23 | repo_2 | openSUSE BuildService - GNOME:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_11.1 |
  24. 24 | repo_3 | openSUSE BuildService - GNOME:STABLE | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/STABLE/openSUSE_11.1 |
  25. 25 | repo_4 | openSUSE BuildService - KDE:Backports | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.1 |
  26. 26 | repo_5 | openSUSE BuildService - KDE:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.1 |
  27. 27 | repo_6 | openSUSE BuildService - OpenOffice.org | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 |
  28. 28 | repo_7 | openSUSE BuildService - Virtualization (QEMU) | Yes | Yes | 99 | rpm-md | Index of /repositories/Virtualization:/Qemu/openSUSE_11.1 |
  29. 29 | repo_8 | openSUSE BuildService - Virtualization (VirtualBox) | Yes | Yes | 99 | rpm-md | Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.1 |
  30. 30 | repo_9 | openSUSE BuildService - X11:Compiz | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/Compiz/openSUSE_11.1 |

Follow the advice of some others, who have disabled all but the kde42’s, oss, and non-oss

I’m not even going to begin trying to decipher all that mess. Sorry but there is no other way to describe it.