Upgrading to glibc 2.33 on Leap 15.3?

Hi everyone, I have the following issue.

I have a brand new HP ZBook Firefly G8. Great laptop, but it has Intel XE graphics which are not supported by kernel 5.3.18 (stock 15.3 kernel), and on top of that, the kernel panics on shutdown, after the shutdown state has been reached, so the laptop never actually powers off and I have to long-press the power button to power it off.

So I upgraded to kernel 5.12.13 from https://download.opensuse.org/repositories/Kernel:/stable/standard/

Now everything works perfectly, including the XE graphics and the laptop shuts down properly.

However, when I try to compile the modules for VirtualBox, I get errors that glibc V2.33 is required to compile the modules. I tried to manually update to glibc v2.33 from tumbleweed packages and…that wasn’t a very good idea as I’m now reinstalling the entire thing.

Is there a way to upgrade to the newer glibc, as I really need VirtualBox for my daily tasks?

Thank you!

Check out the /backport/standard in kernel/HEAD:/. Note the colon.

[Edit] Sorry. Should have given the full url:https://download.opensuse.org/repositories/Kernel:/HEAD:/Backport/standard/

Sorry. Still got it wrong. That url is currently the RCx version. Stable is: https://download.opensuse.org/repositories/Kernel:/stable:/Backport/standard/

And what OP can do with this?

Kernel:stable & others are specially patched to use glibc older than 2.33. I asked for upgrade glibc to 2.33, but no luck.

To OP: Try to use TW.
Maybe developers will add support for Intel Xe into Leap 15.3 kernel - try to negotiate about this via creating bug report.

The backport kernels can compile modules using leap’s existing glibc, which was the OP’s problem (read it again).

kernel:stable is build against factory and uses higher Version to build.

There is a bugreport:

The “normal” kernel:stable:backport Repo is build against Leap 15.3 and should work.
And provides also some kmps as virtualbox, rtl8812au etc.

But has now “problems” with Leap 15.2…

Thank you so much, this solved my issue! The vbox modules now compile and everything is working well. With the RC version, although the modules did compile, the VM would crash on boot. With the release version, everything is smooth.

Happy to be able to help.