upgrading pulseaudio - pavucontrol error?

I’m using suse 11.1 gnome 86_64. I need to upgrade pulseaudio to 9.15 to get my USB mic to work with the new version of Skype that was released last week. I’ve upgraded pulse from factory, and it seems to be working OK, but I’ve lost control as the mixer, pavucontrol now tosses the error:

./pavucontrol: undefined symbol: gtk_scale_add_mark

The version of pavucontrol is 0.9.8-7.7. Any one have any ideas how to sort this out. I’ve tried pulse from some other repositories with the same result. If I put it all back to pulse version 9.14 all is resolved, but that doesn’t solve my original issue. :frowning:

Help?

The things I do for Skype.:sarcastic:

It turns out the pavucontrol error was a gtk+ thing, so I upgraded gtk2 from factory to 2.17. That actually solved the pavucontrol error, but then all my icons in the gnome panel lost their transparency.:frowning:

So I updates the panel, which solved that problem, except for pidgin. I decided to upgrade pidgin, but without giving it near enough thought, I decided to update the rest of gnome as well. That was a huge mistake - broke the desktop completely to the extent that I even didn’t have a command line. :’(

It took a couple hours to get that back under control and to get gnome downgraded back to 2.24.

One interesting thing that I noticed in all of this is that the gnome volume control is “depreciated” in 2.27, and there seems to be no replacement. How is one supposed to manage volume under the new gnome?