Upgrading openSUSE 10.3 installed on encrypted partitions

I have installed openSUSE 10.3 according to (nearly exactly as in) this guide Encrypted Root File System - openSUSE and would like to upgrade it to openSUSE 11.0 (keeping everything encrypted as it is :slight_smile:

What is the simplest and safest way to achieve that? I have backups of all important data stored on this computer but would like to avoid “fresh install” and going through the whole process of encrypting again.

My first idea was to boot the computer from openSUSE 11.0 DVD [1], mount the partitions from command line [2] to make them visible to installer and choose update when such option becomes available.
Is this a way to go?

If so, how should I mount the partitions, which partitions and where [3] (I would really appreciate full commands for clarity here, if it’s not a problem)? Should I expect a reboot or any other unpleasant surprise during the upgrade? Will my /boot partition remain intact and the system wokring?

[1] I was afraid installer might overwrite my swap partition, but no damage was done to the system just by running the installer.
[2] Ctrl-Alt-F2 to access command line during installation and Ctrl-Alt-F7 to jump back to graphic installer.
[3] What I mean is whether /home, /boot or swap are needed for the upgrade and what are the appropriate mounting points.

I managed to mount encrypted filesystem with / without any problems (I have full access), but don’t know how to make installer recognize it as containig my root partition.

What mounting point should I use or how else make the installer recognize my root partition?

I have full access to encrypted partitions but still can’t make installer to recognize my root partition as root partition.

I could (and tried) mounting old root in the /oldroot, but installer still doesn’t let me through. Is it possible to skip the screens, where the root partition is being chosen?

Or how else can I make installer use the encrypted partition?


anyone else have any ideas for this ? I asked yesterday (but noone seemed to know) if their was anyway of:

1.) possibly chrooting the installer to point to a encrypted mounted / on /dev/mapper/blahblah


2.) Somehow getting the installer to read from /etc/cryptab instead of only option reading from /etc/fstab

I dont know underneath the new installation process that well but their has to be someway to do this. Custom initrd perhaps and kernel ?

Personally I havent tried updating yet but I have somewhat the same configuration as skx. If anyone has any ideas would be very helpful thx.

I managed to update (with some minor ptoblems, read the comments!) to 11 following this entry: Upgrading openSUSE 10.3 –> 11.0 in a running system., 24/06/08, Benjamin’s blog

For some reasone I had to recreate the swap afterwards (system reported swap as unavailable), but I don’t know if it’s related to the update, since I noticed missing swap a day later (and realised how cheap the memory became).