Upgrading KDE 4, getting conflict

I’m doing the “switch to this version” but I’m getting a conflict. What do I choose to do?

k3b-codecs…requires k3b = 1.69, but this requirement cannot be provided

It says it deleted the k3b provider and the k3b packman provider is uninstallable. Then it gives me three options:

  • install k3b from excluded repository
  • deinstall k3b
  • break k3b by ignoring dependencies

Which do I choose?

If you are doing the kde switch it is trying to switch packman k3b to kde’s k3b - confusing but you need k3b from packman so the excluded repo is packman because the focus is currently on kde4

Install from excluded should allow k3b to be from packman

Argh! Now (during download) I’m getting this error:

Download failed:
File '/i586/kdm-branding-OpenSUSE-11.2-29.5.15.i586.rmp' not found on medium...

What do I do? I tried “retry” but it throws that over and over again.

skip
it may be an obsolete package

we can deal with it later

An obsolete package will show in software management - view by repos and select ‘system’
with red text in the version number
selecting the version tab will reveal no providing repo

N.B
Packages may also show with red if the installed package is newer than any of the repos currently provide. Sometimes packages get rolled back, so this can happen more often than you might think.

OK, also getting it for

kdebase4-runtime-branding-openSUSE
kdelibs4-branding-openSUSE
kdebase4-workspace-branding-openSUSE

I have a feeling it’s all the openSUSE branding stuff.

I looked at the repository in firefox (Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/i586) and I think I know the problem:

  • it’s asking for version 29.5.x but the repository has 29.4.x versions!

Why is this? And how do I fix this? (I don’t want to lose openSUSE’s look and feel)

Try not to worry about it, the last thing you want is to abort, just skip. When it’s done, don’t logout. Just start software management again and go to kde4 desktop repo and let me see a screen of the installed packages, to the extent you can anyway

OK, I’ll put up a screenshot. Just a quick note:

  • it also said it could not find these either:
    kio_sysinfo-11.2
    kio_sysinfo-branding-openSUSE
    kdebase4

kdebase4 worries me as that seems like the main thing in KDE, no?

There’s 5 screenshots (I’m only allowed to include 4 in one post, so the last is in the next post):




Last one (from the set of 5 screenshots):

NOTE: Start in previous post to see all my installed packages from this repo

http://farm5.static.flickr.com/4057/4290248273_fc82749181_o_d.png

Here’s the stuff I had to skip:

kdebase4-runtime-branding-openSUSE
kdelibs4-branding-openSUSE
kdebase4-workspace-branding-openSUSE
kio_sysinfo-11.2
kio_sysinfo-branding-openSUSE
kdebase4

For all of them the issue was because it was looking for version 29.5.x when the repo has only version 29.4.x. Can I just install the RPMs that are on the repo (the 29.4.x ones)?

Looks good to me
Logout or reboot;)

Thanks.

Logged out and back in, how do I tell if everything’s OK and properly updated?

(BTW, thanks again for helping me on this. I REALLY appreciate it)

kde4-config -v

post result

Qt: 4.5.3
KDE: 4.3.4 (KDE 4.3.4) "release 2"
kde4-config: 1.0

I don’t think there’s a way to know just yet if it fixed my dolphin issue since it didn’t happen 100% of the time, but I’ll monitor it over the next week and see.

Well it all looks good to me.

Well done! Contact me any time if you need to:)

I know this is unrelated to the specific subject of your post but looking at your shot of Yast I see that you have 11.2-Videolan and a Libdvdcss repository. Leads me to think that you have tried to dink with the restricted formats and DVD playing. If true, and the Libdvdcss naming makes me think it is, than both of these repos should have been disabled after installing the libdvdcss file from videolan and the rest should be from the packman repo as outlined in the areas that apply to you here:
Multi-media and Restricted Format Installation Guide - openSUSE Forums.
Just a thought no harm no foul if I’m wrong.

thanks, so I should disable which repos?

>thanks, so I should disable which repos?

VideoLan and or Libdvdcss repos