Upgrading headless machine

I have recently tried to upgrade a headless machine following the SDB:System_upgrade page from 15.2 -> 15.3. From previous experience with upgrades I ran in a tmux session to avoid the impact of loss of connection. The connection indeed broke and the system appeared broken after the upgrade. I had to re-perform the upgrade with the installation DVD after which additional configuration and package repairs were necessary.

Is this scenario supported at all? If so, what are the best practices?

As a side-note the machine has an out-of-tree network module injected via DKMS. The module apparently survived the upgrade. Is the behavior of DKMS modules across upgrades documented somewhere?

Thank you very much in advance.

It would be better if you let us know the exact command(s) you used to do the upgrade. Just pointing to an SDB with multiple options does not really give a clear picture of what you actually did.

For example, did you use:

zypper --releasever=15.3 dup --download-in-advance

after setting all your repos properly? That would seem like a more reliable way to upgrade, especially if you are unsure if the headless machine has a stable internet connection.

For the record, I run zypper remotely by connecting to my user on the target machine through ssh, then I run:

su -

to switch to a root console on the remote machine. I just feel that is safer, more secure.
I then run zypper to update (zypper up) or to upgrade (zypper dup) in that remote root console.

I do this regularly for multiple machines, never had any problems in multiple years.

Other than that, I have nothing additional I can tell you based on the information you provided.

However, it is good to see that you have solved it and are up and running (I think that is what you said, correct?).

Good luck, and Happy openSUSE-ing.

Yes, this is exactly what I did. The machine is running just fine at this time, I just had to physically wire it up and insert the usb-stick. Also thank you for the info that upgrading headlessly works for you. With hindsight, I did not shut down all demons, especially slurm which has caused me trouble in the past when the queue was inconsistent. Slurm is definitely capable of freezing the system. I will attribute the crash to a failure to shut down relevant services for the moment. Should it turn out to be different when the transition to 15.4 comes, I will try to amend this thread.