Upgrading 10.2/3 to 11.0 problems

I have two HP laptops and a homebrew desktop wich ran fine (give or take some minor disadvantages) on previous versions of OpenSuSe… This weekend I boldly tried to upgrade all of them…

The first a Compaq 6710b had a few problems…
In order of appearance:

The GRub defaulted to the third option in the list… My Windows partition… but editing the /boot/grub/menu.list and setting the default from 2 to 0 fixed that.

Virtualbox had disapeared… I guess i installed it either from the repository or from source from the site… A reinstall should fix it… I haven’t tried it yet

I was working with the wireless networkcard without any problem but since the upgrade i cannot get online using the wireless.
lspci gives me a clue what i use
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
and i see in lsmod that the module for the chipset is loaded
and the module for the card (but i read it was deprecated)
cfg80211 35592 1 mac80211
mac80211 190484 1 iwl3945

in dmesg i found that the kill switch was off…

iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.23ks
iwl3945: Copyright(c) 2003-2007 Intel Corporation
ACPI: PCI Interrupt 0000:10:00.0[A] -> GSI 17 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:10:00.0 to 64
iwl3945: Detected Intel PRO/Wireless 3945ABG Network Connection
iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
phy0: Selected rate control algorithm ‘iwl-3945-rs’
ACPI: PCI Interrupt 0000:10:00.0[A] -> GSI 17 (level, low) -> IRQ 17
iwl3945: Radio disabled by HW RF Kill switch

to further investigate the issue i tried to:
cat /sys/bus/pci/drivers/iwl3945/*/rf_kill

sending an echo 0 to those files did not help… and an echo 1 even gave a value of three in mentioned output…

So i plugged in a cable (so i cannot take it to the bedroom aymore… my wife will like that) and went on my way searching about the issue.

the iwlwifi drivers are not in the repository so i could not install them and to build them from source is a bridge too far for then i will just postpone the issue in stead of resolving it.

– So suse 0 problems 1

In my previous installation i had Kooldock running until it chrashed… I hoped this was fixed… but still no cuigar.

– suse 0 problems 2

on the other side my fingerprint scanner was recognized (woohoot) but priority lies with the wireless so i haven’t taken the time to play with that…

– suse 0,5 problems 2

The 3D support of my graphics card should be good eough to enable compiz but without hacking about i could’n get it to work… another time issue.

The second (and much older laptop i tried gave errors in the upgrade mentioning that some dependancies could not be resolved and manual intervention was needed.
Changing the architecture and switching ownership of packages from Packman to SuSe resolved those

– Suse 1,5 problems 2

one of the packages (a lib i could not recognize and i failed to jot it down what it was) could not be installed from the DVD… I checked the hash before burning and chacked the media before installing so it should not be a problem with my copy… I skipped the package and it went right on… Because is was past midnight i called it a day

the next morning (after church) i found that the install was ready… BUT the same problem with Grub but now a bit worse.

The Grub /boot/grub/menu.lst defaulted again to the third option in the list… and strangely enough it was suse 10.2… and grub complained it could not find them.

in the console i chose to load suse 11 and it booted and again i edited the /boot/grub/menu.lst to default on suse 11 and it fixed the issue

This is definitely a bug! This could scare off n00bs

I tested my network connectivity and you can guess wireless is not working…
KNetworkManager did not complain that wireless was disabled but there was no carrier. It did recognize my ESSID
It recognized that is was able to use WPA but only after the 25th try (i just retried before complaining before i get beaten) it worked…

suse 2,5 (with a little pain) problems 2

Another thing i noticed… i can no longer choose “suspend” from the menu… and i would like to do so… will this be fixed?

Some other minor issues (that i could foresee) were:

geoqo did not work after the upgrade because the perl packages i installed manually had disapeared
Enemy territory missed some dependancies

and another problem i DID NOT foresee was that qlandkarte was not automaticaly installed although i did have it before…

Adding and removing repositories was a dream…

I have enough confidence to try to upgrade my third machine (a desktop with 10.2 on it) because it will only take an hour… but i am afraid of the NVIDIA driver install, grub and some other installations from source i will have to repeat…

I tried to post this this morning but SuSe wouldnt let me in…

So update…

On the 6710b i reset the BIOS settings to the defaults and the LED of the wireless was lighting up promissingly after bootup…

I don’t know if it is sticky fingers or something but only after 30+ attempts (even performing a ifconfig wlan0 down && ifconfig wlan0 up ) and finally it gave in. and i am posting this using wireless

On my desktop i finally tried to upgrade and it took me three tries to get a little further…
Adding more than 4 extra repo’s was no good idea for it chrashed on trying to add them (i could take s shower get dressed and come back and still no progress

the same error as on my laptop occured that slib-3a5-29.1.noarch.rpm could not be installed and the installer ran back to mama (it went back to the Ncurses boot/install menu)

After a reboot i opted for trying to find the slib package and taboo it… So gnucash (which i don’t use) had to go too…

as of submit is still installing…

so far so good…


So… machine 3 is running 11.0 aswell…
It was adrag to get this far… after 1,5 hours it exited with an error " failed to install some packages" . .Well thanks for the info… but it will not do. So rebooted again and noticed that only three packages where on the nomination of being installed.

-some java stuff
-some more java stuff
uninstall of gnu-cash

so i decided to NOT install the java stuff (and one dependancie) and it went along finishing up the installation… and rebooted…

and guess what… it defaulted to an incorrect item in grub (this time a 10.2 installation) so i edited it and rebooted to test… Hurray it worked

although i choose to use a NVIDIA repo it didn’t install the Nvidia driver… so… No Compiz. i searched for the driver but could not find it.

and…the same as the other two machines… no luck trying to suspend the machine from the Kmenu

So: four questions

-> Is the failiure of the slib package my bad or does anyone else has the same issue

-> is the grub failure a bug ?

→ what about suspend… is there a fix

-> How can i get Compiz to work in 11.0 (and the Nvidia install)

I can only comment on the above two.

Re grub: maybe, maybe not. I think this is one of the very most difficult installation areas, because there are so many potential permutations and dependencies. I’ve used grub’s own “grub install” script (the Debian method) and it as well sometimes gets confused. It doesn’t help that bios’s are inconsistent in how they report drive sequencing to the boot code. In any event, with nearly all the multi-boot scenarios I have set up (quite a few), I nearly always have to tweak the grub installation. YaST sometimes tries to be overly clever about it, and gets it wrong.

Re Nvidia and Compiz: Add the nvidia repo and install the module and the driver from there. There are two; AFAIK all cards in the last several years use G01. The install will change xorg.conf for you. For Compiz, there is now a “simple desktop effects” app to turn on the Compiz; it is a simpler version of the full-blown ccsm Compiz Manager. Apparently another step is reqd to get Compiz to automatically start with KDE, possibly using a script under ~/.kde/Autostart (there are other threads on this). (Side note: I installed KDE4 and then used the Factory/11.0 repo to upgrade to 4.1beta; KWin now has very good built-in compositing. Not the plethora of effects that Compiz offers, but certainly worth a look.)

mmm… i don’t know about that… it was an upgrade so it just needed to edit them… and ot worked ok… but defaulted to the wrong entry…

nvidia /compiz: well ok… it worked on my intel chipsets on the laptops but not on the pc where i had the NVidia driver installed before…

it even chrashes on an sax2 -r (as root)

i noticed that the one click installers where not working on my laptop (failed at BEGIN)

Can't locate XML/XPath.pm in @INC (@INC contains: /y2update/modules /home/polleke/.yast2/modules /usr/share/YaST2/modules /usr/lib/perl5/5.10.0/i586-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at /usr/share/YaST2/modules/YPX.pm line 6.
BEGIN failed--compilation aborted at /usr/share/YaST2/modules/YPX.pm line 6.
Compilation failed in require.
BEGIN failed--compilation aborted.

when i do a locate on XML/XPath.pm it finds it @


i tried to reinstall the meta-packagemanager, some perl stuff providing the XPath.pm but it did not work…
i can try to hack my way into sonftlinking the old paths back in… but i don’tknow if it is the right way to go along…

and on the desktop (the Nvidia installer)
i cannot find a clear error in the logs about that…

Even in the upgrade the boot loader re-initiates the grub setup.

I can’t speak to your issue with the nvidia driver. I’ve used it since day one and it’s been fine, but I’ve seen other users who have had issues with a particular card. Typically resolved however with another version of the driver. With Compiz it gets more tricky due to the xorg.conf setup required. The driver installs an excellent manual from Nvidia which details all the possible settings. It also describes how to overclock the card, if that’s supported. 11.0 now comes with the nvidia utility to do some of that. There is also an Nvidia installation log. By the way, it’s problematic to switch between the repo driver install and the Nvidia download install script.

Re one-click installs, I don’t use them. I prefer fine-grain control of the installation.

and i solved it…

I did what i did time and time again… i updated the drivers from the package manager BUT this time i utilized the NVdock to set stuff up.

after that (after a reboot) it worked… i even caught a glimps of the nvidia logo…

for the other errors (one click install of the codec-oneclick installer) was fixed by re-installing the perl-xml-XPath package.

(thanx benji)

now for the powermanager in kde3 (in 4 i can suspend from the menu BUT no power manager in yast)

google is not helpfull today…

ok… we are almost there…

remaining issues

That last one is new… well… new… it didn’t work in 10.3 and i was hopefull to get it to work in 11.0. yast helped me out by trying to install the Pam module but that was it…