upgradefailure; what next/

I had previously updated 2 machines from 15.2 to 15.3 without problems so it was time to upgrade m main desk machine.

I did the zypper --releasever=15.3 dup
and afrer a time it seemd to finish. But when I rebooted it got to grub and then said there was no keyboard and the screen said no signal. Tried again a couple of times and eventually got a system running. It seems to have a5.3.8 kernel as was te case with 15.2. It sort of runs but I am not sure wat it is actually running.

What number should the kernel be and how to I get it? What should I di to recover ?

I think you should first check if zypper now thinks that you are on 15.3 or not. And because a repo list might also be of ineterest:

zypper lr -d

BTW, “after a time it seems to finish” is rather vague. What was on the terminal?

| Alias | Name

                                                     | Enabled | GPG Check |

Refresh | Priority | Type | URI
| Service
1 | ftp.gwdg.de-openSUSE_Leap_$releasever | Packman Repository
| Yes | (r ) Yes |
Yes | 97 | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/op
enSUSE_Leap_15.3/ |
2 | openSUSE_Leap_15.2 | packman mirror
| No | ---- |
---- | 97 | rpm-md | http://ftp.halifax.rwth-aachen.de/packman/suse/op
enSUSE_Leap_15.3 |
3 | opensuse-guide.org-repo | Libdvdcss Repository
| Yes | (r ) Yes |
Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.3
/ |
4 | repo-backports-debug-update | Update repository with updates for
openSUSE Leap debuginfo packages from openSUSE Backports | No | ---- |
---- | 99 | NONE | http://download.opensuse.org/update/leap/15.3/bac
kports_debug/ |
5 | repo-backports-update | Update repository of openSUSE Backp
orts | Yes | (r ) Yes |
Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.3/bac
kports/ |
6 | repo-debug | openSUSE_leap_15.3-Debug
| No | ---- |
---- | 99 | NONE | http://download.opensuse.org/debug/distribution/l
eap/15.3/repo/oss/ |
7 | repo-debug-update | openSUSE_leap_15.3-Update-Debug
| No | ---- |
---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15
.3/ |
8 | repo-debug-update-non-oss | openSUSE_leap_15.3-Update-Debug-Non
-Oss | No | ---- |
---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15
.3-non-oss/ |
9 | repo-non-oss | openSUSE_leap_15.3-Non-Oss
| Yes | (r ) Yes |
Yes | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15
.3/repo/non-oss/ |
10 | repo-oss | openSUSE_leap_15.3-Oss
| Yes | (r ) Yes |
Yes | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15
.3/repo/oss/ |
11 | repo-sle-debug-update | Update repository with debuginfo fo
r updates from SUSE Linux Enterprise 15 | No | ---- |
---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15
.3/sle/ |
12 | repo-sle-update | Update repository with updates from
SUSE Linux Enterprise 15 | Yes | (r ) Yes |
Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.3/sle
/ |
13 | repo-source | openSUSE_leap_15.3-Source
| No | ---- |
---- | 99 | NONE | http://download.opensuse.org/source/distribution/
leap/15.3/repo/oss/ |
14 | repo-update | openSUSE_leap_15.3-Update
| Yes | (r ) Yes |
Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.3/oss
/ |
15 | repo-update-non-oss | openSUSE_leap_15.3-Update-Non-Oss
| Yes | (r ) Yes |
Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.3/non-os

So 15.3

It dd what I xpected. 4600 packages or so down loaded and istalle, ten areboot request

BTW, “after a time it seems to finish” is rather vague. What was on the terminal?[/QUOTE]

Ok, I get from this mess that 15.3 is now what zypper thinks it is, which means that much is done.

It also looks as if the two extra repo that you should have now are there.

Can you do a

zypper up

so that we are sure those two repos are used.


But for the rest it is unreadable.

There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.

cage:~ # zypper up
Loading repository data...
Reading installed packages...

The following 6 package updates will NOT be installed:
  gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libsox3 sox
  youtube-dl-bash-completion youtube-dl-zsh-completion
Nothing to do.
cage:~ #

Apologies for the previous mess. I am not sure how to transder data from a xterm on machine 1 to a forum message on machine 2

I do not understand Top toolbar and # and editor. Not seen any of these. All I can see is to type possibly with a quote of previous message.

From bottom to top.

When you use the Reply to Thread or the Reply with Quote, you get a field where you can enter your text. Above this is a tool bar with a lot of buttons. For Bold, Italic, … and there is somewhere the #. The link provided above for the example should show you. Doesn’t you see that when you post?

To transfer. There are many possibilities.
E.g. use an USB memory stick, create a file with an editor and copy/paste from your terminal window into that file.
Move the stick to the other system, open the file and copy/paste to the post editor.

It looks as your system is up-ti-date (it shows a minor problem, but that can IMO not be the reason for the unabilty to boot.

But kernel on 15.3 is now 5.3.18-150300.59.43-default, so something is wrong.

I’m confused about the current state of this upgrade. Is it failing to boot (locking up using) the current kernel, but succeeding with the 15.2 kernel? If yes, and you have an older AMD/ATI GPU, it’s a known problem with the current 59.43 15.3 kernel. Bug 1195142

I can confirm that this is an AMD Phenom 4core from 2009 which I guess counts as old.

I tried reading bug 1195142 but did not find/understand how to fix things. All I got was a belief that it is fixed but not distributed.

That is not what I see. I reply and get a blank box. No tool bar and no buttons.
It is always difficult sending messages in this forum with small font size and no editing facilirties.

It’s the GPU that matters, not the CPU. Does your CPU module provide your GPU? What does lscpu | grep ‘Model name’ report?

I tried reading bug 1195142 but did not find/understand how to fix things. All I got was a belief that it is fixed but not distributed.
Comment #5 in the bug explains how to replace the broken radeon kernel module in .59.43 with one from an older kernel. If that’s too hard to figure how to do, you can keep using the .59.40 or older kernel, or install one from the BS, such as that here.

Output says

AMD Phenom(tm) II X4 810 Processor

I think it has graphics in the processor. Sure there is no GPU separately.

https://www.techpowerup.com/cpu-specs/phenom-ii-x4-810.c611 says that CPU has no onboard graphics. What does inxi -Gxx report?

This is what I get after clicking Reply with Quote: https://susepaste.org/69746033

cage:~/Television> inxi -Gxx
  Device-1: AMD RS780D [Radeon HD 3300] vendor: ASUSTeK driver: radeon 
  v: kernel bus ID: 01:05.0 chip ID: 1002:9614 
  Display: x11 server: X.Org 1.20.3 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1200~60Hz s-dpi: 96 
  renderer: AMD RS780 (DRM 2.50.0 / 5.3.18-150300.59.43-default LLVM 11.0.1) 
  v: 3.3 Mesa 20.2.4 compat-v: 3.0 direct render: Yes 

Your GPU is one of the ones affected by the bug I mentioned in comment #7, where kernel 5.3.18-150300.59.43 was broken for Radeon users. The 5.3.18-150300.59.46 kernel on the mirrors now should fix your problem.

Thank you; it i now working with the new kernel