Upgraded to KDE 4.4. one question, one problem

Greetings all knowing openSUSE forums. lol!

The urge to upgrade to KDE 4.4 now instead of waiting for 11.3 got the best of me today.

Almost everything seems to be working well except I have a small problem and a question.

Question: Do I need to switch system files back to Packman? I noticed Yast removed a k3b codecs file. Is that going to cause a problem?

Problem: Every time I restart, all my folderview widgets (Desktop and Home) are resized and piled up in the corner of the screen. None of the other widgets are affected.

I’m not really sure what to do. Anybody have a suggestion?

I am also running KDE 4.4.2 and it did seem like the icons got smaller, but they can be re-sized, one at a time and not all got smaller. As for the k3b-codecs, I too had to install it back which worked fine. I also found alsa files gone and Yast-alsa-sound gone. I used packman for everything they had. I just reinstalled the missing programs and got back to normal. While I had some odd thing after the update, I do not have desktop icons returning to home each time I restart KDE, not sure what that means is wrong. I updated two machines and one was missing files, while the other was not. My icons did re-size smaller on both installs.

Thank You,

I just updated it too… But before I click accept for installation, while it gave me the options to select for dependencies, I choose not to upgrade K3B, so that current version of k3b codecs would not be uninstalled. I have been doing this to avoid k3b codecs from deleting since previous versions of kde.

Most of the things are working well, sound too as before but, the volume indicator (the one which pops up when you press volume keys) is ok for the first time you use the volume keys, but goes to the top left corner and only displays some part (that pop up thing is zoomed now). Its just a minor glitch, so i am ignoring for now hoping it will be fixed in later updates.

rest are still to figure out.

There are one or two packages that may have been switched (k3b, kaffeine, ktorrent) to mention a few. Use the radio button to switch them back, you will need to physically add the k3b-codecs.

My icons were all fine this time, but on at least 2 occasions I have started a new .kde4 folder, which will really clean things up.

A new .kde4 folder did the trick. Reinstalled the codecs and switched sys files to packman which downgraded a few packages. Now everything is running smooth as silk. :slight_smile:

Thanks a bunch

N worries.
It’s a bit of a hassle because you have to re do all the desktop and drag in any settings you might need. But it’s best if you can keep it as clean of any old stuff as possible.
Good to hear your news anyway;)

one more question comes to mind.
Now that I have got 4.4 running, do i need to remain subscribed to the factory repo or should i disable it?

Keep factory enabled and just use Yast software management
filter by repo
and update all in this list if newer ver avail.

The switches you made should remain.


since you have most compiz version 8.4.xx like mine… I have one question in my mind. Did you face the problem with the OSD of Kmix volume? The osd comes up the first time, then it won’t appear for few times,… later on it appears as half of the magnified osd. (see the top right corner of the screenshot:)

I am trying every thing… even made a fresh new user account,… deleted and replace .kde4 dir, but did not helped. BUT… if i use fusion-icon to “reload window manager” (reload compiz), it will work without any problem after “three” reloads. The problem persists for the first couple of reloads… and after I reload compiz the third time… its gone… I even tried removing all compiz config files…and started with fresh copies… but that is the only solution… reload compiz… not one time, not two but three times…

Did you have any problems with your settings?

Oh… and BTW… i am using “ghost” theme for plasma workspace. removing every plasma related settings (and changing it to default air theme, and whole kde4 dir… and also creating new user did not help).