Upgraded to 42.3 from 42.2

System wont boot with new kernel after upgrading from Leap 42.2 to 42.3. System boots fine with kernel 4.4.74-18.20. It gives an error Failed to start Load Kernel Modules See ‘systemctl status systemd-modules-load.service’ for details. The screen is flashing and impossible to run commands even though it gives a console…Running systemctl status systemd-modules-load.service when its up with the old kernel gives

systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2017-07-19 14:49:57 EDT; 26min ago
Docs: man:systemd-modules-load.service(8)
Process: 493 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 493 (code=exited, status=1/FAILURE)

I think this might have something to do with the nvidia driver? TIA.


Installed nvidia drivers from yast and it looks like it works now. Some backstory, I just installed OpenSUSE Leap 42.2 yesterday from being a long time Ubuntu user. IMHO, it’s out of the box experience is def. lacking. ipw was not installed automatically during installation and thus my wifi didn’t work. Once i got wifi working, I ran zypper update. Then I encountered the error I saw a couple threads down where the repo.xml was missing, so I readded the repos and everything worked again. I didn’t want to use the noveau drivers and so I tried installing the nvidia drivers, but zypper kept giving errors with unresolved dependencies so I installed the drivers the “hard way.” Today, I decided to update to the latest kernel because my sound doesn’t work (Realtek ALC1150). Hence, my troubles began. Newest update, sound still doesnt work and the driver from realtek keeps failing during make…I had a lot of other programs fail to make as well so I ended up jsut copying the files from my ubuntu rig and it seems to work okay so far…I was willing to give OpenSUSE a try since the days of KDE3, since Plasma looked really good, but I’ve found the experience severly lacking as a Desktop user.

Might be.
You have to reinstall the driver after the upgrade, as you use a different kernel now.
Actually it is preferred to uninstall the driver completely before an upgrade and then install it fresh afterwards.

Also, 42.3 contains the backported drm stack from later kernels, this will break the nvidia driver.
You need to uninstall drm-kmp-default before installing the nvidia driver. (if you use the rpm packages from the nvidia repo, this should be done automatically though).

See also the 42.3 release notes: https://doc.opensuse.org/release-notes/x86_64/openSUSE/Leap/42.3/#sec.install.nouveau-extra