upgraded to 15.2; system now only boots via installation USB drive.

HI,

I have upgraded my leap 15.1 to 15.2. It was an ‘upgrade’, not a new install.
The upgrade seemed to go fine, but now I can only boot-up the upgraded system when I have the installation-USB drive still in its slot. That is, with the 15.2 stick connected, I get the installation options of which I choose the default one: installation from hard disk. The system boots into 15.2 and the system works all-right.

However, when I remove the usb-drive, I can no longer boot-up my system. The system stops where it is supposed to boot from the hard disk.
I have not made any modification to the BIOS settings. The hard disk is number 3 in the boot sequence, after the USB (1st) and the CD-ROM dirve (2nd), as it has always been.

What can I do to correct thi issue?

Regards,
Bertwim

After you remove the USB drive and are running

as root or uses sudo

grub2-install /dev/(the drive with opensuse on it not the partition - usually sda or nvme0n1)

to see what to put in you can use df -v and use what / is without the partition if it is sda2 you use sda if it is nvme0n1p2 then you uses nvme0n1

that will reinstall the correct boot code on the drive.

In addition to the information given by ** larryr** –

It seems that, the boot loader hasn’t been properly initialised – reference is here – <https://doc.opensuse.org/documentation/leap/startup/html/book-opensuse-startup/cha-trouble.html#sec-trouble-boot&gt; and here – <https://doc.opensuse.org/documentation/leap/startup/html/book-opensuse-startup/cha-trouble.html#sec-trouble-data-recover-rescue-grub&gt;.

After you’ve re-installed the GRUB2 boot loader on the system, you have to re-install it as a boot-loader –

 # grub2-mkconfig -o /boot/grub2/grub.cfg

The GRUB2 “make configuration” should re-write the Master Boot Record (MBR) – you can be sure that the MBR will be rewritten if you use YaST – and make sure to enable the “Write generic Boot Code to MBR” option …

@larryr, @dcurtisfra,

Thanks for your responses. It worked, problem solved!

Kind Regards,
Bertwim