Upgraded to 15.2, now main account does not give access

The upgrade 15.1->15.2 seems to have gone well, but cannot log in on one main account.
I have two accounts on my machine, my main account and a testing account intended for maintenance techs etc.
Logging in on the testing account works as normal, but logging in on the main account gives a black screen with flashing vertical white cursor bar at top left of screen which echoes back characters typed at the keyboard but does not respond to commands. Same response if I log in immeditately, or log in as tester and then try to switch accounts.
How to proceed at this point to get back into the main account? I have access to root through the testing account.

Hi, welcome here

You don’t tell us what desktop environment you’re using. Nor how you performed the upgrade ( though at first impression that doesn’t seem to be the issue ). Can you post screenshots from the failing user’s desktop on paste.opensuse.org ( use the Image button to upload ) and post the resulting link here?

Thanks, I am using Gnome as provided by 15.2, and was using Gnome previously in 15.1.
I downloaded the 15.2 DVD version and ran that to do the upgrade. Everything worked with the exception of my being required to choose the SUSE versions of some packages I had installed from Packman.
The failing user’s desktop is never displayed; all I see is the black screen with the flashing cursor. I am presented with the login screen listing the two accounts, the tester account works correctly but the main account just goes to black. So I am not sure what I should upload, the image of a black screen?

I have tried going into Yast in the account that works, added the main user to a group to force it to re-save the details and tried to log in again but still end up in a black screen.

Use CTRL-ALT-F1 to get to a command line.
See if this user can login at the command line.

If that works, then the problem is likely in user configuration – perhaps some setting that isn’t compatible with Gnome 3.34.

Thanks, yes the main user can log in at the command line.
For anyone trying the same CTRL-ALT-F1 the key combination to get back to the original screen is CTRL-ALT-F2.
I will try some random changes in the setup for that account; unless I can find a list of incompatibilities.

If all else fails, then try from a command line login:

mkdir OLD
mv .config OLD/.
mv .local OLD/.

That gets rid of most user settings, though with a saved copy.

Then see if you can login and reconfigure. And, finally, see what you can rescue from what you moved to that OLD directory. Use a different name instead of “OLD” if “OLD” already exists.

Good suggestion, nrickert. It worked right away. Desktop is a bit messed up with settings and config gone but I have access to a lot of saved info.
Thanking you.

Huh??? There is a chance that, GNOME doesn’t migrate the user’s settings from the old version to new version?

I don’t use Gnome enough to have a good picture of that.

I have seen messed up settings in KDE after going to a newer version, thought that was back with plasma 4. Mozilla is the best about migrating settings to a newer version. I have never run into a problem with firefox migration.

Me also not.

KDE Plasma 5 is usually OK but, sometimes – it ain’t perfect …