Upgraded to 11.0 - now no gui start

FYI - I have searched this and other groups for the simple answer to this but it still eludes me.

I elected to perform an upgrade from 10.0 to 11.0 and upon completion I only get to runlevel 3 (text). I can issue startx and get the gui gut how do I define that to happen automatically at boot/startup?

I’ve gone through the YaST/kde/boot parameters and cannot locate where.

TIA - Bob:(


a) The quick way:
As root, edit /etc/inittab and change 3 to 5 in this line:
Save and quit.

b) The Yast way:
Yast -> System -> System Services (runlevel)
Once there, select the Expert Mode, and select 5 in the Field named ‘Set default runlevel after booting’.

Reboot to test changes.

Please log in,and type command “starx”(without quote),this will give you the GUI and then do as carboncore told you,if you are not nervous to play with Console windows you can change Service Run Level via Terminal

sudo -s
  (give your root password here)
  nano /etc/fstab
  (go to the line **id:3:initdefault:**)
  change "3" to "5"
  use "control + X" to save and press "Y" to confirm,
press "Enter" to exit.

then reboot!

Good Luck!

Thanks gents.

That’s what I thought but the runlevel i inittab is already set at 5. So my guess is that something is failing in the xserver start. But if so, I ask, why does it start when I key the command startx from the CLI? :confused:

Then it’s probably the /etc/sysconfig/displaymanger setting not set for
kdm/kdm3/kdm4. I use Gnome, hence the gdm.

## Path:        Desktop/Display manager
## Description: settings to generate a proper displaymanager config
## Type:        string(kdm,kdm3,kdm4,xdm,gdm,wdm,console)
## Default:     ""
# Here you can set the default Display manager
(kdm/xdm/gdm/wdm/console). # all changes in this file require a restart
of the displaymanager #

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 2 days 1:35, 3 users, load average: 0.19, 0.07, 0.09
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12