Upgraded from LEAP 42.3 to LEAP15, laoptop constantly locks up

I upgraded my Dell Precision M4500 from 42.3 (which has run fine for years, and with early versions) to a clean install of LEAP15. Since upgrading, whenever I use Google Chrome or Firefox it locks up, the only way to recover is a hard reset. I’ve used the laptop for around 10hrs and it has done this 4 times so far. I need a system that doesn’t do this, how can trouble shoot this or use a version of opensuse that doesn’t do this?

It has a nvidia GT215GLM Quadro FX 1800M, with previous version of opensuse I’ve used the propriety drivers.

Is this a Optimus setup? Can you switch to whichever GPU you wish in the BIOS/UEFI??

The only thing in the “Video Settings” in the BIOS is for the ambient light sensor, and that is it. The BIOS does have UEFI though, but it’s configured to boot using legacy mdoe and not UEFI.

If you have both a Intel and NVIDIA GPU and you can not control from the BIOS then it is Optimus and requires Bumblebee to function correctly

https://en.opensuse.org/SDB:NVIDIA_Bumblebee

Ok, never had to do that before, I’ll take a look, the only graphics card that hardware probe finds is the nvidia one previously mentioned, I’ve used this laptop with other distros and it is the same, nvidia only.

If I understand this correctly, a standard install of LEAP 15 uses Wayland, and the nvidia drivers I previously used will not work with Wayland, they are for Xorg only, but they may work if I used Xwayland - is that correct?

As far as I can understand from the specs, that laptop only uses NVIDIA, so I do not think Bumblebee is the answer. And, even more sure of that if you were already running it in 42.3 without Bumblebee.

Video type

  • Discrete

Data bus

  • PCI-E x16 Gen1
  • PCI-E x16 Gen2

Video controller

  • NVIDIA Quadro FX 880M
  • NVIDIA Quadro FX 1800M

I take it you are running Plasma. You might test with another Display Manager, perhaps LightDM, then report back on the results:

su -
update-alternatives --config default-displaymanager

I should have said, that I’m using GNOME.

I tried Plasma, and whilst I can login there are strange graphical artifacts and screen flashing, it makes it almost impossible to use. I went through several of the options, tried Plasma on Xorg, failed completely, I’ll try your suggestion of LightDM, but at the moment it looks like I may go back to 42.3, it worked flawlessly, as does my work PC, different hardware, obviously.

The reason I upgraded is my >7 year old SSD eventually failed, so decided I might as well go with the latest and greatest.

If you had the NVIDIA driver installed when you upgraded you may need to remove and reinstall. If you only have the NVIDIA then bumblebee is NOT the way to go.

Okay, try Gnome, but with LightDM, see what happens. Can’t hurt.