upgraded from 15.2 to 15.3 iphone pics don't import

Can’t import iphone pics anymore. Some show up but can’t open heic files or view them in kde

Is there a kdeconnect app for iphone?
I can use that with Android and KDE

no not for iphone

Do you have libheif1 installed? From the packman repo do

zypper in libheif1 gdk-pixbuf-loader-libheif gimp-plugin-heif

You need at least KDE frameworks 5.8 to view heic/heif files in KDE applications. The responsible lib is ‘kimageformats’ (current version is 5.83). You can also use Darktable, it has build in capabilities to show those files.

Says I have kimageformats 5.76 installed

That is probably the version that ships with Leap 15.3.


I have to correct myself, it is not darktable but digicam that can handle heic/heif files out of the box. Sorry for that.

The KDE application “digiKam” can manage and edit HEIC images …

I tried that and get errors about camera not being connected. I’m also having a problem with usb ports not charging my iphone after the upgrade. Not sure if it’s related.

I am not sure what is needed on Leap 15.3 as I am on Tumbleweed, but I have

So I won’t be able to view them directly with dolphin under photos without using something like digikam to open them?

Currently, that seems to be the case – Gwenview & Co. seem to be currently suffering HEIC issues …

  • KDE Frameworks version 5.80 has support for HEIF and HEIC for all applications.

Currently, openSUSE Leap 15.3 uses KDE Frameworks version 5.76.0 – which newer than Leap 15.2 (5.71.0) – but because of the Backport for SLE 15 SP3, not the Tumbleweed version (5.83.0) …

  • Please wait …

Maybe I’ll reinstall 15.3 with the dvd. I did the upgrade before.

Reinstalled 15.3. Having the same problem. Digikam can’t find my iphone

How are you attempting to connect to the iPhone?

  • Via WLAN?
  • Via a USB cable?

through usb cable

Then tools such as Dolphin should be able to access the iPhone’s file-system.
And, Digikam also …

Digikam works when I can get the iphone recognized. Most of the time it won’t get charged or recognized through the usb connection.
Sometimes if I leave it connected and restart it works for a short while.

Have you actually tried using an older Kernel
Try moving up

No, I don’t know how to do that.