Upgraded from 15.0 to 15.1 - libgcrypt selftest failed

Hello, I’ve done an online update from 15.0 to 15.1

now whenever I run any console command I get a libgcrypt warning that I didn’t get previously:

~> su root
libgcrypt selftest: binary (0): Selftest failed (/usr/lib64/.libgcrypt.so.20.hmac)
Password:

The commands seem to run OK but any suggestions welcome, thanks

Hi
I see a user reported a similar issue (no reply);
https://lists.opensuse.org/opensuse/2019-04/msg00116.html

Can you check the packages actually updated?


zypper se -si libgcrypt

Yes I saw that other post - thanks. Here’s the output

zypper se -si libgcrypt

Loading repository data…
Reading installed packages…

S | Name | Type | Version | Arch | Repository
—±------------------±--------±----------------±-------±---------------------
i+ | libgcrypt11 | package | 1.5.4-lp151.3.1 | x86_64 | (System Packages)
i+ | libgcrypt20 | package | 1.8.2-lp151.8.1 | x86_64 | Main Repository (OSS)
i+ | libgcrypt20-32bit | package | 1.8.2-lp151.8.1 | x86_64 | Main Repository (OSS)

I installed libgcrypt11 afterwards to get the Spotfy app working, it hasn’t affected anything.
Thanks

Hi
How did you install libgcrypt11 and from where, since it’s a system package.

Switch to root user (su -), are there any errors from the output of;


ldconfig

Can you remove libgcrypt11, rerun ldconfig.

Hello, the selftest failed error was happening before I installed libgcrypt11 so I don’t think it’s connected

I installed libgcrypt11 from a 1 click install
https://software.opensuse.org/package/libgcrypt11
Community package home:ComputerSmurf:Extras

Everything else is from standard 15.1 packages (and packman repo)

No errors (or any output at all) from ldconfig as root

Thanks

Hi
OK, then can you force the re-install of the other two packages;


zypper in -f libgcrypt20 libgcrypt20-32bit

You don’t have any additional kernel command options active?


fgrep GRUB_CMDLINE_LINUX_DEFAULT /etc/default/grub

Thanks, no luck unfortunately. I added noresume as something was causing an error and I don’t use resume. 15.1 seems to have doubled them all up…

fgrep GRUB_CMDLINE_LINUX_DEFAULT /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT=“showopts noresume acpi_osi=Linux splash=silent quiet splash=silent quiet showopts”

zypper in -f libgcrypt20 libgcrypt20-32bit

libgcrypt selftest: binary (0): Selftest failed (/usr/lib64/.libgcrypt.so.20.hmac)
Retrieving repository ‘Application:Geo’ metadata …[done]
Building repository ‘Application:Geo’ cache …[done]
Retrieving repository ‘Packman Repository’ metadata …[done]
Building repository ‘Packman Repository’ cache …[done]
Loading repository data…
Reading installed packages…
Forcing installation of ‘libgcrypt20-32bit-1.8.2-lp151.8.1.x86_64’ from repository ‘Main Repository (OSS)’.
Forcing installation of ‘libgcrypt20-1.8.2-lp151.8.1.x86_64’ from repository ‘Main Repository (OSS)’.
Resolving package dependencies…

The following 2 packages are going to be reinstalled:
libgcrypt20 libgcrypt20-32bit

2 packages to reinstall.
Overall download size: 781.3 KiB. Already cached: 0 B. No additional space will be used or freed after the operation.
Continue? [y/n/v/…? shows all options] (y): y
Retrieving package libgcrypt20-1.8.2-lp151.8.1.x86_64 (1/2), 406.2 KiB ( 1.1 MiB unpacked)
Retrieving: libgcrypt20-1.8.2-lp151.8.1.x86_64.rpm …[done]
Retrieving package libgcrypt20-32bit-1.8.2-lp151.8.1.x86_64 (2/2), 375.1 KiB (885.8 KiB unpacked)
Retrieving: libgcrypt20-32bit-1.8.2-lp151.8.1.x86_64.rpm …[done]
Checking for file conflicts: …[done]
(1/2) Installing: libgcrypt20-1.8.2-lp151.8.1.x86_64 …[done]
(2/2) Installing: libgcrypt20-32bit-1.8.2-lp151.8.1.x86_64 …[done]
conserv3tb:/home/asb # exit
exit
~> su root
libgcrypt selftest: binary (0): Selftest failed (/usr/lib64/.libgcrypt.so.20.hmac)
Password:

Hi
Can you remove the two entries noresume acpi_osi=Linux temporarily, reboot and check again.

That hasn’t helped unfortunately. On the plus side whatever error I had with noresume with a previous version has gone away so I’ll take that out.
Thanks