Upgrade Xorg or KDE/Qt on openSUSE 42.3


I run Tumbleweed and Leap 42.3 on my 2017 Lenovo Yoga 520 laptop. I use this device only for work, so that I don’t have much time to keep testing after each upgrade in Tumbleweed. This is the reason I have been using Leap as my workstation since my previous laptop.

I work like 60% of the time on laptop mode for coding and typing. And 40% in tablet mode for handwriting math and reviewing papers with my active stylus (it uses xinput and the xf86-wacom driver on both Leap and Tumbleweed).

The issue is that there is a glitch when handwriting on Leap 42.3 such that it often draws lines while the stylus is still hovering on the screen. This makes the fluidity of handwriting very annoying and a little bit unusable. And it doesn’t matter the application: tested on xournal, gimp and stylus lab write.
Apart from that, Leap is pretty fine on everything I need.

However, the same problem doesn’t happen on Tumbleweed. So I believe it must be a issue with the old Qt version and/or old Xorg drivers.

The question is: how should I proceed in order to upgrade Qt and/or Xorg on my Leap? Do latest KDE+Qt and latest Xorg work fine separately? Should I upgrade KDE+Qt+Xorg at once? Or is it better to switch completely to Tumbleweed?

Summarizing, what is the best option for me with the purpose of keeping compatibility with active stylus, maximizing stability and minimizing potential bugs?

Thanks in advance :slight_smile:

If you have reasonable Linux experience (and feel comfortable doing so), you could try upgrading to the current stable Linux kernel via the the following repo


The Xorg stack can be upgraded by subscribing to the Xorg repo http://download.opensuse.org/reposit…USE_Leap_42.3/ and upgrading via that perhaps.

The latest Qt is available here:

You’d also need to upgrade KDE Frameworks and Plasma to the latest versions then though:

Add both repos, and do a full switch to both to prevent an incompatible mixture of package versions.

Do latest KDE+Qt and latest Xorg work fine separately?


Should I upgrade KDE+Qt+Xorg at once?

I probably would do it step by step.

In your case, I’d think the Xorg upgrade is more likely to help. See deano_ferrari’s reply for the repo URL, but also in this case it’s advisable to do a full switch to the repo.

But I also concur with deano_ferrari that a newer kernel would probably be the first thing to try (and it’s easier to do and less likely to cause problems as the old kernel will still be available in the boot menu under “Advanced Options”).

Or is it better to switch completely to Tumbleweed?

Well, as you write that it works as expected on Tumbleweed, switching to it may be the easier solution.
Although, you can of course still do that if trying to upgrade some components doesn’t help.


Thank you for the response :slight_smile:

Yes. The first thing I have tried was to run new versions of the kernel. I have tried latest stable 4.14 and latest LTS 4.9. I have also tried different kernel-firmware versions too. The problem persists.

In fact, I’m currently running kernel 4.9 LTS as default on my Leap for months, since kernel 4.4 LTS is pretty non compatible with new laptops and 4.14 has seemed to be too new in comparison to the rest of Leap’s package versions.

So in order to do a full repo switch is it sufficient to lower priority in Yast>Software Repositories ? What else should I do?

In the case upgrading Xorg only solves the problem, should I expected some compatibility issues along with Leap’s LTS KDE/Qt versions?

No, that’s not sufficient.
It will only affect newly installed packages, but won’t change already installed ones.

You need to do what the link I posted tells you.
Either run “zypper dup --from xxx”, or run YaST->Software Management, click on “View” and choose “Repositories”, select the corresponding repo in the list on the left and click on “Switch system packages to the versions in this Repository” (or similar) on top of the package list on the right.

In the case upgrading Xorg only solves the problem, should I expected some compatibility issues along with Leap’s LTS KDE/Qt versions?

Should work fine.

Thank you very much!

I will test it as soon as possible and will get back with a response :slight_smile:


I have updated to latest Xorg, KDE, Qt, Kernel-default and kernel-firmware.

The problem was solved :slight_smile:

Well, the laptop is pretty usable, however some other minor issues appeared:

I had to install latest Dolphin since search got broken.

The laptop power button is not working while in Plasma. It works to restart from shutdown, hibernate and suspend as usual.

The laptop function keys to change display brightness are not working, although I can change it through “Battery and Brightness” tray icon on panel. All other laptop function keys and the F11 and F12 keys are working normally.

upower is behaving weirdly after opening “energy information” window. Upgrading upower to tumbleweed version makes upower completely broken.

Yeah, forgot to mention that it might be a good idea to upgrade KDE Applications then too, mainly to have them built against the latest Qt5/KF5…

The repo URL is https://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_openSUSE_Leap_42.3/ , as you maybe found out already.
And it is advisable to do a full switch to that repo as well.

Although, I do think that (older) dolphin’s search should work with the newer Baloo…

Can’t help you with the other things though, I’m afraid.

Ok. Thank you very much! :slight_smile:

Another question, would be of any help upgrading to these repos too (checking the first options on file conflicts in Yast2):



Or would add some potential to bugs?

Sure it can add bugs.
These are development projects for Factory/Tumbleweed. Packages get updated there to be available for testing.

The first one is actually only available/intended for Factory anyway, do NOT add this to your 42.3 system (the packages won’t be compatible and likely break your system completely, especially considering that this is Base:System, i.e. some very fundamental packages like systemd).

The second should be fine I suppose.

But some caveat still applies: this contains packages before they are tested for inclusion in Tumbleweed (actually the same applies to [noparse] X11:XOrg, KDE:Frameworks5, KDE:Qt5, and KDE:Applications[/noparse]… :wink: ), and newer is not necessarily better, especially when you put it on top of an older base system.

If you always want the latest of everything, better use Tumbleweed.

If you create your own “Tumbleweed” by adding all possible (and impossible) repos, it likely won’t be more stable, rather the opposite.


Thank you very much for your help and your comments :slight_smile:

It seems I will need to spend some time testing indeed. Unfortunately, this is kind of expected I suppose when one buy new hardware that is not at all made to support linux kernels like this laptop. Anyway, I’m waiting anxiously here for the new Leap version (Leap 15, I guess) with new LTS kernel.

I’m wondering if you have tried Korganizer since upgrading. I had upgraded 42.3 exactly as described in this thread with complete success for a few months. At some point in November or December Korganizer started to crash every time I tried to enter a new event. I believe this bug shows up in Bugzilla. Since Korganizer is an essential app for me, I reverted to the original QT, Framework, and applications in the distro. This fixed my problem, but I am wondering if the newer Korganizer has been fixed. Also, Baloo in the stock version tends to eat my cpu and uses gigabytes of memory. I’ve had to disable it. I’m wondering if the new version of Baloo has fixed this problem. Just curious if you have tried these out.

This is not a general problem (e.g. it always worked fine here), so it’s unlikely that somebody else can tell you whether your problem is fixed.

One things that may cause crashes is a corrupted search index, deleting ~/.local/share/baloo/ and ~/.local/share/akonadi/search_db/ (if it exists) might help.

Also, Baloo in the stock version tends to eat my cpu and uses gigabytes of memory. I’ve had to disable it. I’m wondering if the new version of Baloo has fixed this problem. Just curious if you have tried these out.

Similar things here.
That’s not a general problem, and likely related to the particular files you have in your home folder.

I’m not aware of any specific fixed in this regard.

Thanks, Wolfi. I’ll erase the files you mentioned.

Interesting about Korganizer. There are a couple of people who’ve reported the same issue on Bugzilla, but no resolution. It must have something to do with some interaction that’s dependent on a particular configuration.