Upgrade tumbleweed version / repos?

Hi,

pretty often when I try to upgrade, I get the problem with *:



sudo zypper dup 
Loading repository data... 
Reading installed packages... 
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible b
efore you continue. See 'man zypper' for more information about this command. 
Computing distribution upgrade... 
Nothing to do.



I try to uncheck some repos but still the same, idea?

thanks

Hi
You need to show a list of your (enabled) repositories;


zypper lr -dE



**james@msi**:**~**> zypper lr -dE 
# | Alias        | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                        
                           | Service 
--+--------------+-----------------------------+---------+-----------+---------+----------+--------+----------------------------
---------------------------+-------- 
6 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.or
g/tumbleweed/repo/non-oss/ |  
7 | repo-oss     | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.or
g/tumbleweed/repo/oss/     |  
9 | repo-update  | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.or
g/update/tumbleweed/       |  
**james@msi**:**~**> 


and when everything is enable :


[FONT=monospace]
[/FONT][FONT=monospace][FONT=monospace] zypper lr -dE 
# | Alias                                | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI
                                                                       | Service 
--+--------------------------------------+-----------------------------+---------+-----------+---------+----------+--------+----
-----------------------------------------------------------------------+-------- 
2 | brave-browser-nightly                | brave-browser-nightly       | Yes     | (r ) Yes  | No      |   99     | rpm-md | htt
ps://brave-browser-rpm-nightly.s3.brave.com/x86_64/                    |  
3 | ftp.gwdg.de-openSUSE_Tumbleweed      | Packman Repository          | Yes     | ( p) Yes  | Yes     |   99     | NONE   | htt
p://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/       |  
4 | https-download.opensuse.org-2597409d | openSUSE:Tumbleweed         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | htt
ps://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ |  
5 | repo-debug                           | openSUSE-Tumbleweed-Debug   | Yes     | ( p) Yes  | Yes     |   99     | NONE   | htt
p://download.opensuse.org/debug/tumbleweed/repo/oss/                   |  
6 | repo-non-oss                         | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | htt
p://download.opensuse.org/tumbleweed/repo/non-oss/                     |  
7 | repo-oss                             | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | htt
p://download.opensuse.org/tumbleweed/repo/oss/                         |  
8 | repo-source                          | openSUSE-Tumbleweed-Source  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | htt
p://download.opensuse.org/source/tumbleweed/repo/oss/                  |  
9 | repo-update                          | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | htt
p://download.opensuse.org/update/tumbleweed/                           |  
**james@msi**:**~**> 
 

[/FONT] [/FONT]

Hi
Likely repo #4 causing the issue, just have 2,3,6,7 and 9 enabled, then run ‘zypper -vvv dup’.



sudo zypper -vvv dup 
Verbosity: 3 
Initializing Target 
Checking whether to refresh metadata for brave-browser-nightly 
Checking whether to refresh metadata for Packman Repository 
Checking whether to refresh metadata for openSUSE-Tumbleweed-Non-Oss 
Checking whether to refresh metadata for openSUSE-Tumbleweed-Oss 
Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/repodata/repomd.xml .........................................[done] 
Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/media.1/media ...............................................[done] 
Checking whether to refresh metadata for openSUSE-Tumbleweed-Update 
Loading repository data... 
Reading installed packages... 
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible b
efore you continue. See 'man zypper' for more information about this command. 
Computing distribution upgrade... 
Force resolution: No 
Computing upgrade... 

The following 11 package updates will NOT be installed: 
  libavcodec58_134  4.4.1-7.3                       x86_64  Packman Repository  http://packman.links2linux.de 
  libavfilter7_110  4.4.1-7.3                       x86_64  Packman Repository  http://packman.links2linux.de 
  libavformat58_76  4.4.1-7.3                       x86_64  Packman Repository  http://packman.links2linux.de 
  libavresample4_0  4.4.1-7.3                       x86_64  Packman Repository  http://packman.links2linux.de 
  libavutil56_70    4.4.1-7.3                       x86_64  Packman Repository  http://packman.links2linux.de 
  libfdk-aac2       2.0.2-1.16                      x86_64  Packman Repository  http://packman.links2linux.de 
  libheif1          1.12.0-3.22                     x86_64  Packman Repository  http://packman.links2linux.de 
  libpostproc55_9   4.4.1-7.3                       x86_64  Packman Repository  http://packman.links2linux.de 
  libquicktime0     1.2.4+git20180804.fff99cd-4.57  x86_64  Packman Repository  http://packman.links2linux.de 
  libswresample3_9  4.4.1-7.3                       x86_64  Packman Repository  http://packman.links2linux.de 
  libswscale5_9     4.4.1-7.3                       x86_64  Packman Repository  http://packman.links2linux.de 
Nothing to do. 
**james@msi**:**~**> 
 

Hi
The only one to switch to packman from that list is libheif1 the rest should be installed from the oss repo.

What snapshot are you at?


cat /etc/os-release | grep VERSION_ID

VERSION_ID=“20220302”

I would like to upgrade to 20220303 to some new updates as I seen

Hi
That’s the current version, so you should be good.

nut not, still same message about all repos

Hi
I suspect the brave nightly one, if you disable that one the warning should disappear, if it does then if you happy to treat as a warning, then just ignore :wink:

stil the same but how I can ignore it, it gives me no other option

Hi
Strange, force a refresh;


zypper -vvv ref -f

As I recall it, that warning message shows every time you use zypper dup. I’ve always understood it to be a general warning to make sure you only have compatible repos. If not you could damage your sytem with incompatible software.
I know my repos in tumbleweed are all correct so I ignore the warning.

yes I understand but my question is, how to ignore it, my repos are ok.

Hi
Do another dup as there is the next snapshot, all will be fine,…

thank you, I have now the 20220303

someone knows why it says to upgrade tumbleweed with zypper dup but after zypper update + yes, it seems to be installed / upgarded ?



The following product is going to be upgraded: 
  openSUSE Tumbleweed  20220305-0 -> 20220306-0 
    Product 'openSUSE Tumbleweed' requires to be updated by calling 'zypper dup'! 

11 packages to upgrade. 
Overall download size: 16.2 MiB. Already cached: 0 B. After the operation, additional 30.4 KiB will be used. 

    Consider to cancel: 
    Product 'openSUSE Tumbleweed' requires to be updated by calling 'zypper dup'! 
**Continue? [y/n/v/...? shows all options] (y): **y 
Retrieving package libavcodec58_134-debuginfo-4.4.1-7.5.x86_64                            (1/11),  12.4 MiB ( 46.0 MiB unpacked) 
Retrieving: libavcodec58_134-debuginfo-4.4.1-7.5.x86_64.rpm ..................................................[done (3.5 MiB/s)] 
Retrieving package libgphoto2_port12-2.5.29-1.1.x86_64                                    (2/11), 103.0 KiB (172.6 KiB unpacked) 
Retrieving: libgphoto2_port12-2.5.29-1.1.x86_64.rpm ........................................................[done (230.0 KiB/s)] 
Retrieving package libgphoto2_port12-32bit-2.5.29-1.1.x86_64                              (3/11), 101.6 KiB (158.9 KiB unpacked) 
Retrieving: libgphoto2_port12-32bit-2.5.29-1.1.x86_64.rpm ................................................................[done] 
Retrieving package libixion-0_17-0-0.17.0-2.1.x86_64                                      (4/11), 247.1 KiB (700.9 KiB unpacked) 
Retrieving: libixion-0_17-0-0.17.0-2.1.x86_64.rpm ........................................................................[done] 
Retrieving package openSUSE-release-appliance-custom-20220306-1479.1.x86_64               (5/11),   7.5 KiB (   79   B unpacked) 
Retrieving: openSUSE-release-appliance-custom-20220306-1479.1.x86_64.rpm .................................................[done] 
Retrieving package plasma5-pk-updates-0.3.2+git70-1.1.x86_64                              (6/11),  76.1 KiB (202.9 KiB unpacked) 
Retrieving: plasma5-pk-updates-0.3.2+git70-1.1.x86_64.rpm ................................................................[done] 
Retrieving package yast2-network-4.4.43-1.1.noarch                                        (7/11), 262.2 KiB (  1.1 MiB unpacked) 
Retrieving: yast2-network-4.4.43-1.1.noarch.rpm ..........................................................................[done] 
Retrieving package libgphoto2-6-2.5.29-1.1.x86_64                                         (8/11), 725.1 KiB (  3.1 MiB unpacked) 
Retrieving: libgphoto2-6-2.5.29-1.1.x86_64.rpm .................................................................[done (979 B/s)] 
Retrieving package libgphoto2-6-32bit-2.5.29-1.1.x86_64                                   (9/11), 664.2 KiB (  1.9 MiB unpacked) 
Retrieving: libgphoto2-6-32bit-2.5.29-1.1.x86_64.rpm .....................................................................[done] 
Retrieving package openSUSE-release-20220306-1479.1.x86_64                               (10/11),   1.5 MiB (230.7 KiB unpacked) 
Retrieving: openSUSE-release-20220306-1479.1.x86_64.rpm ......................................................[done (4.5 MiB/s)] 
Retrieving package plasma5-pk-updates-lang-0.3.2+git70-1.1.noarch                        (11/11), 221.9 KiB (  1.4 MiB unpacked) 
Retrieving: plasma5-pk-updates-lang-0.3.2+git70-1.1.noarch.rpm ...........................................................[done] 

Checking for file conflicts: .............................................................................................[done] 
( 1/11) Installing: libavcodec58_134-debuginfo-4.4.1-7.5.x86_64 ..........................................................[done] 
( 2/11) Installing: libgphoto2_port12-2.5.29-1.1.x86_64 ..................................................................[done] 
( 3/11) Installing: libgphoto2_port12-32bit-2.5.29-1.1.x86_64 ............................................................[done] 
( 4/11) Installing: libixion-0_17-0-0.17.0-2.1.x86_64 ....................................................................[done] 
( 5/11) Installing: openSUSE-release-appliance-custom-20220306-1479.1.x86_64 .............................................[done] 
( 6/11) Installing: plasma5-pk-updates-0.3.2+git70-1.1.x86_64 ............................................................[done] 
( 7/11) Installing: yast2-network-4.4.43-1.1.noarch ......................................................................[done] 
( 8/11) Installing: libgphoto2-6-2.5.29-1.1.x86_64 .......................................................................[done] 
( 9/11) Installing: libgphoto2-6-32bit-2.5.29-1.1.x86_64 .................................................................[done] 
(10/11) Installing: openSUSE-release-20220306-1479.1.x86_64 ..............................................................[done] 
(11/11) Installing: plasma5-pk-updates-lang-0.3.2+git70-1.1.noarch .......................................................[done] 
Executing %posttrans scripts .............................................................................................[done] 
There are running programs which still use files and libraries deleted or updated by recent upgrades. They should be restarted to benefit from the latest updates. Run 'zypper ps -s' to list these programs. 
  
**james@msi**:**~**> sudo zypper dup 
Loading repository data... 
Reading installed packages... 
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command. 
Computing distribution upgrade... 
Nothing to do. 
**james@msi**:**~**> cat /etc/os-release | grep VERSION_ID 
**VERSION_ID**="20220306"



Hi
For Tumbleweed, only use zypper dup not up, each snapshot is a new release.

yes but if you look at my copied text, we see tumbleweed upgraded from zypper up…

Thats right, but not all packages…

With zypper up in Tumbleweed you will run into problems, sometimes earlier, sometimes later.

Use only

zypper dup