upgrade to PHP5.6.30


I am a new OpenSuse user. I need to use PHP5.6.5 or above.

I installed LAMP on OpenSuse42.3. It was PHP5.5.14. I am going to upgrade it to PHP5.6.30 and hit a error.

First command returned successfully:
zypper ar -f http://download.opensuse.org/repositories/devel:/languages:/php/openSUSE_Leap_42.3/devel:languages:php.repo

Second command returned with error:
zypper up -r devel_languages_php php5

File ‘./repodata/833831df264e45ba999ceac74a266838b76799b1101102e5fe817f274ad1be66-primary.xml.gz’ not found on medium ‘http://download.opensuse.org/repositories/devel:/languages:/php/openSUSE_Leap_42.3/

Then I went to YAST2 Software Management. On starting this module, the same error poped up. I chose skipping it. When I run a search, there wasn’t any PHP5.6.30 but only PHP5.5.14 and PHP7

Could anyone please help?

In my opinion, you need a switch to that new repo. And that is done with

zypper dup --from <the name, alias orr number from the new repo comes here>

You do this only one time to switch the vendor of the packages that you already have from the OSS repo, to those of the same name on the new repo. After that you can do zypper up when needed.

But I am afraid that that does not explain the error. That needs further investigation (by me or others that know better).

http://download.opensuse.org/repositories/devel:/languages:/php/openSUSE_Leap_42.3/repodata/repomd.xml does not contain the right Filenames for xxxxx.xml.gz.

Problem on the Server.

Possible mirror here;


Thank all of you! I have tried following 2 commands and it still returned error.


Su423-PHP56:~ # zypper ar -f http://ftp.gwdg.de/pub/opensuse/repositories/devel%3A/languages%3A/php/openSUSE_Leap_42.3/devel:languages:php.repo
File '/pub/opensuse/repositories/devel%3A/languages%3A/php/openSUSE_Leap_42.3/devel:languages:php.repo' not found on medium 'http://ftp.gwdg.de/'

Abort, retry, ignore? [a/r/i/...? shows all options] (a): a

Su423-PHP56:~ # zypper dup --from http://ftp.gwdg.de/pub/opensuse/repositories/devel%3A/languages%3A/php/openSUSE_Leap_42.3/devel:languages:php.repo
Retrieving repository 'devel:languages:php (openSUSE_Leap_42.3)' metadata ---|]
File './repodata/833831df264e45ba999ceac74a266838b76799b1101102e5fe817f274ad1be66-primary.xml.gz' not found on medium 'http://download.opensuse.org/repositories/devel:/languages:/php/openSUSE_Leap_42.3/'



Well, when the first command did not finish successful, it is rather useless to start the second command.

And the parameter belonging to --from in the second is not what I suggested.

Please show your current repo list:

zypper lr -d

Plus with the scheduled outage, there were mirror issues etc, best to wait until after the weekend and it’s back on the real systems rather than backup ones.


I also tried to load Miuku’s repo. It was successful:

# zypper ar -f https://download.opensuse.org/repositories/home:/Miuku/openSUSE_Leap_42.3/home:Miuku.repo

Then I went to YAST2 Software Management, there was similar error:

File './repodata/844df0e2d51e027411882a7cf2d1bfbd0f47e8bb8cd0b6a52a32486dc4852d06-primary.xml.gz' not found on medium 'http://download.opensuse.org/repositories/home:/Miuku/openSUSE_Leap_42.3/'

I am not sure if I input wrong arguments.


Oh yes, there is scheduled outage notice. I will enjoy my Sunday and come back again on Mon.
Many thanks everybody!

Have a joyful Sunday!

After adding the PHP repo, you should have been able to upgrade with a no-uptions update (no need for vendor change, etc).
Updating should automatically detect the newer version PHP packages and update automatically.

So, just run

zypper up

And then check your PHP version.
I assume if you’ve already enabled PHP modules for apache, you won’t have to re-inspect your modules.

As for your looking for PHP 6.5…
It’s never been released, so not likely available anywhere in openSUSE.
What are you doing that requires it?
And… Because it was never released, you’ll likely get it only from a PHP repo, nowhere else.


I see or higher in the first sentence… OP can just install PHP 7 then part of the available default packages…

Information for package php7:
Repository     : openSUSE-Leap-42.3-Update
Name           : php7                     
Version        : 7.0.7-22.1               

Dear all experts,

I just get back to this task today. I am not familiar with zypper, so I went to YaST2 Software Management. Last Saturday’s error disappeared today (as Opensuse server is back to normal, I think). I just ticked all PHP 5.6.31 items in Development>Libraries RPM group. The upgrade process is quite smooth.

I try this version because I need to use PHP level transaction control for MYSQL. I am afraid PHP7 is too new that not much code on web I can reference from. However as its performance is much faster, I may test my application on it very soon.

All your advice and help make me walk faster and lighter. Many thanks ! :slight_smile: