Upgrade to Gnome 2.26 observations

Upgraded to Gnome 2.26 today and noticed…

Gnome Terminal no longer works. Click and watch spinning icon for a while then nothing. Upgraded to the latest Gnome terminal version, same results. Worked fine prior to the upgrade. X term continues to work.

Windows now have unseen title bar icons. In other words, everything on the title bar is invisible. Close, Minimize and Maximize still work when mouse is pointed to correct location on the bar, but the “X”, etc are no longer visible. I’ve tried several themes. All give same results. Other parts of windows look OK; menu bar, etc.

All the other stuff I’ve tried seems OK, but I haven’t tried everything, it’s only been an hour or so since the upgrade.

I’ll keep poking around. OpenSUSE v11.1 btw.

Sounds more like some parts of your installation did not properly upgrade.

Have you zypper ref && zypper ve’d?

No problems reported with the above command.

I guess I’ll blow up my GNOME installation, not that I really ever use it.

Which address/repo did you upgrade from?

The ones listed here: GNOME/2.26 - openSUSE

Found this today after poking around looking for what was installed with the Gnome upgrade to v2.6.

While reading about GNOME-desktop, see below. I have no idea if this is related to what happened after I installed v2.6 but I did notice the “Use them at your own risk” comment.


gnome-desktop
This package contains the libgnome-desktop library that contains APIs that really belong in libgnome/libgnomeui but have not seen enough testing or development to be considered stable. Use them at your own risk.
Also contained here are documents installed as part of the core GNOME distribution: the GPL, GNOME’s .desktop files, the gnome-about program, some man pages, and GNOME’s core graphics files and icons.


Also don’t know if other stuff that was installed could/might have caused the problems.

I’ll spend a bit more time poking around, but would like to know if there is a how-to on downgrading from Gnome 2.6 to 2.4.

TIA

This GNOME release is somewhere on the way for GNOME 3. They are started to change some features - this screwed up some settings but OK. These bugs are reported you can track them here:
https://bugzilla.novell.com/show_bug.cgi?id=493750.
If you have problem with the programs make sure that the GNOME 2.26 repos have highest priority than the others - lower number means higher priority!

Checked the bug list and there was one that reported problems with Gnome Terminal and themes, both of which I noticed. It was suggested that updating to the latest version of gtk2 fixed things. I had updated to what I thought the latest version (2.16.1-1.9) – no help. All the gtk2 stuff I have are dated mid to late May, so I assume that’s fairly current. Also noticed another note on this same topic here w/similar results. I guess I’ll keep looking for another release of the gtk2 kit.

There was another GNOME update - yesterday. Maybe the problems were fixed. I’ll update tomorrow - I’ll also report if there were any changes in the bugs listed on bugzilla.

I’m having similar problems - had to upgrade to 2.26 to get Compiz to work with Emerald (see Wiki hereabouts - which worked but then updated something else and now have all kinds of issues: no terminal, no SUSE menu (plain Gnome menu works when added to panel), etc.
So how to get back to 2.24 (I can always deal with Compiz later)? Zypper something I expect?

Disable your GNOME 2.26 repositories and downgrade your packages in YaST to GNOME 2.24 (from patterns select GNOME and where the version number is 2.26 select and earlier version for that package in the drop-down list).

Hmmm, did that and no great improvement. So I went beyond the pattern and restored a great deal of other packages to their previous versions, and got some improvement. But basically it’s still borked: it looks like there’s two desktops. My old background comes up on a fresh boot and is then overlaid by solid green. On restarting X I sometimes get the main menu, sometimes I don’t. Sometimes Nautilus works, sometimes it doesn’t, and so on.Apps work, as far as I can tell, but I don’t have access to the external USB drive.
Is using the DVD to repair the entire system my only remaining option?

Have you tried to reset your GNOME settings?
In your home directory execute:


mv .gnome2 .gnome2_old

. It’s working for KDE4 hope that works with GNOME too.
This will reset your personal settings in GNOME applications!

Haven’t done it yet because I’ve made some more progress by hunting down more packages with the wrong version and downgrading them. I now have my desktop background and all other settings (fonts, panel apps etc) back, and almost everything seems to work (including terminal), except Nautilus and the SUSE slab menu (the Gnome menu works). When I try to launch Nautilus from the terminal I get the following error:

(nautilus:20080): Eel-WARNING **: GConf error:
  Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

I’ve reinstalled Gconf and Nautilus but no change.
I’m tempted to try your suggestion (many thanks for your help) now but don’t want to lose all my personal settings so I’m waiting to see if someone (perhaps a Gnome user) comes along with some other idea.

Yep I’m a GNOME users and I don’t have any other idea.
Your current settings are corrupted, deleting it would be the only way to restore the default configuration.

Removing the repos and doing

zypper dup

could have been better I think. I’ve gone 2.26 twice, had the same issues as you and went back that way. No problems with 2.24;)

Do you think it might still be worth doing? What does it do? And which repos do you disable - only the non-offical ones I assume?

1 Remove the gnome 2.26 repos- all of them
2 Go in terminal and do zypper dup (distribution upgrade -basicly it will dongrade your gnome 'couse you don’t have the 2.26 repos)
I don’t know if it’s still worth doing. You can do it anyway, maybe you missed some 2.26 packages and they are still installed.

I have upgraded to 2.26.2 but nothing was fixed from the known bugs so far.

After applying several updates today, as I normally do every day, Gnome terminal now works. Wish I knew what update fixed things.

The invisible title bar elements remain a problem.