Upgrade to 13,2

Greetings,

I Upgraded from 13.1 to 13.2, but the welcome screen still show 13.1 !!

anyhow, how can I check the upgrade process went successful ?

Thanks

You can fix that yourself by editing “/etc/default/grub”.

That file is considered a local configuration file, so the upgrade won’t change it.

anyhow, how can I check the upgrade process went successful ?

If your system is working well, and if you are using the 13.2 repos, then it went well.

You can also try:


cat /etc/os-release

to see your version.

Thanks,

I edited the file

/etc/default/grub

changing 13.1 to 13.2 , but still gives me 13.1 at startup

Now run:


# grub2-mkconfig -o /boot/grub2/grub.cfg

That regenerates “grub.cfg” and the new version should say “13.2”. Any other changes that you made to “/etc/default/grub” will also be applied.

This solution to regenerate the grub.cfg file fix my problem during the upgrade. I was following the directions from https://en.opensuse.org/Upgrade

grub2-mkconfig -o /boot/grub2/grub.cfg

grub2-install /dev/sdX

where /dev/sdX is your boot drive. I also added

mkinitrd

Other than this painfaul problem, I’m well satisfied with 13.2. Run faster.

Note that you can also do it in Yast -boot loader with less pain :wink:

On 2014-11-30 04:26, john613 wrote:
>
> This solution to regenerate the grub.cfg file fix my problem during the
> upgrade. I was following the directions from
> https://en.opensuse.org/Upgrade
>
> # grub2-mkconfig -o /boot/grub2/grub.cfg

The rest you do not need, in order to correct the OP problem, which is
just a message line.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Since I was doing it from a LiveCD, I didn’t knew how to do it from Yast. Would it be possible from a LiveCD?

Maybe I think you can point yast to the drive to write the boot to.

On 2014-12-02 16:36, john613 wrote:
>
> gogalthorp;2679862 Wrote:
>> Note that you can also do it in Yast -boot loader with less pain :wink:
>
> Since I was doing it from a LiveCD, I didn’t knew how to do it from
> Yast. Would it be possible from a LiveCD?

But jamilsaif problem was just the grub message saying that it was 13.1,
and to change that you do not need the live.

I think that using yast from the live is not that trivial; possibly you
would have to chroot to the destination, so that it is fact yast from
the destination which runs, not yast from the live.

I don’t know of a setting to tell yast to work on a different filesystem
than the one that is running. It would be a nice and useful thing to
have, though.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Think you can do it in disk order but never tried it.

But if you can boot you don’t need the live you can do it normally just change the text in Yast

Just boot normally into your new installation, which is mislabeled. Then use YAST’s Bootloader app to change the TITLE from 1 to 2 (leave the 13. intact). That’s all there’s to it. It’s just a title. You did a successful upgrade.

Or just remove the 13.x altogether, you won’t have to change it after the next upgrade then… :wink:

Btw, the default is to use just “openSUSE” (without the version) on a fresh 13.2 installation.

You can of course also use anything else you want, “GeekoOS” e.g. :wink:
As mentioned, it is only a title.