Upgrade to 12.3 from 12.2 - cannot start x (Nvidia)

Hi all

I have an Nvidia GTX550, which was running fine on 12.2

After upgrading to 12.3 startup halts on a message “Reached graphical user interface”

when i alt+f10’d, it said the kernal of the nividia driver and OS were different (I was sure nvidia drivers were in the list when the upgrade was installing?)

so i followed the instructions here:


but the outcome is the same, only now it’s because the system can’t find nvidia0, which is a very funny joke since I’m reading the message

someday it’d be nice to change this thing without wondering if the whole nvidia license thing is going to make the thing unusable…

Update: progress!

I’ve removed all existing nvidia drivers using zypper and removed any nvidia listings from modprobe, after rebooting I now have x server starting and can access the desktop (And it’s all looking beautiful! first time I’ve seen it since the upgrade…)

Anyway, Now I’m using basic drivers I go to the NVidia section on the opensuse site for the one click installs, I’ve tried all of them in turn and nothing new seems to happen (IE I’m still stuck on only a single monitor etc)

Given that I’m using a GTX550 Ti, does anyone know of the best method of trying to get the actual nvidia drivers? When I first installed opensuse at a previous version the one click install worked fine the last time

Please post output of

zypper lr -d

between CODE tags, the # in the editor.

#  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service
 1 | Google-Chrome             | Google-Chrome                      | Yes     | No      |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                 |        
 2 | download.opensuse.org-oss | Main Repository (Sources)          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/12.3/repo/oss/                     |        
 3 | driver:wireless           | driver:wireless                    | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/driver:/wireless/openSUSE_12.2/           |        
 4 | games                     | games                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_12.3/                      |        
 5 | google-chrome             | google-chrome                      | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                 |        
 6 | nVidia Graphics Drivers   | nVidia Graphics Drivers            | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/12.3/                                            |        
 7 | openSUSE-12.3-1.6         | openSUSE-12.3-1.6                  | No      | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SH-222BB_R8LM68AC600E7L,/dev/sr0 |        
 8 | openSUSE_12.3-1.6         | openSUSE 12.3-1.6                  | No      | No      |   99     | yast2  | cd:///                                                                              |        
 9 | packman.inode.at-suse     | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/12.3/                                                  |        
10 | repo-debug                | openSUSE-12.3-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.3/repo/oss/                      |        
11 | repo-debug-update         | openSUSE-12.3-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.3/                                     |        
12 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.3-non-oss/                             |        
13 | repo-non-oss              | openSUSE-12.3-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.3/repo/non-oss/                        |        
14 | repo-oss                  | openSUSE-12.3-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.3/repo/oss/                            |        
15 | repo-source               | openSUSE-12.3-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.3/repo/oss/                     |        
16 | repo-update               | openSUSE-12.3-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.3/                                           |        
17 | repo-update-non-oss       | openSUSE-12.3-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.3-non-oss/   

One thing I see - nothing to do with this problem - is that the wireless repo is a 12.2 one. You should remove it or correct the URL.

Also, remove the cd:// repos, remove one of the google repos.

In your case I’d remove the nvidia repo too, and give this one-click a try: http://opensuse-community.org/nvidia.ymp.

Hi, yeah the wireless was for a ralink2800 adapter chipset, so there was no chance of it working with 12.3 anyway so it’s disabled and left to 12.2, luckily OS12.3 seems to support it as standard which is nice, so i’ll remove it now. the CD ones were just for installing stuff i needed to get networking to work first time, I’ll remove them too when I’m removing this nvidia one and re-trying the one-click, cheers

If it fails again, don’t immediately uninstall them, we might find some info in the logs.

Hi, It’s the same again, no secondary display detected and I’m not sure the new drivers are even being used

Have you tried running nvidia_settings program (as root). That usually works for me. I think it is a separate program now I installed it via yast and the NVIDIA repo.

Hi gogalthorp, running nvidia-settings just gives the following output:

ERROR: The control display is undefined; please run `nvidia-settings --help` for usage information.

Got me then. I’d say foe some reason you are not getting the driver installed. Since you have tried about every method I’m out of ideas.
I have never had or hared of such a problem. Sometimes the the driver breaks things but I never had it not install.

Have you tried dropping back to an older driver. I run an older 6800+ and I use the GO2 driver rather then the G03

yeah I tried G01-G03 (uninstalling the last one installed before trying the next)

I’m happy enough that at least one monitor’s working, but somehow it just seems I’ve jumped 10 years into the past running it like this :frowning:

Well all I can say it works great on my old hardware. Was a little bit of a struggle to install but with the knowledge from this forum it was not a big deal. Sorry it is not working out for you. You should report this on bugzilla or it may never get fixed.

Definitely thanks for trying anyway :slight_smile:

I’m holding off on a bug report for now, simply because I’m fully aware it’s very easily just something fundamental that I’ve done or not done (though i’m not sure what; working, upgrade OS, not working…) but at least if other people take a look they can point me to the most useful logs etc to include with any reports

Or if it gets fixed someone with the same problem can find the thread

Hi, It’s the same again, no secondary display detected and I’m not sure the new drivers are even being used

FWIW, your dual screen issue appears to resemble the one reported here with similar hardware:


Am troubleshooting this thing now, too.

Kms on/off
Nouveau driver
Nv driver
All proprietary drivers offered in the nvidia repo

Sol so far.
This was a zypper dup from 12.2,
Everything else seems to work, can boot into emergency mode and get network access plus everything else.

But no nvidia video solution so far.

HP dv 9500
GPU 8600M GS

Limping along in 640x480

After some investigation and surveying the Internet landscape, IMO there have been some serious mis-calculations on the part of the openSUSE kernel maintainers as well as the core Linux kernel maintainers.

It’s impossible of course to accurately estimate the degree of a problem based on Internet postings, but some things are unquestionable… That not only has there been a steady drumbeat of video driver problems related with the 3.7x kernel, people have been posting their unresolved problems right up to this month (Mar 2013).

In my mind, this means that this kernel is undeniably unstable and should never have been used as the “stable” default version for openSUSE. Kernel problems need to be resolvable or they should not be used.

Less clear are the secondary questions

  • How extensive are the problems?
    There is some scuttlebutt that relatively few of the many nVidia GPUs were tested during kernel development. Regardless, I wonder why KMS “off” doesn’t have an API/interface that’s identical to kernels 3.5 or 3.4 which should have addressed the worst scenarios, but that doesn’t seem to be the case.
  • How much attention and resources are available for resolving these problems?
    Scuttlebutt is that there is relatively little attention being lent to 3.7, most attention now is on 3.8 and when ready 3.8 might actually solve all these problems in 3.7. This makes sense whether actually true or not. So, maybe an option is to go Tumbleweed in an effort to get the 3.8 kernel? In any case, 3.7 may become a footnote of display driver mistakes.

Most common attempts to fix the problem:
I’ve skimmed a number of “fixes.” Many didn’t actually fix the 3.7 problem, they simply installed 3.5 or 3.4 kernels. Others attempted to compile their own kernels with various recommendations, with varying success. Bottom line, this is an option only if you’re brave, understand no guarantee for success and have lots of time.

My Recommendation:
Immediately, on an emergency basis make a 3.5x kernel available. Although there are still some reported issues, most seem to be addressable and solutions are known.

My current course of action:
More than likely I will see if I can restore using a 12.2 YAST restore. Maddenningly, I have found that the 12.3 restore is broken, it can’t even read a backup it itself just created. Failing that and before considering a brand new re-install is the Tumbleweed option I mentioned above, but of course that option also has its own risks even if the display driver problem is resolved.


You should post it on factory if you want it to be “officially” available for 12.3.

Well, that’s a thought.
Looks like subscribing to Tumbleweed isn’t necessary, it looks like the kernel team has posted a 3.8.2 uploaded Mar6 to Factory as of today. I should find some time to test sometime tomorrow.

Am willing to exhaust all everyone has already done before considering doing things on my own.


Looks like a spoke too soon. With the G02 driver and a 6800+ card 3D is just not right. I play Eternal lands and I had to degrade it to have it render right and frame rate is very poor. Google-Earth runs but renders nothing.

Tried the G03 but would not boot at all even though it says for 6XXX and above. Thinking of trying GO1 it is closer to what worked in 11.4.

2D is actually pretty good and desktop effect seem ok also.

So waiting to see