Upgrade to 11.3 -> HAL trouble

I already posted my problem in the German subforum but as here are much more people reading (and helping) I’d like to post my problem here too.

I upgraded to 11.3 (from 11.2) online. HALD does not startup. Log messages can be found in this post.

Any ideas where to start searching for the problem?

Upgrade can be troublesome. I recommend a clean install. It is less trouble in the long run. Something left behind from the old system is not setting right with the new system.

Is you libglib package up to date? I wonder if the live upgrade missed a couple of libraries.

EDIT: The libglib-2_0-0-2.24.1-2.5 version from the package search should be the right one.

libglib has version number 2.24.1-2.5

If there are no other suggestions I think I should really start from scratch. Really annoying…

To make a long story short: it was some old libraries in /usr/local/lib (including an old version of glib).

I came across that other hal and dbus related programs like console-kit-daemon, update-mime-database and some more complained about undefined symbol g_malloc_n or g_malloc0_n.

“ldd console-kit-daemon” quickly showed that the shared library libglib-2.0.so.0 from /usr/local/lib was used. After deleting all files from /usr/local/lib everything looks fine now.

So three days of investigating saved me from a fresh install… :slight_smile:


thanks dude, you solved my problem too. I am using opensuse 11.3 ans was faving this problem for the last one day. :slight_smile:

Nice work Jay! Could you please explain in more detail how you found and solved the problem?
I have a similar issue, as a workaround I issue a:
~>sudo rchal force-reload
But I would like to know how to get hal to run at boot. It used to!