Upgrade to 11.2 with broken zypper?

When I attempt to refresh my zypper repositories, I get messages like:

Repository ‘gwdg_suse11.1’ is invalid.
File /var/tmp/TmpFile.vRNflE doesn’t contain public key data

I’ve asked for help (which has been freely given) on these forums before, but nothing has worked, and I’ve been stuck with this error for many months now. In effect, my system is effectively non-upgradable.

However, I would like to upgrade to 11.2. Is there an upgrade CD, or should I just download the 11.2 DVD (at nearly 5GB) and choose the “upgrade” option from it?


Can we take a look at your configured repos?

zypper lr -d

This is the output of “zypper lr -d”:

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | gwdg_suse11.1 | gwdg_suse11.1 | Yes | Yes | 99 | rpm-md | Index of /pub/opensuse/distribution/11.1/repo/oss |
2 | repo-update | openSUSE-11.1-Update | Yes | No | 99 | rpm-md | Index of /update/11.1

I remember the threads concering this now. You have minimal repos enabled, any reason for this?

I had a quick look through the gwdg repo, and the files in the oss and non-oss directories have not been updated since December 2008, so I can’t see why you’d want it anyway.

My suggestion is to disable or delete it, and maybe add the packman repo instead. Depending on what desktop you have installed, consider having the relevant KDE or Gnome repos as well.

Otherwise, move on to openSUSE 11.2.

Thanks - I’ve been through adding and deleting repositories, deleting and reinstalling zypper, deleting and reinstalling GPG, fiddling with Yast; the lot. But I consistently get “File /var/tmp/TmpFile.vRNflE doesn’t contain public key data” type errors.

For example, if I remove the gwdg_suse11.1 repository, and then perform “zypper refresh”, I obtain:

Retrieving repository ‘openSUSE-11.1-Update’ metadata [error]
Repository ‘openSUSE-11.1-Update’ is invalid.
File /var/tmp/TmpFile.1KVKbo doesn’t contain public key data

There seems to be some sort of glitch deep in my system which has made zypper unusable.

Since I can’t upgrade directly, I’m going to have to use an 11.2 DVD - and indeed I’ve just ordered one. (Saves an interminable download.)

The gpgkeys are stored in /var/cache/zypper/raw AFIK. I guess you could have deleted the repodata there, and then tried re-importing the keys with something like

rpm --import http://download.opensuse.org/update/11.1/repodata/repomd.xml.key

Another simple experiment might be to update with

zypper --no-gpg up

Not normally recommended, but in your case probably worth a go.

Since I can’t upgrade directly, I’m going to have to use an 11.2 DVD - and indeed I’ve just ordered one. (Saves an interminable download.)

With a situation like this I would do a fresh install in preference to an upgrade (actually I always do anyway)

Whatever is causing this is something you don’t want to be included in 11.2.

The DVD is nice to have, so is a liveCD as it allows you to see how the hardware will behave with 11.2, The liveCDs are installable and are also far smaller downloads than the DVD.

Yes, I think an install from scratch (probably including a reformatting of my hard disk) would be the way to go. I know that all my hardware works, so it’s really just a matter of doing a full backup first!


Creating a fresh file system (often called “formatting”) for the root partition is the correct thing to do here, but there is no need to do it for your /home partition, except when one of the following is true:
. you do not have a separate /homee (obvious);
. you want to convert your /home to ext4 from what it is now (can also be done later).
And yes, in any case backup everything in /home (all user data) and also save the contents of /etc somewhere, it can come handy when you ask yourself: how was this configured in 11.1?

The collection of repositories that you have selected seems somewhat unusual. I hadn’t even heard of gwdg_suse11.1, never mind what use it might have. See How to know which repositories are trash? - openSUSE Forums for a view on what a conventional selection of repositories would look like; if you started from that, and just added the absolutely necessary, I suspect you would have a much better chance of success.