upgrade to 11.2 - filesystem error on boot

Upgraded from 11.1 to 11.2 using GUI (YaST and Wagon)

Machine stops on boot and says:

fsck failed. Please repair manually and reboot. The root file system is currently mounted read-only. To remount it read-write do: bash# mount -n -o remount, rw /
Attention: Only CONTROL-D will reboot the system in this maintenance mode. shutdown or reboot will not work.
Give root password for login:

(so i write it)

(repair filesystem) #

I write: mount -n -o remount,rw /

And then reboot with CONTROL-D.

But I guess this is wrong, as it doesn’t help.

Any help would be much appreciated!

Please try booting to any Linux CD where you can get to a command line. Once there you can run an fsck on your / partition. You won’t be able to unmount / and fsck it once it boots.

#fsck -fy /dev/sda1
(Provided this is your / partition)

Your old Suse 11.1 CD in repair, if you have one, also has some repair tools you can run to correct the filesystem, or just use the 11.1 CD to boot to and then go to the shell and run fsck manually on your the partition(s) you need.


Thank you! Sorry for the long wait.

I’ve booted up an ubuntu linux distro. I have a lot of partitions. 1 though 3 is not related to Linux. GParted tells me this about the rest:

sda4 is listed as extende
sda5 is listed as linux-swap
sda6 as ext3
sda7 as ext3

When I run #fsck -fy /dev/sda4 on sda4, linux replies:

fsck 1.40.8 (13-Mar-2008)
e2fsck 1.40.8 (13-Mar-2008)
fsck.ext2: No such file or directory while trying to open /dev/sda4

The superblock could not be read or does not describe a correct ext2 filesystem.  If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

for sda5:

fsck 1.40.8 (13-Mar-2008)
fsck: fsck.swap: not found
fsck: Error 2 while executing fsck.swap for /dev/sda5

For sda6 :

fsck 1.40.8 (13-Mar-2008)
e2fsck 1.40.8 (13-Mar-2008)
Pass 1: Checking inodes, blocks, and sizes
/dev/sda6: e2fsck canceled.

Also, with openSUSE 1.11 CD live boot, fsck returned:

**linux:/sbin # fsck -fy /dev/sda4**
fsck 1.41.1 (01-Sep-2008)
e2fsck 1.41.1 (01-Sep-2008)
fsck.ext2: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda4
Could this be a zero-length partition?
**linux:/sbin # fsck -fy /dev/sda5**
fsck 1.41.1 (01-Sep-2008)
fsck: fsck.swap: not found
fsck: Error 2 while executing fsck.swap for /dev/sda5
**linux:/sbin # fsck -fy /dev/sda6**
fsck 1.41.1 (01-Sep-2008)
e2fsck 1.41.1 (01-Sep-2008)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/sda6: 196672/1046528 files (2.6% non-contiguous), 1848153/4182916 blocks
**linux:/sbin # fsck -fy /dev/sda7**
fsck 1.41.1 (01-Sep-2008)
e2fsck 1.41.1 (01-Sep-2008)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/sda7: 38867/1553440 files (11.0% non-contiguous), 3108741/6205098 blocks
linux:/sbin #

More info: When I boot with failsafe it also says:

Loading required kernel modules     done
Activating swap-devices in /etc/fstab...
[15.239868] Adding 1357252k swap on /dev/sda5 Priority:-1 extends:1 across:1357452k   failed
blogd: no message logging because /var file system is not accessible

Does anyone know what it is trying to tell me?
What might have happened?
And what might help?

Booted into Linux Live. Mounted sda6 and opened fstab with nano. It loads sda6 as /.

I then unmounted sda6 and ran fsck -fy /dev/sda6. fsck (1.41.1) ran though “pass 1” to “pass 5”, and resulted:

/dev/sda6: 196672/1046528 files (2.6% non-contiguous), 1848153/4182916

What is on sda4? It doens’t look right to me. Opensuse by default needs 3 partitions (swap, root and home) and I think you have them in sda5, sda6 and sda7.

What is the size of sda4?

Can you boot into your windows which I assume you have considering you say partitions 1 to 3 are not related to Linux? Can you access sda4 from there?

Thats right, in fstab, sda5 is loaded as swap, sda6 is as /, sda7 as /home and sda1, the windows partition, as /windows/C.

Im not sure what sda4 is, but it’s 40 GB, and not loaded in fstab. nor does it show up in windows disk management. I think it might be a “gathering partition” for sda5, 6 and 7, since there is a green frame around the linux partitons (5,6,7)in windows disk management.

Sda1 (40 gb) is XP, sda2 (30gb) is OpenSolaris, sda3 (40 gb) is FreeBSD (I went a little nuts when looking for substitute for XP, and havent removed them). The linux partitions (5,6 and 7) adds up to 40 gb. This equals 150 gb which is the disk size.

In fstab:
Dump is set to 1 for sda6 and 7. 0 for the other to. FSCK first runs on sda6 then sda7. Both 6 and 7 have mount options: acl, user_xattr

I’m not the best one to answer this but sounds to me like your partitioning is wrong.

I personally would backup SUSE if possible and do a fresh install. During the partition setup I would remove the partitions with OpenSolaris and Freebsd if you are not using them. Then remove sda4 through 7 so you only have sda1 and loads of free space. Then recreate new partitions for swap (twice your ram would be more than enough), your root with a minimum of 20gb and your home partition.

Your drive should only have 4 partitions on them then. I think the partitioning of your drive the way it is is wrong. Think sda4 is a extended partition with sda5, sda6 and sda7 as logical drives. And by the looks of things SUSE doesn’t like it.

If anyone else want to help, please do. (Swerdna, where are you!)

Quote from wikipedia -> Disk Partitioning

Primary A primary partition contains one file system. In MS-DOS and earlier versions of Microsoft Windows systems, the first partition (C:) must be a primary partition. Some operating systems are not limited in this way; however, this can depend on other factors, such as a PC’s BIOS (see Boot sequence on standard PC for more information).
The “partition type” code for a primary partition can either correspond to a file system contained within (e.g. 0x07 means either an NTFS or an OS/2 HPFS file system) or indicate the partition has a special use (e.g. code 0xBC may mean an Acronis Secure Zone and code 0x82 usually indicates a Linux swap partition). The FAT16 and FAT32 file systems have made use of quite a number of partition type codes over time due to the limits of various DOS and Windows OS versions. Though a Linux operating system may recognize a number of different file systems (ext2, ext3, reiserfs, etc.), they have all consistently used the same partition type code: 0x83 (Linux native).
edit] Extended

An extended partition is a primary partition which contains secondary partition(s). A hard disk may contain only one extended partition; which can then be sub-divided into logical drives, each of which is (under DOS and Windows) assigned additional drive letters.
For example, under either DOS or Windows, a hard disk with one primary partition and one extended partition, the latter containing two logical drives, would typically be assigned the three drive letters: C: for the primary partition, and D: and E: for the two logical drives.
See extended boot record for information on the structure of an extended partition.

So I think you went a bit nuts with the partitioning and as a result you now have a non working Linux :slight_smile:

Again, if there’s a different way of fixing it I would love to know about it but I think a reinstall is the best. You can also make the file system ext4 which should give you a speed boost…

You’re probably right. Stuck in XP for the moment while considering my options.

I can help you out:

sda4 is the extended partition. Same on windows. It contains the logical partitions sda5,6 and 7. Now, as you can see fsck errors out on sda5, the swap space. So there’s something wrong in either the partitioning, the swap space cannot be added, mounted. That’s why this is happening.

This is what you can do:
Boot from the medium you installed from and choose the Repair option. It will do a lot of checks and attempt repairs.

Hope this helps you out. If not, get back to us, the system is installed, fsck runs ok on the other 2 partitions, so AFAICS matters could be solved