Upgrade problem

Hi,

When I try to upgrade my Opensuse 11.4 in HP Pavilion dv6-2180us laptop with zypper dup everythings seems normal at the beginning , but after reboot the system my keyboard , mouse and touchpad did not works in graphical login page , but if I reboot again I could boot system in system d or shell mode and I face with no problem with keyboard.

Also I use below repos from 2 years ago till now and never face with any problem.

| Alias | Name | Enabled | Refresh

—±---------------------------------±---------------------------±--------±-------
1 | Education | Education | Yes | Yes
2 | KDE-Core_packages | KDE-Core packages | Yes | Yes
3 | KDE-Extra | OpenSuse11.4-Src-non-oss | Yes | Yes
4 | KDE-Unstable-Playground | openSUSE-11.4-Debug | Yes | Yes
5 | LibreOffice-Unstable | server:php:applications | Yes | Yes
6 | Mozilla | Mozilla | Yes | Yes
7 | OpenSuse11.4-Src-non-oss_ | Packman Repository | Yes | Yes
8 | Packman Repository | openSUSE:11.4 | Yes | Yes
9 | Pacman_Tumbleweed | openSUSE-11.4-Update-Debug | Yes | Yes
10 | Updates-for-openSUSE-11.4-11.4-0 | LibreOffice-Unstable | Yes | Yes
11 | fwbuilder | Firewall Builder | Yes | Yes
12 | games | openSUSE-11.4-Oss | Yes | Yes
13 | google-chrome | Pacman Tumbleweed | Yes | Yes
14 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | Yes | Yes
15 | openSUSE:11.4 | Wine | Yes | Yes
16 | openSUSE:11.4:Contrib | openSUSE:11.4:Contrib | Yes | Yes
17 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Yes | Yes
18 | openSUSE:Tumbleweed | KDE-Unstable-Playground | Yes | Yes
19 | openSUSE:Tumbleweed:GNOME | openSUSE:Tumbleweed:GNOME | Yes | Yes
20 | repo-debug | VLC-OpenSuse | Yes | Yes
21 | repo-debug-update | repo-debug-update | Yes | Yes
22 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes
23 | repo-oss | KDE-Extra | Yes | Yes
24 | repo-source | openSUSE-11.4-Source | Yes | Yes
25 | server:php:applications | google-chrome | Yes | Yes

Anyone could help me please!!!

On 2011-10-10 07:56, dara-hr wrote:
>
> Hi,
>
> When I try to upgrade my Opensuse 11.4 in HP Pavilion dv6-2180us laptop
> with zypper dup everythings seems normal at the beginning ,

Doesn’t it give you a warning that you have TOOOOO MANY repos enabled?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Next time you post computer output please use CODE tags: Posting in Code Tags - A Guide

Hi,

No it does not give me any error or warning.

Also I’ll use code tags next time :).

TNX!

Also I’m using these repos from 2 years ago , and I never had any problem.

Also If it have any conflict it ask me about during installation process , but I gave no warning during this process.

On 10/10/2011 07:56 AM, dara-hr wrote:
> When I try to upgrade my Opensuse 11.4 in HP Pavilion dv6-2180us laptop
> with zypper dup everythings seems normal at the beginning
> Anyone could help me please!!!

suggest you read and follow the paragraph beginning with “IMPORTANT”
here: http://tinyurl.com/33qc9vu

and review this: http://tinyurl.com/y854wdy

then, probably do a


zypper clean --all
zypper ref
zypper dup

which should set you back to an openSUSE 11.4 as shipped and updated…

but, read my sig caveat first…and wait for a zypper guru (like
Carl/caf4926) to weigh in…

on the other hand if you intentionally ‘upgraded’ to Tumbleweed (the
rolling release which openSUSE 11.4 is not) then forget all of that and
please post in the correct forum: Tumbleweed http://tinyurl.com/3ljwanm

or, if you intentionally wanted to test the experimental/BETA code in
factory, please post to the correct forum for that: Pre-Release/Beta
http://tinyurl.com/2du7r4s

note: the forum you are in (install-boot-login) is for problems when
running a current version of openSUSE (11.3 or 11.4)


DD
Caveat
openSUSE®, the “German Automobiles” of operating systems

You “upgrade” using zypper dup. From the listing I understand that you upgrade to 11.4. Mind to tell from which level you upgraded?

Also I point to the fact that all others above tell you not to have all those repos on when upgradding to a new level. First use only the standard repos to upgrade. See if it is OK. And then add all the extras you seem to need and use them (using switching versions to them where needed, e.g. the Packman one).

TNX my friend!

I’m going to test it!

I’ll back with the result soon :slight_smile:


Cheers,

On 2011-10-10 10:36, dara-hr wrote:
>
> Hi,
>
> No it does not give me any error or warning.

I do not believe you.

I’m sure you got this at the very beginning:


Telcontar:~ # zypper dup
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.

Notice that “zypper dup” is intended to be used to change from one
distribution version to another version. It is not intended for periodical
upgrade of packages - for that you should use “zypper up” or “zypper patch”.

If you have not had problems before, you were just lucky.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2011-10-10 10:56, hcvv wrote:
>
> You “upgrade” using -zypper dup-. From the listing I understand that you
> upgrade to 11.4. Mind to tell from which level you upgraded?

He is using ‘dup’ instead of ‘up’ to keep 11.4 up to date. Wrong usage.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I am thinking the same, but I want prove of it. That is exactly why I ask it this way. After he confessed, we could tell him he uses zypper wrongly. :wink:

Of course I gave this warning at the beginning , but never face with ERROR , or if I face with ERROR or warning during packages installation I could manage them.Also I upgrade my system from OpenSuse 11.3 to 11.4 with zypper dup and from someone told me that it is OK if I use zypper dup all the time instead zypper up , so i have a question is it harmful If I use zypper dup all the time for upgrading or update all of the repos like KDE and … and never use zypper up because If I do I never need to check my repoes distribution for finding the upgrades.

Also Robin I did not want give you a wrong data , it was just kind of misunderstanding , any way thank you all!!! :slight_smile:

To avoid future misunderstandings, allways post complete commands including the prompt, the command and the output. When you ask for help, you should never take it for granted that your interpretation of the situation you have until that point in time is the correct on eand thus it not worth telling. Very many problems can not be solved by the first person because (s)he is working in one direction without seeing any others. That is human, we all suffer from it. It is the reason to ask others, but they should look at the problem without any prejudice. So much about the art of problem solving :slight_smile:

I hope you have now read all about how to upgrade to the next level using zypper dup. The meaning of dup says it all.

And no, you should NOT use dup during the normal life time of the system. It will take the newest version from ANY of the repos. Thus when you specialy have some packages from Packman and want to keep it like that, dup will install a higher level if that appears in the Update repo (or on any of the many repos you have). While up which will only load a newer version from the repo the package was installed from. Or patch to get only the update from the Update repo.

On 2011-10-10 12:16, dara-hr wrote:
>
> Of course I gave this warning at the beginning , but never face with
> ERROR , or if I face with ERROR or warning during packages installation
> I could manage them.

Like your current problem? >:-)

Not all problems give conflicts of packages. Those are easy :-p

> Also I upgrade my system from OpenSuse 11.3 to 11.4
> with zypper dup and from someone told me that it is OK if I use zypper
> dup all the time instead zypper up ,

And you believed it.

The warning zypper dup gives at the start is not an idle warning.

> so i have a question is it harmful
> If I use zypper dup all the time for upgrading or update all of the
> repos like KDE and …

Yes, it can be.

About your problem… I would reinstall from scratch. I simply can not
imagine how to repair it, even less describe a solution in writing.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Dear Friends,

Thank you very much for your regards,
If you let me i’ll update you after reinstall and update bye default repos.

Cheers!

I wonder if such a hazardous repository list is the result of one-click installers. For technically inexperienced users a kind of app-center would better fit the needs (if not yast is enough) .

The main problem that you have is that **you have mixed up repos from 11.4, Tumbleweed and Factory** from what i see. To solve the problem stick to a openSUSE version, personally i suggest you disable all the repos from Tumbleweed and Factory and then if you are lucky maybe sudo zypper dup may solve your issues.

Hi,

I edit the repository and everything is OK now , just I have a question again , why when I upgrade from openssuse 11.4 to Tumbleweed only with Tumbleweed and Tumbleweed packman repository my mouse and keyboard did not work in login page???I really interesting to upgrade my system to Tumbleweed and face with this problem!!!Could you please help me!!!

On 10/15/2011 08:26 PM, dara-hr wrote:
>
> why when I upgrade from openssuse 11.4 to Tumbleweed only with
> Tumbleweed and Tumbleweed packman repository my mouse and keyboard did
> not work in login page???I really interesting to upgrade my
> system to Tumbleweed and face with this problem!!!Could you please help
> me!!!

tumbleweed questions should go to the tumbleweed forum where the
tumbleweed gurus receive and answer tumbleweed questions:
http://tinyurl.com/69mj3zj


DD
openSUSE®, the “German Automobiles” of operating systems

I agree with DenverD.

We appently solved your problem by bringing you back to openSUSE 11.4 proper.

When you think that you like/need Tumbleweed then you should go to the Tumbleweed subforum here and first read he first sticky thread there. When you then still think you should try Tumbleweed and have a questionm then please ask there.

I think this thread is solved.