Upgrade problem from 11.4 to Tumbleweed


Why when I upgrade from openssuse 11.4 to Tumbleweed only with Tumbleweed and Tumbleweed packman repository my mouse and keyboard did not work in login page???I really interesting to upgrade my system to Tumbleweed and face with this problem!!!Could you please help me!!!

We only help, if there are Details like Logfiles, Error Messages and Hardware Description and at a minimum 20 “!”.

my laptop is HP pavilion dv6-2280us , also I just face with 1 ERROR during installation and it is something about xcfe lang package.

I’m so sorry but as I told my keyboard , mouse and touchpad did not work so I don’t have any control on my system , so I can’t send more about this issue , also I don’t have SHELL or systemd in Grub session.

Also I face with this issue 3 days ago , so I update my system via OpenSuse 11.4 DVD and then upgrade it only with Tumblweed and Tumbleweed all Packman repos , also befor this step I tried to upgrade my system via mentioned repos plus opensuse basic official repos but I faced with this issue again! :frowning:

On 2011-10-15 21:26, dara-hr wrote:
> Hi,
> Why when I upgrade from openssuse 11.4 to Tumbleweed only with
> Tumbleweed and Tumbleweed packman repository my mouse and keyboard did
> not work in login page???I really interesting to upgrade my
> system to Tumbleweed and face with this problem!!!Could you please help
> me!!!

Tumbleweed is derived from the factory version. It is more stable than
factory, but less than 11.4, for example.

IMO, it is not a version appropriate for novices.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

And what I have to do? I can’t work with my laptop yet :frowning:

On 10/16/2011 07:56 AM, dara-hr wrote:
> And what I have to do? I can’t work with my laptop yet :frowning:

in a different thread (yesterday) someone had helped you get a well
working 11.4 system…

you wrote: I edit the repository and everything is OK now"

and then you immediately started asking questions on how to move to
Tumbleweed, why? it seems to me that you should have stopped messing
with your system when you got back to a working system…spend some time
with that (working system)…it is FAR superior and more advanced than
95% of the systems in use today…and pretty stable if you treat it right…

personally, i think you do not seem to have the Linux or openSUSE
experience to move!

the moderator (in that other forum) wrote to go to the Tumbleweed forum
and “first read he first sticky thread there.”, i wonder did you??

if you did you sure didn’t follow the bread crumbs there…because that
sticky includes a link to “HowTo Upgrade openSUSE 11.4 to Tumbleweed”
and the second line in that article is:

Warning: Tumbleweed can be a challenge for new users: The system is
gradually and perpetually upgraded with new RPMs appearing almost daily
in the Tumbleweed repositories. Zypper is the recommended tool for
keeping your Tumbleweed distro up to date. You will receive messages
from zypper regarding dependencies where you will make choices. If that
could make you stressed, don’t install Tumbleweed.

which is exactly where you should have STOPPED.

or, if you were intent on continuing you should have READ the
instructions which would have answered all of your questions in your
just earlier thread in which you asked “I am new to Tumblewee and
confused with repositories that I should use”

so, to answer your question at the top of this note: And what i have to
do? i submit:

-wait until you have more experience, and are better able to deal with
‘routine’ administrative duties

-when it is suggested for you to read provided information, do so

-follow provided information

and, to return to a working system you should again follow the
instructions you were given before in

it is a steep learning curve, no doubt…go more slowly…it is not as
easy as enjoying cake.

openSUSE®, the “German Automobiles” of operating systems

Hi Denver,

Thanks for you suggestion, I just need explain something for you , I used OpenSuse from 11.1 and at this time that I write this post for you I’m Redhat linux and also VMWare virtualization Expert and working at MTN Datacenter , so maybe I’m new in this forum and I don’t have many posts but usually I know what I am doing.

Also I completely read that article and I completely follow the instruction , and I think you face with a bug , also I just thought like many forums that I’m a membership we can communicate more …

Now if anyone can help me in this case It will be appreciated , and if not I’m going to close this thread , any GURU???

Also forgive me but I’m little angry because of this problem :slight_smile:

TNX guys! :slight_smile:

I have the same problem with my desktop PC, no keyboard or mouse on startup. What I had to do was unplug them then replug them and they worked, not much help for a laptop I’m afraid :frowning: but external keyboard and mouse may just kick things back into life so you can get to the logs.


If this would happen to me, first though would be: “can I ssh into the machine? I need the log files to see what’s wrong…”. Did an upgrade to Tumbleweed on a friend’s machine yesterday, no such issues at all, in fact it was a very smooth operation, done only because he wants a rolling release that can deal with most recent hardware. Which makes me wonder how you upgraded to Tumbleweed.


I upgraded with Tumbleweed core and packman , also main opensuse repoes .and zypper dup.

I guess my network service is down because I can’t ssh to the machin :frowning: , but let me downgrade it and upgrade again , then I will send a log file , just as I told i,m expert in redhat so I can’t find any /var/log/messeges , could you please tell me where is the log file?

TNX a lot!

You should have /var/log/messages. And sshd is not on by default, switch it on when running 11.4

Hi, I think I’m having a similar problem. When I boot KDE after recent zypper dup (I’ve been on Tumbleweed for a while), I must unplug/ replug the (Logitech) mouse & keyboard, and I can’t seem to correct the issue. I also can’t read var/log/messages, it’s listed as “unknown” file type and I can’t open it.

Here’s Xorg.0.log instead: SUSE Paste

(There also seems to be an issue with the audio backend, but that’s another issue…)

Please make sure that you assign the same priority number to all of your repositories.

What version of KDE did you end up with after your “recent zypper dup”? It would probably have caused a downgrade to KDE 4.6.0 (sourced from 11.4 repo).

What audio backend?

regarding kbd and mouse problems, looks like it’s being worked on:
an hour ago greg k-h reported this on the mailing list:

Right now tumbleweed will want to downgrade your version of udev, but
not your version of libudev. This will cause bad problems for your
system (audio output not working, keyboard not working in xorg, etc.)

I’m working right now to resolve this, please be patient…

greg k-h

then half hour ago he reported this:

Ok, this is now fixed, if anyone else has problems, please let me know.

greg k-h

So might be worth another run of zypper dup.

Hmm that was a lucky break here. There was nothing on the mailing list when I saw a few non-KDE related downgrades and decided it was best to leave them alone for today. It doesn’t always pay to zypper dup. :smiley:

Thanks conused and swerdna; and hat’s off to greg k-h! By the time I was able to get back to my desktop, the dependencies seem to be resolved after immediately “zypper dup”.


I’ve been waiting a couple of weeks now. I get an issue with kdebas4-runtime like this:

Problem: kdebase4-runtime-4.6.5-4.7.x86_64 requires oxygen-icon-theme >= 4.6.5, but this requirement cannot be provided
Problem: kaffeine-1.2.2-1.pm.1.7.x86_64 requires kdebase4-runtime >= 4.6.5, but this requirement cannot be provided

and assume it’s just part of the general kde build problem. I’m not dupping until I see on the mailing list for a clearance of sorts to come through from greg k-h


I downgrade my system to opensuse 11.4 with only DVD repository , and now going to upgrade it to Tumbleweed , please wait a moment for me dude!!!

I’ll inform you about the result ASAP.