Upgrade & new installing packages is causing a system issue (blocking internet)


I’m running Tumbleweed and tried to do a routine update today. It turned out anything but. I ran the update as usual (using sudo zypper dup) and allowed it to do the updates. I restarted and had a warning that the OS wasn’t connected to the internet (even though I checked and made sure it was connected via wired, then also wireless as a secondary method). Though the OS showed it was connected in the taskbar area and gave the IP addresses, I couldn’t connect to any webpage or urls for anything either via a browser or via zypper.

I used snapper to roll back and got things working again. I figured I’d wait a couple of days to do the full update again but I needed to install docker because I have been working towards installing Homebridge. I tried via zypper first but got some dependencies that weren’t being installed so I didn’t install and decided to look at the dependencies via YaST. Things seemed to install OK but I also needed to add git-core and podman. When I tried to add these on, I got a number of errors saying that there were problems connecting to the servers (like I wasn’t connected to the internet again). I rebooted and got the same error that I wasn’t online (though I was). I did another rollback with snapper but now I don’t know what to do. It seems that something odd may be happening with these installs and I’m not quite sure what to do. I’ve not had any issues like this previously (well, once or twice I’ve had issues when trying to upgrade but waiting till the packages were updated to the next version has always sorted it out). This seems different since trying to install new packages without the upgrade also seemed to cause issues.

Any advice and help would be amazing. Thanks so much. :slight_smile:

What is output from:

cat /etc/resolv.conf
ip a
inxi -Nayz

Duped here. No problems whatsoever:

Operating System: openSUSE Tumbleweed 20210330
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.6-1-default
OS Type: 64-bit
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700K CPU @ 4.00GHz
Memory: 31.3 GiB of RAM
Graphics Processor: Radeon RX550/550 Series

Beware of additional repos. My list is:

**erlangen:~ #** zypper lr -uEP 
#  | Alias               | Name                        | Enabled | GPG Check | Refresh | Priority | URI 
 4 | Packman             | Packman                     | Yes     | (r ) Yes  | Yes     |   90     | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/ 
12 | openSUSE-20191106-0 | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/oss/ 
17 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/non-oss/ 
19 | repo-update         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/tumbleweed/ 
 3 | BellSoft            | BellSoft Repository         | Yes     | (r ) Yes  | Yes     |  100     | http://yum.bell-sw.com/ 
 6 | chrome              | chrome                      | Yes     | (r ) Yes  | Yes     |  100     | http://dl.google.com/linux/chrome/rpm/stable/x86_64 
10 | jalbum              | jalbum                      | Yes     | (  ) No   | Yes     |  100     | http://jalbum.net/download/software/yumrepo/ 
11 | myrepo              | myrepo                      | Yes     | (  ) No   | Yes     |  100     | dir:/home/karl/Downloads/myrepo 
**erlangen:~ #**

[QUOTE=mrmazda;3018200]What is output from:

cat /etc/resolv.conf
ip a
inxi -Nayz


@mrmazda, Thanks so much for responding. Sorry it’s taken me a couple of days to get the info back. I’ve tried upgrading again and had to roll back another couple of times. The internet connection has also gone briefly when I wasn’t updating.

I did spend some time with the system after an upgrade when the internet wouldn’t work. I checked out everything I could think of:
Firewall - inactive/off
VPN - not in use
IP addresses showing up correctly in the info section
disabled Ethernet, used WiFi, disabled WiFi, tried ethernet
disabled IPV6 on both connections since my provider currently doesn’t support it
Checked on my router app and each time the Ethernet or WiFi connections are properly connected and the correct static IP addresses are assigned (from within our local router - not a true static IP from our internet provider).
The router app does show some internet usage from this device but when I try to access a webpage via Firefox I get nothing.

I did go back through my repos to see if there were any there shouldn’t be. There were three that looked correct but seemed to have exact duplicates. I couldn’t find anything at all different about these three so I disabled one of each of the duplicates. I can delete if that happens to work.

I also did the output of the commands that you suggested. Here is the info I got back (was trickier than I anticipated to get them off the computer without internet…oh how we rely on it now!). These were run while the computer was connected to the internet (as it has always been) but NOT putting through any of the info in or out:

me@localhost:~$ cat /etc/resolv.conf### /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
### autogenerated by netconfig!
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
# or disable DNS configuration updates via netconfig by setting:
# See also the netconfig(8) manual page and other documentation.
### Call "netconfig update -f" to force adjusting of /etc/resolv.conf.
me@localhost:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 94:c6:91:a2:35:1e brd ff:ff:ff:ff:ff:ff
    altname enp0s31f6
3: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 5c:5f:67:4a:4f:b1 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlp0s20f3
       valid_lft 42242sec preferred_lft 42242sec
me@localhost:~$ inxi -Nayz
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel 
  port: 4000 bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280 
  Device-2: Intel Ethernet I219-V driver: e1000e v: kernel port: efa0 
  bus-ID: 00:1f.6 chip-ID: 8086:15be class-ID: 0200 

Any thought or info you might spot in this would be amazing. I really appreciate your help. Thank you!

The main thing I see is this thread would have been much better started in the networking forum, where more expertise should be expected for your situation. I am familiar with neither NetworkManager nor any form of wireless, as I only deal with static IP configurations, thus nothing net needing any kind of “management”.

Two other things I see are 1-no IP is being assigned to your NIC, and 2-a possible need for firmware installation for your Intel NIC, either kernel-firmware-intel and/or kernel-firmware-network.

One thing I suggest to try is posting back here or in a new networking thread content from /etc/sysconfig/network/ifcfg-e* and /etc/systemd/network/, locations where static configurations live, and possibly automatics as well. Also try editing /etc/resolv.conf to change nameserver to nameserver, then execute systemctl restart network before attempting internet access again. One handy way to test internet is speedtest-cli, if it is working for you. I get python errors when I try it in 15.2. traceroute and ping are also simple tests. There’s no need for GUI or web browser to see whether zypper should be working.