Upgrade issue with mismatched rpm check sums

Downloaded cd. Checked ISO with sha. Reported ok with 14 mismatched lines etc.
I tried the upgrade (from 15.1). At some point I received errors of checksum requested does not match check sum received, but that it was signed by the repository. I chose “ignore”. After a few of these I aborted and tried Installation with the same result. I aborted again. This time I chose installation without using the On-line option. 15.2 installed, but I noticed K3B was not installed. I don’t know what other packages may not have installed.

Should I have just let the upgrade run I ignore all the mismatched checksums?

Hi and welcome to the Forum :slight_smile:
The 14 mismatched lines can be ignored, that’s just the pgp lines. Likely k3b is not on the install medium, just install manually and you should be fine.

Thank you.

You’ll probably want K3b and any other multimedia apps from Packman, anyway and not from the OSS so you get full codecs support.


Waitng to make sure updates are done before adding packman repo. Thanks.

Installation with USB thumb drive is much faster and reliable than with optical media.

Thank you. I will keep that in mind.